Announcement

Collapse
No announcement yet.

Cyrillic entities

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cyrillic entities

    Hello,

    I have recently installed OX hyperion and got the following problem, if incoming email contains cyrillic 'o' or cyrillic 'm' OX displays it as "<" and ">". It seems there is some error in the html entities converter. Can anybody direct me to the part of the code where it can be coded. Any other suggestions are wellcome.
    Thank you in advance.

    The OX has been installed on debian stable with java6

  • #2
    Hello.

    I have the same problem.
    System installed on debian 2.6.18 and Java 1.5.0
    OX Hyperion installed from the official Open-Xchange CVS.

    Thank you in advance.

    Comment


    • #3
      Could you post the source (RFC 822) of an example message?

      Comment


      • #4
        In source of message is all right.

        Code:
        Return-Path: <xxx@xxx.ru>
        Received: from xxxx.xxxxx.ru ([unix socket])
        	 by mail (Cyrus v2.2.13-Debian-2.2.13-10) with LMTPA;
        	 Thu, 28 Feb 2008 14:27:18 +0300
        X-Sieve: CMU Sieve 2.2
        Received: from aps.mark-itt.ru (aps.mark-itt.ru [217.14.192.43])
        	by xxxx.xxxxx.ru (Postfix) with ESMTP id 7D9DF2201DC
        	for <x.xxxxx@xxxxx.ru>; Thu, 28 Feb 2008 14:27:03 +0300 (MSK)
        X-Spam-Status: No, hits=-100.9 required=5.0
        Received: from [77.238.226.137] (account xxx@xxx.ru)
          by aps.mark-itt.ru (CommuniGate Pro WEBUSER 5.1.14)
          with HTTP id 91345745 for x.xxxxx@xxxxx.ru; Thu, 28 Feb 2008 15:33:42 +0400
        From: "Konstantin N. Volkov" <xxx@xxx.ru>
        Subject: =?koi8-r?Q?=CD=CF=FE=E3?=
        To: x.xxxxx@xxxxx.ru
        X-Mailer: CommuniGate Pro WebUser v5.1.14
        Date: Thu, 28 Feb 2008 15:33:42 +0400
        Message-ID: <web-91345745@aps.mark-itt.ru>
        MIME-Version: 1.0
        Content-Type: text/plain;charset=koi8-r
        Content-Transfer-Encoding: 8bit
        
        ёйцукенгшщзхъфывапролджэячсмитьбю
        ЁЙЦУКЕНГШЩЗХЪФЫВАПРОЛДЖЭЯЧСМИТЬБЮ
        but in OX MailView window it looks different. In "subject" this letters looks correct.
        If message was created in html-mode, it's all right.

        Thanks a bunch.
        Attached Files

        Comment


        • #5
          This is a known bug and it has already been fixed in CVS.

          Comment

          Working...
          X