Announcement

Collapse
No announcement yet.

Problems when trying to add aliases

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems when trying to add aliases

    Hi

    I got a strange problem when trying to add an alais/additional email to an user, i got the following errors:

    Code:
    cindy:/opt/open-xchange/sbin# /opt/open-xchange/sbin/changeuser -A oxadmin -P XXXX -c 1 -i 8 --email1 sh@maildomain.ch -e kenshi@maildomain.ch --defaultsenderaddress kenshi@maildomain.ch
    user 8 in context 1 could not be changed:
    Server response:
     email1 not equal with primarymail!
    What am i doing wrong?

  • #2
    Hi Kenshi,

    did you try to split this process to two parts?

    1. Add a alias
    2. Set the default sender address

    Greetings

    Comment


    • #3
      Hi Martin,

      yes i did:

      Code:
      cindy:/opt/open-xchange/sbin# /opt/open-xchange/sbin/changeuser -A oxadmin -P XXXX-c 1 -i 8 -a sh@maildomain.ch
      user 8 in context 1 could not be changed:
      Server response:
       primaryMail, Email1 and defaultSenderAddress must be present in set of aliases.

      Comment


      • #4
        No ideas? :/

        Comment


        • #5
          Well, no idea to override this issue, but i suppose it's a bug. I'll reproduce this on my own cvs ox and will report a bug if it is one.

          Thanks for reporting!

          Comment


          • #6
            I know this is an old thread but I was going through these trying to solve the same problem. The error message finally made me realize how to do it - you submit a list of aliases and you need to make sure the existing primary email, email1 (if exists) and default sender are all in this list.

            so if there is just a primary (also def. sender) do as the second example above but -a primaryemail@maildomain.ch,newalias@maildomain.ch

            Anyway, this worked for me.

            Comment

            Working...
            X