Announcement

Collapse
No announcement yet.

Problems with open-xchange-gui

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Xalan is an XSLT processor which supports XSLT 1.0. The GUI requires XSLT 2.0 and uses Saxon to process it. The error was that Ant chooses the wrong XSLT processor when both are available in the classpath.

    Comment


    • #32
      Hi

      on gentoo moved /usr/share/xalan/lib/xalan.jar away before compiling open-xchange-gui and it works.

      Installation is now complete and the gui works.

      David
      Last edited by lenda; 03-06-2007, 05:17 PM.

      Comment


      • #33
        @lenda

        Great!

        Please provide a short documentation what you installed, which USE-flags and so on. We have some experienced Gentoo guys here, too who will review it so we can create official documentation together with you

        Thanks
        Daniel

        Comment


        • #34
          @Daniel Halbe
          Just followed the Installation-Docs. Tested open-xchange on my privat computer and changed no USE-flags.
          I will check the installation on a fresh gentoo

          Ok... quick and dirty!!!

          -> /etc/conf.d/apache2: APACHE2_OPTS="... -D JK"
          -> /etc/apache2/jk-workers.properties: not changed
          -> /etc/apache2/modules.d/88_mod_jk.conf: added "jkMount /ajax/* ajp13" and "jkMount /servlet/* ajp13"
          -> /etc/imapd.conf: see Inst-Docs
          -> /etc/pam.d/imap: see Inst-Docs (just the two entrys...)

          compile open-xchange with the parameters in the Docs
          compile open-xchange-gui with -Dhtdoc=/var/www/localhost/htdocs/open-xchange (before compiling rename /usr/.../xalan.jar to something else, compile, rename it back to xalan.jar)

          start open-xchange-admin and open-xchange

          thats for me... but will check it on a fresh install...

          David

          Comment


          • #35
            Originally posted by lenda View Post
            @Daniel Halbe
            Just followed the Installation-Docs. Tested open-xchange on my privat computer and changed no USE-flags.
            But what about the USE-flags for cyrus, apache2, mysql, ...


            Daniel

            Comment


            • #36
              I hope someone can also help me...

              when I compile the gui I recieve the following error-message

              Code:
              Buildfile: build.xml
              
              css:
                   [xslt] Processing /root/ox/open-xchange-gui/style.xml to /root/ox/open-xchange-gui/build/border.css
                   [xslt] Loading stylesheet /root/ox/open-xchange-gui/css.xsl
              
              BUILD FAILED
              /root/ox/open-xchange-gui/build.xml:57: javax.xml.transform.TransformerFactoryConfigurationError: Provider net.sf.saxon.TransformerFactoryImpl not found
              I try to install OX on ubuntu 6.10

              thanks, orlando

              Comment


              • #37
                Originally posted by oprocopio View Post
                I hope someone can also help me...

                when I compile the gui I recieve the following error-message

                Code:
                Buildfile: build.xml
                
                css:
                     [xslt] Processing /root/ox/open-xchange-gui/style.xml to /root/ox/open-xchange-gui/build/border.css
                     [xslt] Loading stylesheet /root/ox/open-xchange-gui/css.xsl
                
                BUILD FAILED
                /root/ox/open-xchange-gui/build.xml:57: javax.xml.transform.TransformerFactoryConfigurationError: Provider net.sf.saxon.TransformerFactoryImpl not found
                I try to install OX on ubuntu 6.10

                thanks, orlando
                This problem has been already posted here
                http://www.open-xchange.com/forum/sh...?p=409#post409

                Comment


                • #38
                  thank you for your answer.

                  I have downloaded this file and copied saxon8.jar to /opt/open-xchange/lib.

                  still the same error.

                  I have also updated to ant 1.7

                  do I forgot something??

                  orlando

                  Comment


                  • #39
                    I build the file with:

                    Code:
                    ant -lib /opt/open-xchange/lib/ deploy
                    (maybe a error in the installinstructions?)

                    now seems everything is ok.

                    orlando

                    Comment


                    • #40
                      Originally posted by oprocopio View Post
                      I build the file with:

                      Code:
                      ant -lib /opt/open-xchange/lib/ deploy
                      (maybe a error in the installinstructions?)

                      now seems everything is ok.

                      orlando
                      No, the install instruction is OK. It seems like you already have any other XSLT jar/installation in your classpath which conflicts with the saxon package.
                      Last edited by Stefan Preuss; 03-13-2007, 06:03 PM.

                      Comment

                      Working...
                      X