Announcement

Collapse
No announcement yet.

Unable to start daemon because of start-stop-daemon

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to start daemon because of start-stop-daemon

    Hello,

    Moving foward in the installation of OX, i'm stoped by the daemon statinr script which use the SysVInit prg 'start-stop-daeaon' with an option that is not recognized by my installed version of start-stop-daemon.

    I'm running a SuSE 10.1 Linux with a start-stop-daemon v. 0.3.1 which comes from with my SysVInit package 2.86.47.

    I'm not able to find a more recent package of SysVInit and neither a stand alone package for the latest start-stop-daemon.

    Is there any way to upgrade my start-stop-dameon prgm with the appropriate version for start OX or on the other hand a turn arround fix for the start script /opt/open-xchange/etc/admindaemon/oxfunctions.sh ?

  • #2
    but

    Code:
    & sh /etc/init.d/openexchange-admindaemon
    works?
    (maybe the file name a bit different)

    Comment


    • #3
      The script failed because of one of the argument (--background). It happens that another argument is not recongnized : --make-pidfile

      /etc/init.d/open-xchange-admin start
      Starting Open-Xchange Admin Daemon: start-stop-daemon: unrecognized option `--background'
      Try `start-stop-daemon --help' for more information.

      Then running start-stop-daemon --help gives me :

      start-stop-daemon for Debian Linux - small and fast C version written by
      Marek Michalkiewicz <marekm@i17linuxb.ists.pwr.wroc.pl>, public domain.
      version 0.3.1, 1996-07-19

      Usage:
      start-stop-daemon -S|--start options ... -- arguments ...
      start-stop-daemon -K|--stop options ...
      start-stop-daemon -H|--help
      start-stop-daemon -V|--version

      Options (at least one of --exec|--pidfile|--user is required):
      -x|--exec <executable> program to start/check if it is running
      -p|--pidfile <pid-file> pid file to check
      -u|--user <username>|<uid> stop this user's processes
      -n|--name <process-name> start/stop processes with this name
      -s|--signal <signal> signal to send (default 15)
      -t|--test test mode, don't do anything
      -o|--oknodo exit status 0 (not 1) if nothing done
      -q|--quiet | -v, --verbose

      Exit status: 0 = done 1 = nothing done (=> 0 if --oknodo) 2 = trouble

      Comment


      • #4
        Check start-stop-daemon

        You are working with debian. That's fine. We have to check where your start-stop-daemon comes from:

        Code:
        debian:~# whereis start-stop-daemon
        start-stop-daemon: /sbin/start-stop-daemon /usr/share/man/man8/start-stop-daemon.8.gz
        
        debian:~# dpkg -S /sbin/start-stop-daemon
        dpkg: /sbin/start-stop-daemon
        
        debian:~# dpkg --status dpkg | grep Version
        Version: 1.13.24
        "whereis" gives you where the executable start-stop-daemon is located and "dpkg -S" on the executable gives you which package installes start-stop-daemon and then we check the version of this package. Please provide this output on your debian system.

        Which version of debian do you use? Stable, Testing, Sarge, Etch?

        Regards...

        Comment


        • #5
          My system don't use start-stop-daemon (it's SuSE, not Debian) even if an old version exist in my /sbin directory.

          With SuSE, the dameons are started with startproc in the /etc/rc.d directories.

          I tried to convert the start-proc-dameon call into a startproc call in the ox_start_daemon() function but I can't find the name of the daemon to start in the call to start-proc-dameon there ???

          Comment


          • #6
            Originally posted by genielog View Post
            Hello,

            Moving foward in the installation of OX, i'm stoped by the daemon statinr script which use the SysVInit prg 'start-stop-daeaon' with an option that is not recognized by my installed version of start-stop-daemon.

            I'm running a SuSE 10.1 Linux with a start-stop-daemon v. 0.3.1 which comes from with my SysVInit package 2.86.47.
            ?
            The provided init scripts currently only work on Debian.
            Porting to other systems like SUSE should not be very hard.
            You can use /etc/init.d/skeleton and the Debian script as template to build your own one.

            Comment


            • #7
              start-stop-daemon on centos

              I didnt get to start the admin damon on my centos box cause of the start-stop-daemon, this is how I did it on my centos box

              I downloaded this tar archive

              http://developer.axis.com/download/d..._9_18-1.tar.gz

              unpacked it
              tar zxvf apps-sys-utils-start-stop-daemon-IR1_9_18-1.tar.gz
              cd apps/sys-utils/start-stop-daemon-IR1_9_18-1/

              gcc start-stop-daemon.c -o start-stop-daemon

              Then I copied the newly created start-stop-daemon binary to /usr/sbin/
              Then I was able to start the daemon with the script

              /etc/init.d/open-xchange-admin start

              Hope this helps others non debian / ubuntu users

              Tronn

              Comment


              • #8
                some more start-stop-daemon issues

                Originally posted by Carsten Hoeger View Post
                The provided init scripts currently only work on Debian.
                Hm, do they? From my knowledge, "start-stop-daemon" does not understand
                '--group'

                Instead, '--chuid user:group' (=> '--chuid open-xchangepen-xchange') has to be used. Imo.

                Another bummer - at least on SuSEs non-root is not allowed to create a pid in /var/run - so this fails. A 'more compatible' workaround would be to create a /var/run/openexchange or similar, owned by "open-xchangepen-xchange", created during installation...

                Another "feature request" for the start script: Probably a number of people will have several JSEs installed - often with (some older) version usually "found" by your 'which java' in ox_set_JAVA_BIN.
                Wouldn't it be more flexible (and less hardcoding) to use something like "$JAVA_HOME/bin/java"?
                Afaik there even is some "standard" named "JAVA_BINDIR"...


                Jan

                Comment


                • #9
                  Originally posted by jleg View Post
                  Hm, do they? From my knowledge, "start-stop-daemon" does not understand
                  '--group'

                  Instead, '--chuid user:group' (=> '--chuid open-xchangepen-xchange') has to be used. Imo.


                  Jan
                  Well, exactly those scripts are already in use on Sarge and Ubuntu Server 6.06 LTS.

                  Comment

                  Working...
                  X