Announcement

Collapse
No announcement yet.

apache2 not starting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • apache2 not starting

    Hi,
    I followed your excellent howto.
    When starting apache2 it drops out with
    "Syntax error on line 1 of /etc/apache2/conf.d/ox.conf:
    Invalid command 'JkWorkersFile', perhaps misspelled or defined by a module not included in server configuration"

    Somehow mod_jk is not loaded by apache2, but:
    libapache2-mod-jk (v.1.2.18-3etch1) is installed and mod_jk.so is in /usr/lib/apache2/
    JkWorkersFile in ox.conf is pointing to /etc/libapache2-mod-jk/workers.properties.

    Am I missing something? Is the module to be included somewhere in apache-configs?

    [edit] there is no jk.load in /etc/apache2/mods-enabled/
    how do I get it? [/edit]

    Thanks
    Aszrael
    Last edited by Aszrael; 08-10-2007, 02:15 PM.

  • #2
    Hi,

    to use mod_jk the module has to be loaded by apache2, this seems to be distribution specific, maybe there exists a how-to for your distribution?

    Comment


    • #3
      a2enmod lists available apache modules, choose your mod_jk, restart Apache2 and then should everything be all right.

      Comment


      • #4
        thanks for your extremely quick reply.
        I found the answer:
        # a2enmod jk
        did the trick for me on debian/etch
        Maybe this could be added to Open_Xchange_Installation.

        Thanks a lot
        Aszrael

        Comment


        • #5
          Hi,

          i installed a dozen machines with Hyperion on Debian Etch and mod_jk worked on every default install... *confused*

          Comment

          Working...
          X