Announcement

Collapse
No announcement yet.

Problem with saslauthd on debian

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with saslauthd on debian

    Hi,

    I use debian installer on fresh install, and I get this error when I restart saslauthd :

    * No run directory defined for , cannot stop
    * No run directory defined for , cannot start

    saslauthd can't start, an idea ?

    Here my /etc/default/saslauthd file

    START=yes
    MECHANISMS="pam"

    Can you help me ?

  • #2
    It seems that your saslauthd is not able to create any pid / socket file during start/stop
    check for pid file in "/var/run/saslauthd" !!!



    Originally posted by brouanet View Post
    Hi,

    I use debian installer on fresh install, and I get this error when I restart saslauthd :

    * No run directory defined for , cannot stop
    * No run directory defined for , cannot start

    saslauthd can't start, an idea ?

    Here my /etc/default/saslauthd file

    START=yes
    MECHANISMS="pam"

    Can you help me ?

    Comment


    • #3
      Hi,

      ls -al /var/run/saslauthd/
      total 8
      drwxr-xr-x 2 root sasl 4096 2007-10-15 08:59 .
      drwxr-xr-x 3 root root 4096 2007-10-15 08:59 ..

      there is nothing in the directory.

      Comment


      • #4
        I think here is the problem ..
        That .pid file should exist for every daemon running ...
        This is mine :

        -rw------- 1 root root 0 2007-10-13 09:38 cache.flock
        -rw------- 1 root root 945152 2007-10-13 09:38 cache.mmap
        srwxrwxrwx 1 root root 0 2007-10-13 09:38 mux
        -rw------- 1 root root 0 2007-10-13 09:38 mux.accept
        -rw------- 1 root root 5 2007-10-13 09:38 saslauthd.pid

        Originally posted by brouanet View Post
        Hi,

        ls -al /var/run/saslauthd/
        total 8
        drwxr-xr-x 2 root sasl 4096 2007-10-15 08:59 .
        drwxr-xr-x 3 root root 4096 2007-10-15 08:59 ..

        there is nothing in the directory.

        Comment


        • #5
          Problem with saslauthd on debian

          Hi,
          I had the same problem.
          It was because of a wrong value of OPTIONS in /etc/default/saslauthd.

          With: OPTIONS="-r" I had the following error message: "saslauthd* No run directory defined for salsauthd, not starting" when running "/etc/init.d/saslauthd restart"

          Correct value is: OPTIONS="-c -r -m /var/run/saslauthd"
          Now saslauthd is restarting without any error.

          Cheers,
          Remy

          Comment

          Working...
          X