Announcement

Collapse
No announcement yet.

Problem with OXInstaller

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with OXInstaller

    Hi community.

    I've just found OX and want to apply it on my server.
    I've used the installation script from http://213.239.220.146/~mbraun/ox/debian_etch/
    but OX won't be installed on my Debian Etch system, why?
    The error messages:

    [javac] final int groupID = IDGenerator.getId(context_ID, com.openexchange.groupware.Types.PRINCIPAL, con);
    [javac] ^
    [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXGroupMySQLStorage.java:350: cannot find symbol
    [javac] symbol : variable IDGenerator
    [javac] location: class com.openexchange.admin.storage.mysqlStorage.OXGrou pMySQLStorage
    [javac] final int groupID = IDGenerator.getId(context_ID, com.openexchange.groupware.Types.PRINCIPAL, con);
    [javac] ^
    [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXGroupMySQLStorage.java:355: package com.openexchange.groupware does not exist
    [javac] gid_number = IDGenerator.getId(context_ID, com.openexchange.groupware.Types.GID_NUMBER, con);
    [javac] ^
    [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/storage/mysqlStorage/OXGroupMySQLStorage.java:355: cannot find symbol
    [javac] symbol : variable IDGenerator
    [javac] location: class com.openexchange.admin.storage.mysqlStorage.OXGrou pMySQLStorage
    [javac] gid_number = IDGenerator.getId(context_ID, com.openexchange.groupware.Types.GID_NUMBER, con);
    [javac] ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 100 errors

    BUILD FAILED
    /usr/src/open-xchange-admin/build.xml:199: Compile failed; see the compiler error output for details.

    Total time: 2 seconds

    Building Open-Xchange Groupware GUI...

    BUILD SUCCESSFUL
    Total time: 10 seconds

    Executing oxinstaller...
    awk: cmd. line:1: fatal: cannot open file `/opt/open-xchange/etc/admindaemon/ox-admin-scriptconf.sh' for reading (No such file or directory)
    awk: cmd. line:1: fatal: cannot open file `/opt/open-xchange/etc/groupware/ox-scriptconf.sh' for reading (No such file or directory)
    ./hyperion-debian_etch.sh: line 377: /opt/open-xchange/sbin/oxinstaller: No such file or directory

    Creating startup scripts... done.

    Creating Groupware user... ./hyperion-debian_etch.sh: line 390: /opt/open-xchange/sbin/createuser: No such file or directory
    ./hyperion-debian_etch.sh: line 392: /etc/init.d/open-xchange-admin: No such file or directory
    Open-Xchange Groupware Daemon: /opt/open-xchange/etc/groupware/oxfunctions.sh missing, exiting

    Please help me.

    Thanks

    sdh82

  • #2
    I'll take a look at it...

    Comment


    • #3
      Thanks for your response.
      Gruß aus Stuttgart

      Comment


      • #4
        Hi,

        you're right, installation from the latest cvs sources is broken right now as enormous changes are applied at the moment. This is no issue caused by the installer but i modified the installer to use the sourcecode from 24.08.2007 (except the GUI) to let the installation work flawlessly. Please note that you will _not_ get the latest server sourcecode when using the installer. Developers should always use the latest CVS checkout to work - only to take a quick look the installer is the way to go.

        Greetings

        Comment


        • #5
          Originally posted by Martin Braun View Post
          Hi,

          Please note that you will _not_ get the latest server sourcecode when using the installer.

          Greetings
          Does it mean, that the installer worked again?
          I'll test it tonight!

          Thank you

          mfg.

          sdh82
          Last edited by sdh82; 10-17-2007, 10:27 AM.

          Comment


          • #6
            Hi.

            Yes, that's what i wanted to say

            Comment


            • #7
              hi Martin,

              update my system and same error !!!

              Dryphon

              Comment


              • #8
                Did you chose the "Update" or the "Replace" option? "Updating" will checkout the latest source which does not compile correclty. You should chose the "Replace" option or update manualy.

                Comment


                • #9
                  "Update" chosed
                  after cvs upadete and compile manualy same error
                  How manualy install

                  Comment


                  • #10

                    [UPDATE]
                    The workaround below is no longer required, CVS has been fixed.


                    You need to define a date from where the cvs should be checked out. 24.08.2007 works nice as far as i experienced, you may do it like this:

                    Code:
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-console-ee
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-plugin-imap
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-plugin-mail
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-plugin-mailfilter
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-plugin-context_light
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-admin-plugin-ca_mgmt_simple
                    cvs -d:pserver:anonymous@www.open-xchange.com:/cvsroot co -D "08/24/2007" open-xchange-gui
                    and then build it. You may want to remove the previous checkout to avoid conflicts. If your services are already configured you do not need to do it again, just make sure your database/oxadmin password is set at configdb.properties.

                    gui works wit the latest checkout.
                    Last edited by Martin Heiland; 10-18-2007, 04:55 PM.

                    Comment


                    • #11
                      Thanks, Martin. It was broken for me but after your latest fix I did a "replace" and now it works fine.

                      Jim

                      Comment


                      • #12
                        For your information: CVS is working properly again, the installer uses the latest sources now.

                        Comment


                        • #13
                          now "update" works
                          but in gui calender not show day and week its empty
                          and calender shortcut is not works fine

                          Comment


                          • #14
                            HI,

                            did you clear the cache of your browser after updating?

                            Greetings

                            Comment


                            • #15
                              sorry
                              now works fine

                              Comment

                              Working...
                              X