Announcement

Collapse
No announcement yet.

VMWare manual ip address change needed (192.168.1.100)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VMWare manual ip address change needed (192.168.1.100)

    Greetings,

    OX looks great and I am eager to use it. I'm using the latest vmware file that has been released which defaults the IP address to 192.168.1.100. I have vmware running on a server at my datacenter and booted this image up. I am not able to go in via 192.168.1.100 so I need to manually change the IP address.

    I logged in via admin / ChangeMe via ssh and su'd to root (via the same password). I was able to get eth1 up and running on a real IP, then rebooted the machine. Everything is working great until I try to log in via the admin.

    If I use oxadmin I can log in to the first part. When I try to log in to the admin to configure everything, it lets me partially in then times out. The failure message is something to the effect of it's looking for 192.168.1.100. I cannot find where this is being used by the OX admin. Any ideas?

  • #2
    Hi,

    is eth0 still listening to 192.168.1.100? If so, you should change that ip address to the "real" IP and reboot again, as far as i know the network settings for eth0 are used as reference to the admin tools.

    Comment


    • #3
      Originally posted by Martin Braun View Post
      Hi,

      is eth0 still listening to 192.168.1.100? If so, you should change that ip address to the "real" IP and reboot again, as far as i know the network settings for eth0 are used as reference to the admin tools.
      No, eth0 is disabled. I ran iptables -A and it only showed eth1 for a network card. I switched the interface to eth1 and set up the network and did a reboot. It does come up under the real IP via eth1 and everything appears to work fine. I can ssh into it from an external network, and view http. The only thing that I can't seem to do is login to the admin page via http.

      Comment


      • #4
        Hi,

        please try to restart the open-xchange-admin daemon (/etc/init.d/open-xchange-admin restart) or (/etc/init.d/open-xchange-restart-services).

        Hope that helps.

        Comment


        • #5
          Originally posted by Martin Braun View Post
          Hi,

          please try to restart the open-xchange-admin daemon (/etc/init.d/open-xchange-admin restart) or (/etc/init.d/open-xchange-restart-services).

          Hope that helps.
          No such luck. Trying to login to the admin still results in the following error:

          Error code: Connection refused to host: 192.168.1.100; nested exception is:
          java.net.ConnectException: Connection timed out (SVL-0001,1291057313-2)

          Comment


          • #6
            Hello, I have the same problem.
            I edited /etc/network/interfaces to change from 192.168.1.100 to 192.168.0.15

            Then rebooted and get this error message:
            http://www.open-xchange.com/forum/at...1&d=1218094696

            Then rebooted again and I get another error message:
            http://www.open-xchange.com/forum/at...1&d=1218094888

            And as you can see it says "Server IP Address 192.168.1.100":
            http://www.open-xchange.com/forum/at...1&d=1218094696

            I would appreciate any help on where to change that IP settings.
            Regards.
            Attached Files
            Last edited by josego; 08-07-2008, 09:48 AM. Reason: changing images to links to images

            Comment


            • #7
              Problem solved.
              Just edit /etc/hosts

              Comment

              Working...
              X