Announcement

Collapse
No announcement yet.

Compiling Problems with Libraries

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiling Problems with Libraries

    I'm tryng to compile with Installer_script and a manually.
    it looks like that libraries in some buil.xml have changed how could upgrade this:

    build.xml
    ...
    ..

    <property name="osgibundle" value="org.eclipse.osgi_3.3.0.v20070530.jar"/>
    <property name="osgiservicesbundle" value="org.eclipse.osgi.services_3.1.200.v20070605.jar"/>
    <property name="commonsloggingbundle" value="org.apache.commons.logging_1.0.4.v200706111724.jar"/>
    <property name="globalbundle" value="com.openexchange.global_6.5.0.jar"/>
    <property name="configbundle" value="com.openexchange.config_6.5.0.jar"/>
    <property name="serverbundle" value="com.openexchange.server_6.5.0.jar"/>
    <property name="monitoringbundle" value="com.openexchange.monitoring_6.5.0.jar"/>
    <property name="managementbundle" value="com.openexchange.management_6.5.0.jar"/>
    <property name="sessiondbundle" value="com.openexchange.sessiond_6.5.0.jar"/>
    <property name="servletbundle" value="javax.servlet_2.4.0.v200706111738.jar"/>


    <!-- non-osgi jars -->
    <property name="oxlanguages" value="ox_languages.jar"/>
    <property name="commons-fileupload" value="commons-fileupload.jar"/>
    <property name="commons-httpclient" value="commons-httpclient-2.0.2.jar"/>
    <property name="commons-io" value="commons-io.jar"/>
    <property name="concurrent" value="concurrent.jar"/>
    <property name="activation" value="activation.jar"/>
    <property name="jcs" value="jcs-1.2.7.9.2.jar"/>
    <property name="mail" value="mail.jar"/>
    <property name="junit" value="junit-4.1.jar"/>

    thanks

  • #2
    non-consistency in build.xml?

    I noticed some differences from the HOWTO as well

    here's my property section from the build.xml

    <!-- JAR names for classpath -->
    <property name="servletjar" value="servlet-api-2.4.jar" />
    <property name="jdbcjar" value="mysql-connector-java-3.1.14-bin.jar" />
    <property name="mailjar" value="mail.jar" />
    <property name="activationjar" value="activation.jar" />
    <property name="jdomjar" value="jaxen-jdom.jar" />
    <property name="jcsjar" value="jcs-1.3.jar" />
    <property name="concurrentjar" value="concurrent.jar" />
    <property name="loggingjar" value="commons-logging-1.1.1.jar" />
    <property name="jsonjar" value="json.jar" />
    <property name="fileuploadjar" value="commons-fileupload-1.2.jar" />
    <property name="iojar" value="commons-io-1.4.jar" />
    <property name="webdavjar" value="jakarta-slide-webdavlib-2.1.jar" />
    <property name="httpclientjar" value="commons-httpclient-3.1.jar" />
    <property name="tnefjar" value="tnef.jar" />
    <property name="springbeanjar" value="spring-beans_1.2.7.jar" />
    <property name="springcorejar" value="spring-core_1.2.7.jar" />
    <property name="commonscodecjar" value="commons-codec-1.3.jar" />
    further in the build.xml, a reference is made to a jbossclientjar, but I haven't been able to locate this property yet. Anyone got a clue?

    from the HOWTO (http://www.open-xchange.com/wiki//wi...y_dependencies)
    I made the following absent references in the build.xml:

    jcharset.jar
    saxon9.jar ( version 8 is mentioned in the HOWTO)
    commons-cli
    junit-4.4.jar (version 4.1 in the HOWTO)
    org-eclipse.osgi_3.2.2.ox.jar
    i can't be the only one?

    My distro is Debian Etch, installed through PXE in a VM server session. nothing but the base system is installed.

    Hope that anyone can help me

    Comment


    • #3
      Hi,

      which branch are you using? Please note that the installation manual as well as the installer scripts are made for bf_6_4 (server) and bf_6_4_2 (gui)

      greetings

      Comment

      Working...
      X