Announcement

Collapse
No announcement yet.

failed to compile Open-Xchange GUI

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • failed to compile Open-Xchange GUI

    Hey,

    I have a problem with my OX installation.
    When i try to compile the Open-Xchange GUI, it fails with the following message:

    # ant -Dlib.dir=/opt/open-xchange/lib/ deploy
    Buildfile: build.xml

    css:
    [xslt] Processing /usr/src/open-xchange/open-xchange-gui/style.xml to /usr/src/open-xchange/open-xchange-gui/build/border.css
    [xslt] Loading stylesheet /usr/src/open-xchange/open-xchange-gui/css.xsl

    BUILD FAILED
    javax.xml.transform.TransformerFactoryConfiguratio nError: Provider net.sf.saxon.TransformerFactoryImpl not found

    Total time: 1 second
    oxnew:/usr/src/open-xchange/open-xchange-gui# nano build.xml
    oxnew:/usr/src/open-xchange/open-xchange-gui# ant -Dlib.dir=/opt/open-xchange/lib/ deploy
    Buildfile: build.xml

    css:
    [xslt] Processing /usr/src/open-xchange/open-xchange-gui/style.xml to /usr/src/open-xchange/open-xchange-gui/build/border.css
    [xslt] Loading stylesheet /usr/src/open-xchange/open-xchange-gui/css.xsl

    BUILD FAILED
    javax.xml.transform.TransformerFactoryConfiguratio nError: Provider net.sf.saxon.TransformerFactoryImpl not found

    Total time: 1 second

    I'm not really fix with java, so i doesnt have any plan why this step fail.
    Are any further informations needed, please tell me.

    thx for help
    Johanson

  • #2
    Have you downloaded the Saxon parser and put saxon8.jar in /opt/open-xchange/lib/ ?

    Comment


    • #3
      Helo Viktor,

      thx for your fast answer.
      Yes i have the saxon8.jar in /opt/open-xchange/lib, and all the saxon8*.jar they was included in the saxonb8-9-0-2j.zip
      But, what is the saxon parser ?
      Is it listed in the HowTo ?
      Wher can i get it ?

      lg
      Johanson

      Comment


      • #4
        Originally posted by johanson View Post
        But, what is the saxon parser ?
        It is an XSLT 2.0 processor. We use to convert XML to HTML when building the GUI.
        Originally posted by johanson View Post
        Is it listed in the HowTo ?
        Yes: III.2. Apache Ant and 3rd party dependencies
        Originally posted by johanson View Post
        Yes i have the saxon8.jar in /opt/open-xchange/lib, and all the saxon8*.jar they was included in the saxonb8-9-0-2j.zip
        ...
        Wher can i get it ?
        Err... Didn't you just say that you already got it?

        Comment


        • #5
          Hey,

          Yes, i downloaded all files listed in the "3rd party section",
          but i didn't know that this is same (saxon - saxon-parser)

          # ls /opt/open-xchange/lib
          activation.jar commons-logging.jar junit-4.1.jar ox_languages.jar saxon8-sql.jar commons-cli-1.0.jar concurrent.jar mail.jar ox_server.jar saxon8-xom.jar commons-fileupload.jar jakarta-slide-webdavlib-2.1.jar mysql-connector-java-3.1.13-bin.jar saxon8-ant.jar saxon8-xpath.jar commons-httpclient-2.0.2.jar jcs-1.2.7.9.2.jar org.eclipse.osgi_3.2.1.R32x_v20060919.jar saxon8-dom4j.jar saxon8-xqj.jar commons-io.jar jdom.jar ox_admindaemon.jar saxon8-dom.jar spring-beans_1.2.7.jar commons-logging-adapters.jar jsdk.jar ox_admin_plugin_context_light.jar saxon8.jar spring-core_1.2.7.jar
          commons-logging-api.jar json.jar ox_admin_plugin_imap.jar saxon8-jdom.jar tnef.jar

          # echo $ANT_OPTS
          -Djavax.xml.transform.TransformerFactory=net.sf.sax on.TransformerFactoryImpl
          # echo $CLASSPATH
          /opt/open-xchange/lib/

          lg and sorry for my misstake ;o)
          Johanson

          Comment


          • #6
            now it compiles !!!

            the hit was the following post (39):
            http://typo3.open-xchange.com/forum/...hp?t=16&page=4

            the right command was:
            ant -lib /opt/open-xchange/lib/ deploy

            Maybe to adapt it into the HowTo ?

            thx Viktor for help

            Comment


            • #7
              This is not a howto problem! It seems like you already have any other XSLT jar/installation in your classpath which conflicts with the saxon package. We may put a note to the install howto anyway.

              Comment


              • #8
                I added it to the howto, as this seems to be a common situation.

                Comment


                • #9
                  Hmm, its possible, but i installed OX on a complete fresh Debian/Etch installation, and follow step by step the HowTo.
                  And there are no other Java packages installed.

                  Johanson

                  Comment


                  • #10
                    It could be part of the normal Java installation. Some java versions bring along their own XSLT processor.

                    Comment


                    • #11
                      ok,...
                      I'll try to install it again on a fresh minimal Debian (vmware) installation.

                      Thx @all for help
                      Johanson

                      Comment

                      Working...
                      X