Announcement

Collapse
No announcement yet.

After Server Update: oxadminmaster authentication failes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thiel
    replied
    Das sieht schon mal gut aus:

    Code:
    root@h2484727:~# listbundles | grep -v ACTIVE
    bundlename: com.openexchange.logback.classic.extensions status: RESOLVED
    bundlename: com.openexchange.logback.configuration status: RESOLVED
    bundlename: com.openexchange.logback.core.extensions status: RESOLVED
    bundlename: com.openexchange.system.extension status: RESOLVED
    Ich denke es gibt Probleme mit dem Apache, der wurde aktualisiert und seitdem funktioniert alles was mit dem balancer zu tun hat nicht mehr. Ich habe in der proxy_http.conf mal die ganzen ProxyPass angaben direkt auf localhost gesetzt und nun komme ich wieder drauf, nur der Guard macht noch Probleme:

    Code:
    #   ProxyPass /ajax balancer://oxcluster/ajax
         ProxyPass /ajax http://localhost:8009/ajax
    #   ProxyPass /appsuite/api balancer://oxcluster/ajax
         ProxyPass /appsuite/api http://localhost:8009/ajax
    #   ProxyPass /drive balancer://oxcluster/drive
         ProxyPass /drive http://localhost:8009/drive
    #   ProxyPass /infostore balancer://oxcluster/infostore
         ProxyPass /infostore http://localhost:8009/infostore
    #   ProxyPass /publications balancer://oxcluster/publications
         ProxyPass /publications http://localhost:8009/publications
    #   ProxyPass /realtime balancer://oxcluster/realtime
         ProxyPass /realtime http://localhost:8009/realtime
    #   ProxyPass /servlet balancer://oxcluster/servlet
         ProxyPass /servlet http://localhost:8009/servlet
    #   ProxyPass /webservices balancer://oxcluster/webservices
         ProxyPass /webservices http://localhost:8009/webservices
    #   #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
    
    #   ProxyPass /usm-json balancer://eas_cluster/usm-json
         ProxyPass /usm-json http://localhost:8009/usm-json
    #   ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync[/url]
         ProxyPass /Microsoft-Server-ActiveSync http://localhost:8009/Microsoft-Server-ActiveSync
    open-xchange.log liefere ich nach, war aber kaum aussagekräftig.

    Leave a comment:


  • Wolfgang Rosenauer
    replied
    Kommt ja offenbar 503 zurück. Was spricht denn das open-xchange.log dazu?
    Und listbundles | grep -v ACTIVE ?

    (
    bundlename: com.openexchange.logback.classic.extensions status: RESOLVED
    bundlename: com.openexchange.logback.configuration status: RESOLVED
    bundlename: com.openexchange.logback.core.extensions status: RESOLVED
    bundlename: com.openexchange.system.extension status: RESOLVED
    )
    ist normal

    Leave a comment:


  • thiel
    replied
    Die Meldung kam nach normalen Updates, worunter unter anderem auch der Apache war.

    Nach einer Neuinstallation ging es wieder.

    Allerdings klappt die Connection zum Backend nicht mehr.

    Im Frontend kommt die Meldung:

    Connection error
    The Service is not available right now


    In der Error Log steht:

    [Tue Nov 24 09:30:16.486265 2015] [proxy_balancer:error] [pid 11969] [client 217.xxx.xxx.xxx:61449] AH01170: balancer://oxcluster: All workers are in error state, referer: http://domain.de/appsuite/

    Access Log:

    217.xxx.xxx.xxx - - [24/Nov/2015:09:30:16 +0100] "GET /appsuite/api/login?action=autologin&client=open-xchange-appsuite&rampup=true&rampupFor=open-xchange-appsuite&version=7.8.0-10 HTTP/1.1" 503 1365 "http://domain.de/appsuite/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36"
    217.xxx.xxx.xxx - - [24/Nov/2015:09:30:16 +0100] "GET /appsuite/api/apps/manifests?action=config HTTP/1.1" 503 1365 "http://domain.de/appsuite/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36"


    Die proxy_http.conf habe ich original übernommen und die ging auch vorher.

    Das System an sich läuft, ich komme über die Konsole drauf und kann user und Kontexte auflisten usw.

    Apache Version 2.4.7 Alle benötigten Module sind aktiv. lbmethod_byrequests auch.

    Gibts eine Idee wonach man noch schauen könnte?

    Leave a comment:


  • Wolfgang Rosenauer
    replied
    Is this related to any update?

    In any case just use /opt/open-xchange/sbin/generatempasswd to create a new mpasswd file and your chosen password.

    Leave a comment:


  • After Server Update: oxadminmaster authentication failes

    Any ideas where to look? Frontend cant connect and console says:

    Code:
    root@xxx:/opt/open-xchange/etc# /opt/open-xchange/sbin/listdatabase -A oxadminmaster -P xxxxxx
    databases could not be listed:
    Server response:
     Authentication failed
            at com.openexchange.admin.rmi.impl.BasicAuthenticator.doAuthentication(BasicAuthenticator.java:188)
            at com.openexchange.admin.rmi.impl.OXUtil.listDatabase(OXUtil.java:483)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:606)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:322)
            at sun.rmi.transport.Transport$2.run(Transport.java:202)
            at sun.rmi.transport.Transport$2.run(Transport.java:199)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:198)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:567)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:828)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.access$400(TCPTransport.java:619)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler$1.run(TCPTransport.java:684)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler$1.run(TCPTransport.java:681)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:681)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            at java.lang.Thread.run(Thread.java:745)
            at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:275)
            at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:252)
            at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:161)
            at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:227)
            at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:179)
            at com.sun.proxy.$Proxy0.listDatabase(Unknown Source)
            at com.openexchange.admin.console.util.database.ListDatabase.<init>(ListDatabase.java:86)
            at com.openexchange.admin.console.util.database.ListDatabase.main(ListDatabase.java:142)
    but i can manage users. so my oxadmin password works.
    Can i check my oxadminmaster password? it worked before.
Working...
X