Announcement

Collapse
No announcement yet.

database problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • database problems

    Hi,

    at first i have to excuse me for my bad english. But i've some problems at installing openexchangeserver on my debian sarge 3.1. I've follow the installationsteps in your wiki, but i think i have a problem with the mysql database. Running the oxinstaller will bring this message

    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=pass --admin-pass=pass --maildomain example.com
    initializing database (step 1/2) done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Server response:
    RMI module OXContextPlugin not available on server
    done

    trying the mysql-client bring this:

    mysql -h localhost -u openexchange -p configdb
    Enter password:
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 21
    Server version: 5.0.32-Dotdeb_1.dotdeb.1-log Dotdeb Sarge backport

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>

    The config.db was created, but:

    /opt/open-xchange/sbin/createuser -A oxadmin -P "pass" --username hanswurst --displayname "Hans Wurst"\ --password pass --email hans.wurst@exemple.com --givenname Hans\ --surname Wurst --language de_DE --timezone Europe/Berlin
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=-1084336870-3

    There is no more db as the config db. My next and last problem is the gui. It has install succesfull but try login give me a: 404 Not Found but the loginscreen i can see. Thanks a lot for help. If you need more information i will post it.

    hacki

  • #2
    Originally posted by hacki View Post
    Hi,

    at first i have to excuse me for my bad english. But i've some problems at installing openexchangeserver on my debian sarge 3.1. I've follow the installationsteps in your wiki, but i think i have a problem with the mysql database. Running the oxinstaller will bring this message

    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=pass --admin-pass=pass --maildomain example.com
    initializing database (step 1/2) done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Server response:
    RMI module OXContextPlugin not available on server
    done

    trying the mysql-client bring this:

    mysql -h localhost -u openexchange -p configdb
    Enter password:
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 21
    Server version: 5.0.32-Dotdeb_1.dotdeb.1-log Dotdeb Sarge backport

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>

    The config.db was created, but:

    /opt/open-xchange/sbin/createuser -A oxadmin -P "pass" --username hanswurst --displayname "Hans Wurst"\ --password pass --email hans.wurst@exemple.com --givenname Hans\ --surname Wurst --language de_DE --timezone Europe/Berlin
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=-1084336870-3

    There is no more db as the config db. My next and last problem is the gui. It has install succesfull but try login give me a: 404 Not Found but the loginscreen i can see. Thanks a lot for help. If you need more information i will post it.

    hacki
    Your not the onlyone to have that problem, I got the same errors, and I dont know java so I was "creative" and used the oxinstaller script from vm-image, at least then it created the open-xchange-db. So I tried to get new sources, but then Im not abel to compile the open-xchange-admin.

    New discover: When i download the cvs source to my Centos box It will not compile, but if download the source to the VM-image, and then transfer it to my Centos box, then it compiles, and everything works, both db are created, and I can add users, but the GUI initilizes for ever. I allso wounder, when you enter the URL for the GUI, I see some german txt and some english txt, howcome??

    Tronn
    Last edited by tronn; 03-19-2007, 10:48 AM. Reason: Found a workaround

    Comment


    • #3
      I've found something with the mod_jk:
      Code:
      /etc/init.d/apache2 restart
      Forcing reload of web server: Apache2[Mon Mar 19 11:10:12 2007] [notice] config.update(): done logger
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done config:
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uriMap:
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done shm:
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done workerEnv:
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done lb:lb
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done lb:lb_1
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done channel.socket:localhost:8009
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done channel.socket:localhost:8019
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done channel.un:/opt/33/work/jk2.socket
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done status:
      [Mon Mar 19 11:10:12 2007] [error] env.createBean2(): Factory error creating vm: ( vm, )
      [Mon Mar 19 11:10:12 2007] [error] config.update(): Can't create vm:
      [Mon Mar 19 11:10:12 2007] [error] env.createBean2(): Factory error creating worker.jni:onStartup ( worker.jni, onStartup)
      [Mon Mar 19 11:10:12 2007] [error] config.update(): Can't create worker.jni:onStartup
      [Mon Mar 19 11:10:12 2007] [error] env.createBean2(): Factory error creating worker.jni:onShutdown ( worker.jni, onShutdown)
      [Mon Mar 19 11:10:12 2007] [error] config.update(): Can't create worker.jni:onShutdown
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/jkstatus/*
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:127.0.0.1:8003
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:127.0.0.1:8003/ex
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples1/*
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples/servlet/*
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples/*.jsp
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples/*
      [Mon Mar 19 11:10:12 2007] [notice] config.update(): done uri:/examples/servlet/HelloW
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done logger
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done config:
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uriMap:
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done shm:
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done workerEnv:
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done lb:lb
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done lb:lb_1
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done channel.socket:localhost:8009
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done channel.socket:localhost:8019
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done channel.un:/opt/33/work/jk2.socket
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done status:
      [Mon Mar 19 11:10:13 2007] [error] env.createBean2(): Factory error creating vm: ( vm, )
      [Mon Mar 19 11:10:13 2007] [error] config.update(): Can't create vm:
      [Mon Mar 19 11:10:13 2007] [error] env.createBean2(): Factory error creating worker.jni:onStartup ( worker.jni, onStartup)
      [Mon Mar 19 11:10:13 2007] [error] config.update(): Can't create worker.jni:onStartup
      [Mon Mar 19 11:10:13 2007] [error] env.createBean2(): Factory error creating worker.jni:onShutdown ( worker.jni, onShutdown)
      [Mon Mar 19 11:10:13 2007] [error] config.update(): Can't create worker.jni:onShutdown
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/jkstatus/*
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:127.0.0.1:8003
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:127.0.0.1:8003/ex
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples1/*
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples/servlet/*
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples/*.jsp
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples/*
      [Mon Mar 19 11:10:13 2007] [notice] config.update(): done uri:/examples/servlet/HelloW
      .
      The workers2.workers2.properties look like this:

      Code:
      [logger]
      level=DEBUG
      
      [config:]
      file=${serverRoot}/conf/workers2.properties
      debug=0
      debugEnv=0
      
      [uriMap:]
      info=Maps the requests. Options: debug
      debug=0
      
      # Alternate file logger
      #[logger.file:0]
      #level=DEBUG
      #file=${serverRoot}/logs/jk2.log
      
      [shm:]
      info=Scoreboard. Required for reconfiguration and status with multiprocess servers
      file=${serverRoot}/logs/jk2.shm
      size=1000000
      debug=0
      disabled=0
      
      [workerEnv:]
      info=Global server options
      timing=1
      debug=0
      # Default Native Logger (apache2 or win32 )
      # can be overriden to a file logger, useful
      # when tracing win32 related issues
      #logger=logger.file:0
      
      [lb:lb]
      info=Default load balancer.
      debug=0
      
      [lb:lb_1]
      info=A second load balancer.
      debug=0
      
      [channel.socket:localhost:8009]
      info=Ajp13 forwarding over socket
      debug=0
      tomcatId=localhost:8009
      
      [channel.socket:localhost:8019]
      info=A second tomcat instance.
      debug=0
      tomcatId=localhost:8019
      lb_factor=1
      group=lb
      group=lb_1
      disabled=0
      
      [channel.un:/opt/33/work/jk2.socket]
      info=A second channel connecting to localhost:8019 via unix socket
      tomcatId=localhost:8019
      lb_factor=1
      debug=0
      
      #[channel.jni:jni]
      #info=The jni channel, used if tomcat is started inprocess
      
      [status:]
      info=Status worker, displays runtime informations
      
      [vm:]
      info=Parameters used to load a JVM in the server process
      JVM=java
      classpath=${TOMCAT_HOME}/bin/tomcat-jni.jar
      classpath=${TOMCAT_HOME}/server/lib/commons-logging.jar
      OPT=-Dtomcat.home=${TOMCAT_HOME}
      OPT=-Dcatalina.home=${TOMCAT_HOME}
      #OPT=-Xmx128M
      #OPT=-Djava.compiler=NONE
      disabled=1
      
      [worker.jni:onStartup]
      info=Command to be executed by the VM on startup. This one will start tomcat.
      class=org/apache/jk/apr/TomcatStarter
      ARG=start
      # For Tomcat 5 use the 'stard' for startup argument
      # ARG=stard
      disabled=1
      stdout=${serverRoot}/logs/stdout.log
      stderr=${serverRoot}/logs/stderr.log
      
      [worker.jni:onShutdown]
      info=Command to be executed by the VM on shutdown. This one will stop tomcat.
      class=org/apache/jk/apr/TomcatStarter
      ARG=stop
      disabled=1
      
      [uri:/jkstatus/*]
      info=Display status information and checks the config file for changes.
      group=status:
      
      [uri:127.0.0.1:8003]
      info=Example virtual host. Make sure myVirtualHost is in /etc/hosts to test it
      alias=myVirtualHost:8003
      
      [uri:127.0.0.1:8003/ex]
      info=Example webapp in the virtual host. It'll go to lb_1 ( i.e. localhost:8019 )
      context=/ex
      group=lb_1
      
      [uri:/examples]
      info=Example webapp in the default context.
      context=/examples
      debug=0
      
      [uri:/examples1/*]
      info=A second webapp, this time going to the second tomcat only.
      group=lb_1
      debug=0
      
      [uri:/examples/servlet/*]
      info=Prefix mapping
      
      [uri:/examples/*.jsp]
      info=Extension mapping
      
      [uri:/examples/*]
      info=Map the whole webapp
      
      [uri:/examples/servlet/HelloW]
      info=Example with debug enabled.
      debug=10
      I think her is the problem of geting 404 not found message. In the howto you say: worker.list=ajp13_worker

      but this is not a available parameter. Maybe the connection error with the oxinstaller depending on this problem? How can I fix my problems?

      Comment


      • #4
        how to config the apache mod-jk for ox on debain

        Hacki, you can config the apache2 mod-jk on debian like following:

        first install the libapache2_mod_jk2 package:
        apt-get install libapache2-mod-jk
        if you have install the libapache2_mod_jk2, please remove it:
        apt-get remove --purge libapache2_mod_jk2

        then edit this file: /etc/apache2/conf.d/ox.conf

        # Where to find workers.properties. We will create this file later in the tutorial.
        #JkWorkersFile /etc/apache2/workers.properties
        JkWorkersFile /etc/libapache2-mod-jk/workers.properties
        # Where to put jk logs.
        JkLogFile /var/log/apache2/mod_jk.log
        # Set the jk log level [debug/error/info]
        JkLogLevel error
        # Select the log format
        JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
        # JkRequestLogFormat set the request format
        JkRequestLogFormat "%w %V %T"
        # This points to our servlets we install later
        JkMount /ajax/* ajp13_worker
        JkMount /servlet/* ajp13_worker


        final edit this file : /etc/libapache2-mod-jk/workers.properties


        #workers.tomcat_home=/usr/share/tomcat4
        #workers.java_home should config according your java_home path
        workers.java_home=/usr/lib/jvm/java-1.5.0-sun
        ps=/
        worker.list=ajp13_worker
        worker.ajp13_worker.port=8009
        worker.ajp13_worker.host=localhost
        worker.ajp13_worker.type=ajp13
        worker.ajp13_worker.lbfactor=1
        worker.loadbalancer.type=lb
        worker.loadbalancer.balanced_workers=ajp13_worker

        final final restart your apache2
        /etc/init.d/apache2 restart

        now , you mod_jk for apache2 is ok.
        Notice: workers.java_home according your java_home patch config

        Comment


        • #5
          Hi,

          Maybe something wrong due this step:

          http://wiki.open-xchange.com/wiki/in...hange_Database

          I had same problems, when my open-xchange-db was empty. Just try as root:
          # mysql open-xchange-db

          mysql> select * from user ;
          You should have empty user.

          Comment

          Working...
          X