Announcement

Collapse
No announcement yet.

open-xchange.service hangs: Hash Manager Error : 4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • open-xchange.service hangs: Hash Manager Error : 4

    hello every1,
    the open-xchange.service hangs with the following log-message:
    /var/log/open-xchange/open-xchange-console.log.old:
    Code:
    Worker started
    error: line 1: missing or bad word count in the dic file
    Hash Manager Error : 4
    Exception in thread "AsyncAppender-Worker-ASYNC" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "RMI RenewClean-[127.0.1.1:49428]" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "FileWatcherTimer" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "hz._hzInstance_1_mail.staderschulen.de.SlowOperationDetectorThread" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "ActiveTaskWatcher" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "HttpServer-0" java.lang.OutOfMemoryError: Java heap space
    
    Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "OXWorker-0002363"
    
    Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "OXWorker-0002303"
    Exception in thread "SpreadsheetLoadRequestQueue" Exception in thread "Timer-0" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "DelayedQueueConsumer" java.lang.OutOfMemoryError: Java heap space
    java.lang.OutOfMemoryError: Java heap space
    after restarting the open-xchange.service, it still gives an error, but works:
    /var/log/open-xchange/open-xchange-console.log:
    Code:
    Worker started
    error: line 1: missing or bad word count in the dic file
    Hash Manager Error : 4
    the open-xchange.log files are too big to post them here.

    i am using the newest version of open-xchange 7.8.4:
    Version der Benutzeroberfläche: 7.8.4 Rev40
    Server-Version: 7.8.4-Rev39

    the system i am running is also up-to-date: debian 8.11

    dovecot/postfix/etc are working fine.

    memory and hard drive are not full either...

  • #2
    As it was an OOM the other error might be also memory related.

    What are your memory options in ox-scriptconf.sh? Especially -Xmx but probably paste everything.

    Comment


    • #3
      #cat ox-scriptconf.sh
      Code:
      LIBPATH=/opt/open-xchange/lib
      PROPERTIESDIR=/opt/open-xchange/etc
      OSGIPATH=/opt/open-xchange/osgi
      
      # Define the Java options for the groupware Java virtual machine.
      JAVA_OPTS_GC="-XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:NewRatio=3"
      JAVA_OPTS_LOG="-Dlogback.threadlocal.put.duplicate=false -XX:-OmitStackTraceInFastThrow"
      JAVA_OPTS_MEM="-XX:MaxHeapSize=512M -XX:MaxPermSize=256M -XX:+UseTLAB"
      JAVA_OPTS_NET="-Dsun.net.inetaddr.ttl=3600 -Dnetworkaddress.cache.ttl=3600 -Dnetworkaddress.cache.negative.ttl=10"
      JAVA_OPTS_OSGI="-Dosgi.compatibility.bootdelegation=false"
      JAVA_OPTS_SERVER="-server -Djava.awt.headless=true"
      
      JAVA_OPTS_OTHER=""
      
      # Define options for debugging the groupware Java virtual machine, disabled by default.
      #JAVA_OPTS_DEBUG="-XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/mnt/heapdump -Xloggc:/var/log/open-xchange/gc.log -verbose:gc -XX:+PrintGCDateStamps -XX:+PrintHeapAtGC -XX:+PrintGCApplicationStoppedTime -XX:+PrintTenuringDistribution"
      
      # Defines the Java options for all command line tools. CLTs need much less memory compared to the groupware process.
      JAVA_OXCMD_OPTS="-Djava.net.preferIPv4Stack=true"
      
      # Maximum number of open Files for the groupware. This value will only be
      # applied when using sysv init. For systemd have a look at the drop-in configs
      # at /etc/systemd/system/open-xchange.service.d
      NRFILES=65536
      
      # Maximum number of processes or more precisely threads for the groupware. This
      # value will only be applied when using sysv init. For systemd have a look at
      # the drop-in configs at /etc/systemd/system/open-xchange.service.d
      NPROC=65536
      
      # Specify the umask of file permissions to be created by ox, e.g. in the
      # filestore.
      # BEWARE: setting a nonsense value like 666 will make open-xchange stop working!
      #         useful values are 006 or 066
      UMASK=066

      Comment


      • #4
        -XX:MaxHeapSize=512M

        this is probably too small depending what components are running.
        Please try to increase this to 1024M for example and see what happens.

        Comment


        • #5
          after restarting the open-xchange.service i still get the message in
          open-xchange-console.log:
          Code:
          Worker started
          error: line 1: missing or bad word count in the dic file
          Hash Manager Error : 4
          open-xchange-console.log.old (before restarting open-xchange.service):
          Code:
          Worker started
          error: line 1: missing or bad word count in the dic file
          Hash Manager Error : 4
          Exception in thread "ActiveTaskWatcher" java.lang.OutOfMemoryError: Java heap space
          cat /opt/open-xchange/etc/ox-scriptconf.sh
          Code:
          LIBPATH=/opt/open-xchange/lib
          PROPERTIESDIR=/opt/open-xchange/etc
          OSGIPATH=/opt/open-xchange/osgi
          
          # Define the Java options for the groupware Java virtual machine.
          JAVA_OPTS_GC="-XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:NewRatio=3"
          JAVA_OPTS_LOG="-Dlogback.threadlocal.put.duplicate=false -XX:-OmitStackTraceInFastThrow"
          JAVA_OPTS_MEM="-XX:MaxHeapSize=1024M -XX:MaxPermSize=256M -XX:+UseTLAB"
          JAVA_OPTS_NET="-Dsun.net.inetaddr.ttl=3600 -Dnetworkaddress.cache.ttl=3600 -Dnetworkaddress.cache.negative.ttl=10"
          JAVA_OPTS_OSGI="-Dosgi.compatibility.bootdelegation=false"
          JAVA_OPTS_SERVER="-server -Djava.awt.headless=true"
          
          JAVA_OPTS_OTHER=""
          
          # Define options for debugging the groupware Java virtual machine, disabled by default.
          #JAVA_OPTS_DEBUG="-XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/mnt/heapdump -Xloggc:/var/log/open-xchange/gc.log -verbose:gc -XX:+PrintGCDateStamps -XX:+PrintHeapAtGC -XX:+PrintGCApplicationStoppedTime -XX:+PrintTenuringDistribution"
          
          # Defines the Java options for all command line tools. CLTs need much less memory compared to the groupware process.
          JAVA_OXCMD_OPTS="-Djava.net.preferIPv4Stack=true"
          
          # Maximum number of open Files for the groupware. This value will only be
          # applied when using sysv init. For systemd have a look at the drop-in configs
          # at /etc/systemd/system/open-xchange.service.d
          NRFILES=65536
          
          # Maximum number of processes or more precisely threads for the groupware. This
          # value will only be applied when using sysv init. For systemd have a look at
          # the drop-in configs at /etc/systemd/system/open-xchange.service.d
          NPROC=65536
          
          # Specify the umask of file permissions to be created by ox, e.g. in the
          # filestore.
          # BEWARE: setting a nonsense value like 666 will make open-xchange stop working!
          #         useful values are 006 or 066
          UMASK=066
          only to get this right:
          ox-scriptconf.sh is not executable!
          so i don't have to execute it myself?
          systemctl restart open-xchange.service takes the changes in affect?

          thanks for ur help.

          Comment


          • #6
            Originally posted by user1378 View Post
            hello every1,
            the open-xchange.service hangs with the following log-message:
            /var/log/open-xchange/open-xchange-console.log.old:
            [CODE]Worker started
            error: line 1: missing or bad word count in the dic file
            Hash Manager Error : 4
            Exception in thread "AsyncAppender-Worker-ASYNC" java.lang.OutOfMemoryError: Java heap space
            Exception in thread "RMI RenewClean-[127.0.1.1:49428]" java.lang.OutOfMemoryError: Java heap space
            Exception in thread "FileWatcherTimer" java.lang.OutOfMemoryError: Java heap space
            Exception in thread "hz._hzInstance_1_mail.staderschulen.de.SlowOperat ionDetectorThread" java.lang.OutOfMemoryError: Java heap space
            The error doesn't seem to be caused by Open-Xchange. Please contact the developer of this mail.staderschulen.de.SlowOperationDetectorThread method,
            maybe the OOM is related.

            Comment


            • #7
              there is no1 else to contact.
              i installed open-xchange years ago from your install-manual.

              Comment

              Working...
              X