Announcement

Collapse
No announcement yet.

createuser probem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • createuser probem

    Tach!

    i have some problems to create users.

    i try:

    /opt/open-xchange/sbin/createuser -A oxadmin -P adminpass /
    --username danio --displayname "Danio" --password mypass /
    --email danio@myoxdomain.de --givenname Danio /
    --surname Danio --language en_US --timezone Europe/Berlin /
    --department staff --company "nix"

    but it failed:

    Exception in thread "main" java.lang.NoClassDefFoundError: com/openexchange/admin/rmi/extensions/OXUserIMAPExtension

    at com.openexchange.admin.console.user.Create.<init>( Create.java:148)
    at com.openexchange.admin.console.user.Create.main(Cr eate.java:79)

    I can access database and gui. all daemons are running, i got no errors while installation. (better: i have not recognized any errors!).

    searching this board was not providing any matching results. can anyone help?

    i'm sorry for my lousy english

    danio

  • #2
    That's because of the last line in createuser in /opt/open-xchange/sbin.

    It should be like this:

    Code:
     $JAVA_BIN -classpath $LIBPATH/ox_admindaemon.jar:$LIBPATH/ox_admin_plugin_context_light.jar:$LIBPATH/ox_admin_plugin_imap.jar:$LIBPATH/ox_admin_console_ee.jar:$LIBPATH/commons-cli-1.0.jar $JAVAMAIN $*

    Comment


    • #3
      i have replaced the last line. it does not work.

      result:
      Server response:
      RemoteException occurred in server thread; nested exception is:
      java.rmi.UnmarshalException:
      error unmarshalling arguments; nested exception is:
      java.lang.ClassNotFoundException: com.openexchange.admin.rmi.extensions.OXUserIMAPEx tension


      danio

      Comment


      • #4
        Originally posted by danio View Post
        i have replaced the last line. it does not work.

        result:
        Server response:
        RemoteException occurred in server thread; nested exception is:
        java.rmi.UnmarshalException:
        error unmarshalling arguments; nested exception is:
        java.lang.ClassNotFoundException: com.openexchange.admin.rmi.extensions.OXUserIMAPEx tension


        danio
        Hmm, may be a typo?

        Please print the last line of createuser here

        Comment


        • #5
          my last line:

          Code:
          $JAVA_BIN -classpath LIBPATH/ox_admindaemon.jar:$LIBPATH/ox_admin_plugin_context_light.jar:$LIBPATH/ox_admin_plugin_imap.jar:$LIBPATH/ox_admin_console_ee.jar:$LIBPATH/commons-cli-1.0.jar $JAVAMAIN $*
          i have downloaded ox groupware on thurday (03/19) but the plugins on wednesday (03/20). is it possible that there are significant differences between this both cvs snapshots? maybe a new new module? i can't remember i have read about 'open-xchange-admin-console-ee' before wednesday.

          Comment


          • #6
            Originally posted by danio View Post
            my last line:

            Code:
            $JAVA_BIN -classpath LIBPATH/ox_admindaemon.jar:$LIBPATH/ox_admin_plugin_context_light.jar:$LIBPATH/ox_admin_plugin_imap.jar:$LIBPATH/ox_admin_console_ee.jar:$LIBPATH/commons-cli-1.0.jar $JAVAMAIN $*
            i have downloaded ox groupware on thurday (03/19) but the plugins on wednesday (03/20). is it possible that there are significant differences between this both cvs snapshots? maybe a new new module? i can't remember i have read about 'open-xchange-admin-console-ee' before wednesday.
            When I checkout a new version, I delete my old one to be on the safe side. can you please try that as well?
            And don't forget to patch the last line in createuser after compiling

            Comment


            • #7
              it lives,my god, it lives...muahahahaharrr i am allmighthy....muahahar...

              k, just kidding
              neo, thx for supporting me. i took a fresh debian and fresh ox sources and now it is working.

              now i have some error messages in the gui. but them seems to be harmless.

              Comment


              • #8
                Check this Topic over here:

                http://www.open-xchange.com/forum/showthread.php?t=130

                Comment

                Working...
                X