Announcement

Collapse
No announcement yet.

Error during installation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error during installation

    Hello,

    I experienced an error during open-xchange-admin installation.


    The first part of open-xchange has passed ant without any error messages

    After this I did following:

    cd /tmp
    cvs -d server:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin
    cvs -d server:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-imap
    cvs -d server:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-context_light
    cvs -d server:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-console-ee
    All 4 steps seems to be ok, now I did

    cd open-xchange-admin
    ant -Dlib.dir=/opt/open-xchange/lib install
    The error output looks like this

    [mkdir] Created dir: /tmp/open-xchange-admin-console-ee/classes
    [javac] Compiling 10 source files to /tmp/open-xchange-admin-console-ee/classes
    [javac] /tmp/open-xchange-admin-console-ee/src/com/openexchange/admin/console/user/Create.java:76: cannot find symbol
    [javac] symbol : class OXUserMailExtension
    [javac] location: package com.openexchange.admin.rmi.extensions
    [javac] import com.openexchange.admin.rmi.extensions.OXUserMailEx tension;
    [javac] ^
    [javac] /tmp/open-xchange-admin-console-ee/src/com/openexchange/admin/console/user/Create.java:166: cannot find symbol
    [javac] symbol : class OXUserMailExtension
    [javac] location: class com.openexchange.admin.console.user.Create
    [javac] OXUserMailExtension ume = new OXUserMailExtension();
    [javac] ^
    [javac] /tmp/open-xchange-admin-console-ee/src/com/openexchange/admin/console/user/Create.java:166: cannot find symbol
    [javac] symbol : class OXUserMailExtension
    [javac] location: class com.openexchange.admin.console.user.Create
    [javac] OXUserMailExtension ume = new OXUserMailExtension();
    [javac] ^
    [javac] 3 errors

    BUILD FAILED
    /tmp/open-xchange-admin/build.xml:138: The following error occurred while executing this line:
    /tmp/open-xchange-admin/build.xml:65: The following error occurred while executing this line:
    /tmp/open-xchange-admin-console-ee/build.xml:35: Compile failed; see the compiler error output for details.
    Any idea what could went wrong? Have sources changed today?
    I installed OX the same way yesteray at local test server and no error occured.
    Please advice what I can do. I am trying to install at my root server and Etch
    is OS.

  • #2
    I have the same error, same output

    Comment


    • #3
      Many thanks for your reply, it wasn´t me then who did something wrong, I believe.

      Arrrggggghhhhh... nichts funktioniert heute und es nicht mal Freitag der 13....

      Greetz Jasmin

      Comment


      • #4
        Problem is, that nobody else have this problem. But lets hope that someone can solve our poblem.

        Aber Montage sind bekanntlich schlimmer als irgendwelche Unglücksfreitage

        Comment


        • #5
          I guess they changed the sources today. I have installed OX hyperion at my local servers yesterday in the evening and every step passed the compiler without any errors.

          Werde mal die Sourcen vergleichen wenn ich nach Hause komme, installiere gottlob nicht temporär nach /tmp (Erfahrungswerte ) und die Daten müssten noch da sein...
          Werde mich dann mal um ein Fixing des Problems kümmern, bin es gewohnt seitdem wir in der Firma einen doppelt bezahlten Programmierer vorgesetzt bekommen haben und ich dessen "gute Arbeit" nachbereiten muss.

          Gruss Jasmin
          Last edited by pennywize; 03-26-2007, 05:36 PM.

          Comment


          • #6
            Hi Altarig,

            have a look for wiki page, it seems they really changed sources and there are some additional commands regarding this to find in wiki

            Comment


            • #7
              Thx a lot, i will try it tomorrow. Today i have not much time

              Comment


              • #8
                Now another error message occurred:

                ...
                ...
                ...
                setting writeProperty.1 in @absserverconfdir@/configdb.properties
                grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                setting writeProperty.2 in @absserverconfdir@/configdb.properties
                grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                (Re)Starting Admin Daemon done
                initializing database (step 2/2)Error:
                Connection refused to host: xx.yy.zz.aa; nested exception is:
                java.net.ConnectException: Connection refused
                Error:
                Connection refused to host: xx.yy.zz.aa; nested exception is:
                java.net.ConnectException: Connection refused
                Server response:
                RMI module OXMailServer not available on server
                done
                Happens with this command:

                /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain mail.domain.tld
                Arggghhhh, have everything changed

                Greetz Jasmin

                Comment


                • #9
                  Originally posted by pennywize View Post
                  Now another error message occurred:



                  Happens with this command:



                  Arggghhhh, have everything changed

                  Greetz Jasmin
                  Ah, sorry, missed some variables in ant file.
                  Fixed.

                  Comment


                  • #10
                    Many thanks, Carsten. Have to reinstall OS now, have tried so much and want be sure everything´s working fine then. Fortunately every step is in my own lil howto and it doesn´t take so much effort to do this again

                    ...or maybe a new test install first at local test server.

                    Is it just the only one new addition in wiki for today or is a new *big* surprise on the way?

                    & cd /tmp
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-console-ee
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-imap
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-mail
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-mailfilter
                    pserver:anonymous@www.open-xchange.com:/var/lib/cvs co open-xchange-admin-plugin-context_light
                    Thanks for info again,

                    Jasmin

                    Comment


                    • #11
                      Originally posted by Carsten Hoeger View Post
                      Ah, sorry, missed some variables in ant file.
                      Fixed.
                      Nope. I have reinstalled OS and start installation again.
                      /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain my.domain.tld
                      Result: same error occurred!

                      ...
                      ...
                      ...
                      setting readUrl in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      setting writeUrl in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      setting readProperty.1 in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      setting readProperty.2 in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      setting writeProperty.1 in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      setting writeProperty.2 in @absserverconfdir@/configdb.properties
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
                      (Re)Starting Admin Daemon done
                      initializing database (step 2/2)Error:
                      Connection refused to host: 12.34.56.78; nested exception is:
                      java.net.ConnectException: Connection refused
                      Error:
                      Connection refused to host: 12.34.56.78; nested exception is:
                      java.net.ConnectException: Connection refused
                      Server response:
                      RMI module OXMailServer not available on server
                      done
                      Last edited by pennywize; 03-26-2007, 07:59 PM.

                      Comment


                      • #12
                        Maybe it wasn't synchronized to the public CVS yet. Could you try again?

                        Comment


                        • #13
                          Hi,

                          I recognized same error messages yesterday AFAIR. It was the point where I stopped an installment during you developers obviously update sources every hour
                          Try again later in the evening at my small dedicated testserver (for testing purposes only) and am in hope it works then...

                          May you are interested in a full howto for installments at dedicated servers later with security levels for Apache2 and Lighttpd - server (Etch)...
                          Before I really start I need a sign 'heaviest developements' are done for example...

                          Guess many peoples want run OX (whatever version they want) at dedies...

                          Comment


                          • #14
                            well yesterday i did not have this error - but after a lot of problems i decided to start from beginning - and today i got the same error...

                            greets, Nik

                            Comment

                            Working...
                            X