Announcement

Collapse
No announcement yet.

oxinstaller failed now... :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • oxinstaller failed now... :(

    Hello,

    I have opened a new thread to keep of track regarding this problem from this thread
    http://www.open-xchange.com/forum/sh...=newpost&t=150

    Have installed at locat test server now and the same error occurred as mentioned in my last message. Both steps 1/2 and 2/2 are containing errors

    Originally posted by Carsten Hoeger View Post
    Ah, sorry, missed some variables in ant file.
    Fixed.
    Nope. I have reinstalled OS and start installation again.
    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain my.domain.tld
    full error message

    testserver:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain testserver.de
    initializing database (step 1/2)cat: @absoxconfdir@/mysql/configdb.sql: Datei oder Verzeichnis nicht gefunden
    cat: @absoxconfdir@/mysql/optimize/configdb.sql: Datei oder Verzeichnis nicht gefunden
    cat: @absoxconfdir@/mysql/consistency/configdb.sql: Datei oder Verzeichnis nicht gefunden
    done
    Configuring services
    setting readUrl in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeUrl in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting readProperty.1 in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting readProperty.2 in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeProperty.1 in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeProperty.2 in @absoxconfdir@/configdb.properties
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absoxconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting readUrl in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeUrl in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting readProperty.1 in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting readProperty.2 in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeProperty.1 in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    setting writeProperty.2 in @absserverconfdir@/configdb.properties
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    grep: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    /opt/open-xchange/etc/admindaemon/oxfunctions.sh: line 160: @absserverconfdir@/configdb.properties: Datei oder Verzeichnis nicht gefunden
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Error:
    Connection refused to host: 192.168.0.200; nested exception is:
    java.net.ConnectException: Connection refused
    Error:
    Connection refused to host: 192.168.0.200; nested exception is:
    java.net.ConnectException: Connection refused
    Server response:
    RMI module OXMailServer not available on server
    done
    testserver:/tmp/open-xchange-admin#
    I am following every step like mentioned in your wiki. Have installed on the same way *like today*' last weekend without any errors and it works fine

    Hope you can either fix problem or advice what can I do

    Greetz Jasmin
    Last edited by pennywize; 03-26-2007, 11:12 PM.

  • #2
    I got the same problem but in English ( No such file or directory ) with the evil and yet unexplained " RMI module OXMailServer not available on server "


    Please help..... all these problems are going to drive us to zimbra.....


    UPDATE

    I fixed the file not found error by replacing @absserverconfdir@ with the proper path in the script. Still though we need help solving the RMI module OXMailServer not available on server error.

    Please and thank you.

    Nick
    Last edited by ndsharp; 03-26-2007, 11:36 PM.

    Comment


    • #3
      I have realized the same errors, some modules in source either missing or are renamed.
      Really hope developers fix that problem soon or add some lines about in wiki.

      Version 0.8.x was great but want compare with new version asap.

      Just another request regarding your wiki. Is it possible you add time of last change in wiki?
      Makes things easier I believe
      Last edited by sledge0303; 03-27-2007, 09:05 AM.

      Comment


      • #4
        Originally posted by sledge0303 View Post
        I have realized the same errors, some modules in source either missing or are renamed.
        Really hope developers fix that problem soon or add some lines about in wiki.

        Version 0.8.x was great but want compare with new version asap.

        Just another request regarding your wiki. Is it possible you add time of last change in wiki?
        Makes things easier I believe
        Hello,
        please keep in mind that the new OX CH is under heavy development. At the moment I could compile and install the OX without any errors.
        There is a VMWare-Virtual-Appliance available for those who wants to "see" the new groupware.

        Now I update my postfix stuff to the new WIKI setup.

        Comment


        • #5
          Hi Neo,

          yes I have in mind Hyperion is still under developement. The latest installment has passed compiler an hour ago.
          May I should wait 2-3 months till the main file has finished developement status and try to install again at root server.

          Just a note for my own 'developements'. I develope some personal modified modules like in case OX runs later with Lighttd, my preferred web server daemon. This should happen with latest running OX modules for making sure it works then!
          Something like a for Apache2 webservers compareable module like mod_security

          Anyway, your effort with VMware Image is really great and keep up your good work
          Last edited by sledge0303; 03-27-2007, 12:21 PM.

          Comment


          • #6
            oxinstaller failing...

            I downloaded sources this evening and tried to do a fresh install
            I compiles nicely, but then I run the oxinstaller

            initializing database (step 2/2)
            Exception in thread "main" java.lang.NullPointerException
            at com.openexchange.groupware.delete.DeleteEvent.<ini t>(DeleteEvent.java:94)
            at com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage.delete(OXUserMySQLStorage.java:1275)
            at com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage.delete(OXUserMySQLStorage.java:1369)
            at com.openexchange.admin.rmi.impl.OXUser.create(OXUs er.java:179)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:460)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:701)
            at java.lang.Thread.run(Thread.java:595)
            at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:247)
            at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:223)
            at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 26)
            at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 179)
            at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:132)
            at $Proxy0.create(Unknown Source)
            at com.openexchange.admin.console.user.Create.<init>( Create.java:183)
            at com.openexchange.admin.console.user.Create.main(Cr eate.java:91)
            done
            setting up the system
            creating certificates
            Server response:
            RemoteException occurred in server thread; nested exception is:
            java.rmi.RemoteException: java.rmi.RemoteException: Wrong exit status for selfsignedcertificate creation
            done



            Then when trying to add a user this error messages

            Exception in thread "main" java.lang.NullPointerException
            at com.openexchange.groupware.delete.DeleteEvent.<ini t>(DeleteEvent.java:94)
            at com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage.delete(OXUserMySQLStorage.java:1275)
            at com.openexchange.admin.storage.mysqlStorage.OXUser MySQLStorage.delete(OXUserMySQLStorage.java:1369)
            at com.openexchange.admin.rmi.impl.OXUser.create(OXUs er.java:179)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:460)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:701)
            at java.lang.Thread.run(Thread.java:595)
            at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:247)
            at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:223)
            at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 26)
            at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 179)
            at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:132)
            at $Proxy0.create(Unknown Source)
            at com.openexchange.admin.console.user.Create.<init>( Create.java:183)
            at com.openexchange.admin.console.user.Create.main(Cr eate.java:91)

            Then thought I try login as oxadmin, it stops with the txt

            Initialisierung... Bitte warten..


            Tronn

            Comment


            • #7
              If you want a stable working OX, take 0.8.2-1 till Hyperion becomes stable.
              Keep in mind, Hyperion is still under developement, sources change quite often...
              You´ll see much more error messages in case you change log levels to upper settings

              Anyway, I really don't understand peoples who start an installment on Monday in hope they get it working till next Friday.
              As for myself, I learnt my lesson and now I know why my boss always said in past: don't waste time and install stable only.
              Last edited by pennywize; 03-31-2007, 12:07 AM.

              Comment


              • #8
                Im not in a hurry, I got a stable 0.8.? installation, but im curious about ox6, and maybe I could be of some help allso. I remember when I first installed 0.7.? then it took me about 3 months before I got it running. But now 0.8.? takes about 10 minutts to install on fresh minimal Centos boxs, with all the goodies like, jabber, samba, clamv etc. I allso learned alot too

                Is there a changelog on the installation instructions to ox6 ?


                Tronn

                Comment


                • #9
                  Originally posted by tronn View Post
                  Im not in a hurry, I got a stable 0.8.? installation, but im curious about ox6, and maybe I could be of some help allso. I remember when I first installed 0.7.? then it took me about 3 months before I got it running. But now 0.8.? takes about 10 minutts to install on fresh minimal Centos boxs, with all the goodies like, jabber, samba, clamv etc. I allso learned alot too

                  Is there a changelog on the installation instructions to ox6 ?
                  Tronn
                  I have been curious myself in OX6 and have learnt same lesson like Pennywize mentioned above.
                  Of course you can download 0.8.2-1
                  or Version 0.8.6-0

                  I have no idea there´s another 0.8 Version between both releases?! 6-0 is buggy a bit.
                  It doens´t take much more efford to install 0.8 than 0.7. Steps should be the same. I install on Debian Sarge/Etch and have no clue what howto is good for CentOS.

                  Comment

                  Working...
                  X