Announcement

Collapse
No announcement yet.

Problem Compiling OX - Ubuntu 7.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Compiling OX - Ubuntu 7.04

    hi, i think that i followed all the instructions correctly, i have checked for the correct names on the files etc.

    but when i compile ox i am getting a lot of errors, i am attaching the log.

    can anybody tell me whats happening im using ubuntu 7.04 and the last cvs version of OX

    Thanks
    Attached Files

  • #2
    The additional library's are not found (logging, mail ...). Have you downloaded all in section "III.2. Apache Ant and 3rd party dependencies" from install wiki? Please follow all steps exactly ...

    Comment


    • #3
      yeah i have all the libraries in another directory and im putting that directory as a parameter with -Dlib.dir :

      gvillaran@host:/opt/tmp/open-xchange$ sudo ant -Dlib.dir=/opt/ox/lib install

      directory of open xchange temp files is /opt/tmp/open-xchange
      directory of additional libraries is /opt/ox/lib

      all the files are chmod 777 and have root ownership.

      Comment


      • #4
        try changing line 10 in the build.xml file to point your OX directory

        Code:
        <property name="prefix" location="/opt/ox"/>

        Comment


        • #5
          Seems to be that errors has changed, i am attaching the file.

          also im gettin this error when tryin to start apache2 :

          * Starting web server (apache2)...
          Syntax error on line 1 of /etc/apache2/conf.d/ox.conf:
          Invalid command 'JkWorkersFile', perhaps misspelled or defined by a module not included in the server configuration

          dont know what to do now.
          Attached Files

          Comment


          • #6
            apache:
            Has mod_jk been installed?

            ox compile:
            are you sure all .jar files are available as mentioned in the wiki? It seems that some servlet related stuff is not present.
            Last edited by Martin Heiland; 06-06-2007, 05:02 PM.

            Comment


            • #7
              just in case that i missed anything im attaching a directory list of the third party libraries...

              i downloaded mod_jk, how can i check if is installed on my system?

              excuse my bad english, is not my primary language

              Thanks for the help
              Attached Files

              Comment


              • #8
                if you run debian/ubuntu

                Code:
                dpkg -l |grep jk
                or, have a look here
                Code:
                /etc/apache2/mods_available/



                greets,
                Eisenkopf

                Comment


                • #9
                  gvillaran@host:$ dpkg -l |grep jk
                  ii libapache-mod-jk 1.2.18-3ubuntu1 Apache 1.3 connector for the Tomcat Java ser

                  is that ok?

                  Comment


                  • #10
                    jup,

                    Code:
                    libapache-mod-jk
                    is installed.

                    you could check, if jk is loaded by apache.

                    Code:
                    cd /etc/apache2/mods_enabled/
                    if jk is not listed there, then

                    Code:
                    a2enmod jk
                    Code:
                    /etc/init.d/apache2 reload
                    and have again a look in:
                    Code:
                    cd /etc/apache2/mods_enabled

                    greets,
                    Eisenkopf

                    Comment


                    • #11
                      i did it (a2enmod) but it says that module dont exist ???

                      is not listed in mods_enabled and is not listed in mods_available, but i found the mod_jk.so in "/usr/lib/apache/1.3/" directory

                      Comment


                      • #12
                        ok apache2 is running now.....thank you

                        still have the problem compiling the program, if anybody can help me will be great, boss is pushing me to phpgroupware but i think that ox is better, hope that anybody can help me with this

                        Thanks again

                        Comment


                        • #13
                          Originally posted by gvillaran View Post
                          yeah i have all the libraries in another directory and im putting that directory as a parameter with -Dlib.dir :

                          gvillaran@host:/opt/tmp/open-xchange$ sudo ant -Dlib.dir=/opt/ox/lib install

                          directory of open xchange temp files is /opt/tmp/open-xchange
                          directory of additional libraries is /opt/ox/lib

                          all the files are chmod 777 and have root ownership.
                          Try to change to the root user to be on the safe side.


                          Another hint could be the vm. It is based on debian/etch.

                          greetz
                          neo

                          Comment


                          • #14
                            ok i tried to build ox and it give me this errors (attached doc)
                            is something related with AJAX? what did i miss?

                            btw i did it with root user this time as neo suggested.

                            Thank you very much for all your help guys

                            Very appreciated
                            Attached Files

                            Comment


                            • #15
                              hi, i managed to compile and install the program, but im having problems to create a user, it give me an authentication error, where should i look to correct this?

                              extract of the log :
                              07/06/2007 02:29:58 PM com.openexchange.admin.rmi.impl.OXUser create
                              GRAVE: unable to create directory: /home/gvillaran
                              07/06/2007 02:30:01 PM com.openexchange.admin.rmi.impl.OXUserIMAPImpl initImap
                              GRAVE: javax.mail.AuthenticationFailedException: Login failed: authentication failure
                              07/06/2007 02:30:01 PM com.openexchange.admin.rmi.impl.OXUser create
                              GRAVE: Error while calling create for plugin: open_xchange_admin_plugin_imap
                              com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPEx ception: javax.mail.AuthenticationFailedException: Login failed: authentication failure
                              at com.openexchange.admin.rmi.impl.OXUserIMAPImpl.cre ate(OXUserIMAPImpl.java:467)
                              at com.openexchange.admin.rmi.impl.OXUser.create(OXUs er.java:215)
                              at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
                              at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
                              at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
                              at java.lang.reflect.Method.invoke(Method.java:597)
                              at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:305)
                              at sun.rmi.transport.Transport$1.run(Transport.java:1 59)
                              at java.security.AccessController.doPrivileged(Native Method)
                              at sun.rmi.transport.Transport.serviceCall(Transport. java:155)
                              at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:535)
                              at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:790)
                              at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:649)
                              at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:885)
                              at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:907)
                              at java.lang.Thread.run(Thread.java:619)
                              07/06/2007 02:30:01 PM com.openexchange.admin.rmi.impl.OXUser create
                              GRAVE: Now doing rollback for everything until now...

                              Comment

                              Working...
                              X