Announcement

Collapse
No announcement yet.

Loading ox.html

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loading ox.html

    I have some error java script in loading ox.html .I used Opera, I localised the js file create this error ( fr.js) in openxchange-cgi. but I cant correct its .can you help me please.

  • #2
    Could you please post these errors?

    Hint: www.getfirebug.com for debugging in Mozilla Firefox

    Comment


    • #3
      The Opera Browser is not supported by the current GUI implementation.

      Comment


      • #4
        Thank you for response

        Opera doesnít my default browser. I used it to localized this errors (because opera can display script) I used Firefox and Internet Explorer.


        Iím sorry for my bed English

        Comment


        • #5
          Well, take a look at firebug, it is a very very useful tool for debugging and customizing js/css/html. As far as i know the very best friend of the OX GUI developers (and some qa guys)

          Comment


          • #6
            That seems to be a configuration problem. When the firebug is installed you can type config.language in the firebug console and post the value of this variable. This will help us to find the solution anyway.

            Comment


            • #7
              I installed firebug but i canít resolve this problem

              I think this error not for my configuration, because used my configuration and open-xchange Express and vmware image, in this 3 example I have this errors.

              Look error in firefox

              http://www.open-xchange.com/forum/at...1&d=1182441354
              Attached Files

              Comment


              • #8
                The attached image talking about an error in the server reply. In this case is that not a JS error.

                Comment


                • #9
                  How I can resolve this error please

                  Comment


                  • #10
                    We need in any case additional information to resolve this. The error says that the JSON in the server reply has invalid syntax. Please take a look in the firebug and post browser requests and server responses here in forum. Alternatively you can sniff the communication between server and GUI with wireshark (ethereal) and post the result here as attachment.

                    BTW: Is Tomcat runing on the same mashine?

                    Comment


                    • #11
                      This can happen if you use DOS linebreaks in your PO file.

                      Comment


                      • #12
                        I havenít tomcat running.

                        This attachment is ethereal capture between my host client 192.168.2.17 and Ox server 192.168.2.27
                        please change the name captureOx.txt by captureOx.cap
                        and open it by etheral

                        think you
                        Attached Files

                        Comment


                        • #13
                          forget it all! I can reproduce this bug on my local system with french version of firefox!! It's a bug in the french language file (lang/fr_FR.js). See the comment from Viktor too.
                          Last edited by Andreas Mayer; 06-22-2007, 03:07 PM.

                          Comment


                          • #14
                            Thank very much for Mr Viktor Pracht, I can resolved this problem

                            This problem happen by used DOS linebreaks in your PO file.

                            I removed this linebreaks and compiled this file

                            Thank very

                            Comment


                            • #15
                              DOS = evil

                              Comment

                              Working...
                              X