Announcement

Collapse
No announcement yet.

cannot edit contacts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot edit contacts

    Hello everybody
    I hope you'll help me find out why i cannot edit any of the contacts that i have created?
    No user can and neither the oxadmin

  • #2
    Hi,

    What contacts do you mean? Those in the global address book represent the system users and cannot be modified by other users. To create, modify, delete your own contacts - you should use the personal "Contacts" folder.
    If you already are using this folder and it does not work - please specify what you are doing and what the error/problem is.

    Comment


    • #3
      Thank you for the reply..

      Well actually i'm new to open-xchange but i found it very very interesting and usefull.
      After i've installed it, I started "playing" around to find out how it works. Everything seems to work fine, but when i've been on the contact manager...
      i've created a new contact, of a customer. Then I decided to Edit that contact and add/update more information. The popup window opens but the fields are empty and an error with red letters appears (it disappears after i left-click anywhere on the whole popped up window).

      The error says:
      Error code: missing field: folder (NON-0000,-1421455287-196)

      (the last three digits (NON-0000,-1421455287-xxx) changes everytime i open that editing window)
      Last edited by daedalus; 06-24-2007, 05:09 PM.

      Comment


      • #4
        Hi,


        Seems like something with the contact folder is broken - does the server throw any exceptions? (/var/log/open-xchange/) Did it work after logout/login again? Does this happen on any users contact folder? Which version of OX are you using?
        Last edited by Martin Heiland; 06-25-2007, 08:57 AM.

        Comment


        • #5
          Originally posted by Martin Braun View Post
          Hi,


          Seems like something with the contact folder is broken - does the server throw any exceptions? (/var/log/open-xchange/) Did it work after logout/login again? Does this happen on any users contact folder? Which version of OX are you using?
          Well there's nothing in folder /var/log/open-xchange.
          After login/logout users can normally login but there's no difference when trying to edit any contact...
          I'm using the one I've installed following the installation of the wiki.open-xchange.com (GUI-Build: 6115 , Server-Build: 6.2.0-0)

          There's also another thing, that i saw now... When login off it asks for saving changes... If i choose YES then it gives this warning (Your configuration couldn't saved. All your changes will be lost. Do you really want to continue? YES-NO)

          Also, i cannot send any email. Should i make changes in postfix, to send emails? I'm about to make postfix login in, sending and receiving my emails from an extrenal(remote) imap server, but i think it sould be sending emails with the default configuration, shouldn't it?
          Last edited by daedalus; 06-25-2007, 09:21 AM.

          Comment


          • #6
            Uhm, this seems to be a real problem with the server, are there any information in the logfiles (syslog, apache, jk log etc.)?

            E-Mailing does not work out-of-the-box in most ways because it is a configuration task of the smtp/imap server and just a bit of configuration at the Groupware. The Groupware behaves like a IMAP Client.
            Last edited by Martin Heiland; 06-25-2007, 09:23 AM.

            Comment


            • #7
              Nothing logged as bad, just the following into file (sorry about before... i had them logs cleared, but now it created them again)

              /var/log/open-xchange/open-xchange-admin.log.0
              23-Jun-2007 12:14:25 org.apache.jcs.auxiliary.lateral.LateralCacheResto re canFix
              SEVERE: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462
              23-Jun-2007 12:14:45 org.apache.jcs.auxiliary.lateral.socket.tcp.Latera lTCPService <init>
              SEVERE: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462

              I wasn't here at the following date/time...
              /var/log/apache2/mod_jk.log
              [Sun Jun 24 07:35:17 2007] [error] init_jk::mod_jk.c (2356): Initializing shm:/etc/apache2/logs/jk-runtime-status errno=2
              [Sun Jun 24 18:03:44 2007] [error] jk_child_init::mod_jk.c (2312): Attachning shm:/etc/apache2/logs/jk-runtime-status errno=2
              [Sun Jun 24 18:04:09 2007] ajp13_worker xxxxxxxxxxxxxxx.com 0.006753

              I wasn't here at the following date/time...
              /var/log/apache2/error.log
              [Sun Jun 24 07:35:18 2007] [notice] Apache/2.0.55 (Ubuntu) mod_jk/1.2.14 PHP/5.1.2 configured -- resuming normal operations
              [Mon Jun 25 10:13:21 2007] [error] [client 10.0.0.6] File does not exist: /var/www/xchange/ugly.css, referer: http://xxxxxxxxxxxxxxxx.com/xchange/ox.html

              I wasn't here at the following date/time...
              /var/log/syslog
              Jun 25 07:56:09 daidalos cyrus/master[6222]: about to exec /usr/sbin/ctl_cyrusdb
              Jun 25 07:56:09 daidalos cyrus/ctl_cyrusdb[6222]: checkpointing cyrus databases
              Jun 25 07:56:10 daidalos cyrus/ctl_cyrusdb[6222]: archiving database file: /var/lib/cyrus/annotations.db
              Jun 25 07:56:10 daidalos cyrus/ctl_cyrusdb[6222]: archiving log file: /var/lib/cyrus/db/log.0000000001
              Jun 25 07:56:11 daidalos cyrus/ctl_cyrusdb[6222]: archiving database file: /var/lib/cyrus/mailboxes.db
              Jun 25 07:56:11 daidalos cyrus/ctl_cyrusdb[6222]: archiving log file: /var/lib/cyrus/db/log.0000000001
              Jun 25 07:56:12 daidalos cyrus/ctl_cyrusdb[6222]: done checkpointing cyrus databases
              Jun 25 07:56:12 daidalos cyrus/master[25779]: process 6222 exited, status 0
              Last edited by daedalus; 06-25-2007, 09:40 AM.

              Comment


              • #8
                could you please run a "tail -f /var/log/open-xchange/*", clear the lines (pressing enter some times) and reproduce the problem with the contact? This should output some error messages to the logfiles. With tail -f you are watching them in real-time.

                Comment


                • #9
                  tail -f /var/log/open-xchange/*
                  ==> /var/log/open-xchange/open-xchange.log.0 <==
                  25-Jun-2007 10:46:31 org.apache.jcs.engine.memory.shrinking.ShrinkerThr ead checkForRemoval
                  INFO: Exceeded maxIdleTime CacheKey context=1 | key=7
                  25-Jun-2007 10:46:35 com.openexchange.pooling.ReentrantLockPool run
                  FINEST: Starting cleaner run.
                  25-Jun-2007 10:46:35 com.openexchange.pooling.ReentrantLockPool run
                  FINEST: Clean run ending. Time: 1
                  25-Jun-2007 10:46:35 com.openexchange.database.Pools run
                  FINEST: Starting cleaner run.
                  25-Jun-2007 10:46:35 com.openexchange.database.Pools run
                  FINEST: Cleaner run ending.
                  25-Jun-2007 10:46:35 com.openexchange.pooling.ReentrantLockPool run
                  FINEST: Starting cleaner run.
                  25-Jun-2007 10:46:35 com.openexchange.pooling.ReentrantLockPool run
                  FINEST: Clean run ending. Time: 0
                  25-Jun-2007 10:46:36 com.openexchange.sessiond.SessionHandler getSession
                  FINE: getSession <5dbcf32f5a455af6a738769031acac33>
                  25-Jun-2007 10:46:36 com.openexchange.ajax.request.ContactRequest <init>
                  FINE: use timezone string: Europe/Athens
                  25-Jun-2007 10:46:36 com.openexchange.ajax.request.ContactRequest <init>
                  FINE: use user timezone: sun.util.calendar.ZoneInfo[id="Europe/Athens",offset=7200000,dstSavings=3600000,useDayli ght=true,transitions=138,lastRule=java.util.Simple TimeZone[id=Europe/Athens,offset=7200000,dstSavings=3600000,useDaylig ht=true,startYear=0,startMode=2,startMonth=2,start Day=-1,startDayOfWeek=1,startTime=3600000,startTimeMode =2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
                  25-Jun-2007 10:46:36 com.openexchange.tools.Logging log
                  SEVERE: NON-0000 Category=5 Message=missing field: folder exceptionID=-1421455287-220
                  NON-0000 Category=5 Message=missing field: folder exceptionID=-1421455287-220

                  at com.openexchange.ajax.parser.DataParser.checkInt(D ataParser.java:215)
                  at com.openexchange.ajax.request.ContactRequest.actio nGet(ContactRequest.java:357)
                  at com.openexchange.ajax.request.ContactRequest.actio n(ContactRequest.java:127)
                  at com.openexchange.ajax.Contact.doGet(Contact.java:1 48)
                  at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
                  at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:138)
                  at com.openexchange.ajax.PermissionServlet.service(Pe rmissionServlet.java:84)
                  at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
                  at com.openexchange.tools.ajp13.AJPv13Request.respons e(AJPv13Request.java:92)
                  at com.openexchange.tools.ajp13.AJPv13RequestHandler. createResponse(AJPv13RequestHandler.java:345)
                  at com.openexchange.tools.ajp13.AJPv13Connection.crea teResponse(AJPv13Connection.java:168)
                  at com.openexchange.tools.ajp13.AJPv13Listener.run(AJ Pv13Listener.java:237)
                  at java.lang.Thread.run(Thread.java:619)

                  I underlined the error it gave...
                  Last edited by daedalus; 06-25-2007, 11:33 AM.

                  Comment


                  • #10
                    well? can you help me further or i should try a new install?

                    Comment


                    • #11
                      Since the update (Last Friday) I have the same problem.

                      Comment


                      • #12
                        Originally posted by oprocopio View Post
                        Since the update (Last Friday) I have the same problem.
                        Then I guess is a bug!

                        Comment


                        • #13
                          Well, i don't know the "history" of this installation and such errors should not lead to reinstallation for sure. If you think that you've got more knowledge to install the system more easily, you may do so

                          # edit:
                          OK, please open a bug in bugzilla (open-xchange.org/bugs) with a complete error description and log output, thanks!

                          Comment


                          • #14
                            How could i get a version before the one i have?

                            I might install the older one, or else i'll have to wait for new update..

                            Comment


                            • #15
                              I have re-created both DB's (config and ox) but the problem is still there!

                              here my log:

                              Code:
                              Jun 26, 2007 11:19:34 AM com.openexchange.sessiond.SessionHandler getSession
                              FINE: getSession <af8a2fd0cff182bc8047578bb00f116b>
                              Jun 26, 2007 11:19:34 AM com.openexchange.ajax.request.ContactRequest <init>
                              FINE: use timezone string: Europe/Zurich
                              Jun 26, 2007 11:19:34 AM com.openexchange.ajax.request.ContactRequest <init>
                              FINE: use user timezone: sun.util.calendar.ZoneInfo[id="Europe/Zurich",offset=3600000,dstSavings=3600000,useDaylight=true,transitions=121,lastRule=java.util.SimpleTimeZone[id=Europe/Zurich,offset=3600000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
                              Jun 26, 2007 11:19:34 AM com.openexchange.tools.Logging log
                              SEVERE: NON-0000 Category=5 Message=missing field: folder exceptionID=24248044-129
                              NON-0000 Category=5 Message=missing field: folder exceptionID=24248044-129
                                      at com.openexchange.ajax.parser.DataParser.checkInt(DataParser.java:215)
                                      at com.openexchange.ajax.request.ContactRequest.actionGet(ContactRequest.java:357)
                                      at com.openexchange.ajax.request.ContactRequest.action(ContactRequest.java:127)
                                      at com.openexchange.ajax.Contact.doGet(Contact.java:148)
                                      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
                                      at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:138)
                                      at com.openexchange.ajax.PermissionServlet.service(PermissionServlet.java:84)
                                      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
                                      at com.openexchange.tools.ajp13.AJPv13Request.response(AJPv13Request.java:92)
                                      at com.openexchange.tools.ajp13.AJPv13RequestHandler.createResponse(AJPv13RequestHandler.java:345)
                                      at com.openexchange.tools.ajp13.AJPv13Connection.createResponse(AJPv13Connection.java:168)
                                      at com.openexchange.tools.ajp13.AJPv13Listener.run(AJPv13Listener.java:237)
                                      at java.lang.Thread.run(Thread.java:619)

                              Comment

                              Working...
                              X