Announcement

Collapse
No announcement yet.

Funambol Connector

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hello,

    Could you please explain how to compile the ox-core jar ?
    We use a 7.1.0 (beta?) connector, and can't use your patched version

    Thanks in advance
    Bas van den Heuvel

    Comment


    • #17
      Hi,
      to compile the connector download the source for your version from funambol's repositories.
      If you don't have Maven installed (the mvn command) get it from http://maven.apache.org/
      Inside the source directory you downloaded before execute
      Code:
      mvn validate
      it should download all build dependencies and check for your environment.
      afterwards you can use
      Code:
      mvn compile
      and
      Code:
      mvn package
      If that works you got a build environment.
      No you could add the patch and compile, package again.

      The package command creates the new jar file you need to replace.

      Kind regards
      Raimund

      Comment


      • #18
        Build Funnambol connector

        Hello, first of all thanks for the patch! I spent some days trying to make Funambol Connector work with OX 6.18 with no success.

        For those who are using connector 7.10 or anyone who need it, in order to build the connector with this fix, you can proceed as follows:

        -. Download the sources from subversion repository:
        svn checkout https://core.forge.funambol.org/svn/core/trunk core --username guest (empty password)

        -. You must have installed the build tool marven2 (mvn) to compile sources.

        -. Locate this line in ox-core/src/main/java/com/funambol/ox/util/Utility.java:
        if (h[i].getValue().startsWith("open-xchange-session"))
        -. Replace for:
        if (h[i].getValue().startsWith("open-xchange-secret"))

        -. Create or edit the file ~/.m2/settings.xml with this:

        Code:
        <settings xmlns="http://maven.apache.​org/SETTINGS/1.0.0"
           xmlns:xsi="http://www.w3.org/20​01/XMLSchema-instanc​e"
           xsi:schemaLocation="http://maven.apache.​org/SETTINGS/1.0.0
                               http://maven.apache.​org/xsd/settings-1.0​.0.xsd">
        <profiles>
        <profile>
        <id>funambol</id>
        <repositories>
        <repository>
        <id>central</id>
        <url>http://m2.funambol.o​rg/repositories/arti​facts</url>
        </repository>
        </repositories>
        <pluginRepositories>
        <pluginRepository>
        <id>central</id>
        <url>http://m2.funambol.o​rg/repositories/arti​facts</url>
        </pluginRepository>
        </pluginRepositories>
        </profile>
        </profiles>
        
        <activeProfiles>
        <activeProfile​>funambol</active​Profile>
        </activeProfiles>
        </settings>
        -. cd to the repo source root

        -. Build sources:
        mvn compile

        Now you can locate the built class (ox-core/target/classes/com/funambol/ox/util/Utility.class) and add it to the ox-connector-7.1.0.s4j package inside ox-core-7.1.0.jar (ox-connector-7.1.0.s4j/lib/ox-core-7.1.0.jar/lib/) replacing the old existing Utility.class (you can package this inside the original ox-connector-xxx.s4j directly with you package manager; Gnome's File Roller works ok).

        -. FINALLY you can proceed with the connector installation as usual and all should work fine


        P.S. I attach the packaged 7.10 connector s4j file, for those who want to avoid the build process.



        Originally posted by Maxfurn View Post
        Hello,

        Could you please explain how to compile the ox-core jar ?
        We use a 7.1.0 (beta?) connector, and can't use your patched version

        Thanks in advance
        Bas van den Heuvel
        Attached Files

        Comment


        • #19
          How to patch 7.1.0

          For anyone trying to patch 7.1.0 see http://blog.peter-b.org/2010/12/11/f...ver-error-511/ - ymmv.

          Thanks to Bas (post above) for the actual patch. Shame there's no documentation anywhere.....!

          Comment


          • #20
            Hat denn irgendjemand den Connector mit der aktuellen Ox-CE am laufen?

            Gruß

            Daniel

            Comment


            • #21
              Hallo!

              Ich habe versucht auf einem OX-Stable CE (Version : 6.20.0 Rev8 (2011-04-21 12:43:06)) den neuestem Funambol zum Laufe zum bekommen.
              Funambol: funambol-10.0.3.bin
              + funambol-ox-module-7.0.8.zip (+ ox-core.zip Patch)
              und alternativ mit Funambol-ox-connector-7.1.1-patched-for-ox-6.18.tgz (http://blog.peter-b.org/2010/12/11/f...rver-error-511)

              Aber mit beiden Varianten renne ich das 511 Problem wenn ich synce (neueste Version von Funambil Win Sync Client)#

              Funambol Client:
              12:00:07 GMT +1:00 [ERROR] - Server Failure: server returned error code 511
              12:00:07 GMT +1:00 [DEBUG] - end (mode "none")
              12:00:07 GMT +1:00 [ERROR] - Error in syncing: Server Failure: server returned error code 511

              ds-Server Log

              011-12-11 11:39:29,323] [funambol.auth] [ERROR] [978A42C9906E51D4FCE61B5C9D4C369C] [192.168.123.214] [fol-QU5EWURWRDpwZXpp] [] [] $
              com.funambol.ox.exception.OXAccessException: Wrong response while attempting to retrieve config data.
              at com.funambol.ox.items.dao.OXEntityDAO.getUserConfi g(OXEntityDAO.java:532)
              at com.funambol.ox.security.OXOfficer.setUserInfo(OXO fficer.java:404)
              at com.funambol.ox.security.OXOfficer.authenticateBas icCredential(OXOfficer.java:234)
              at com.funambol.ox.security.OXOfficer.authenticateUse r(OXOfficer.java:150)
              at com.funambol.ox.security.OXOfficer.authenticateUse r(OXOfficer.java:73)

              Ich dacht dieser Fehler sei gefixt - siehe auch:
              http://comments.gmane.org/gmane.comp...bol.devel/5901


              Gruß
              Peter
              Last edited by pezi; 12-11-2011, 05:38 PM.

              Comment


              • #22
                Das ist sehr hilfreich Idee. Dass es einfach sein, für mich zu verwenden. Vielen Dank für die Beratung und Unterstützung.
                yes thing

                Comment


                • #23
                  Hi!

                  I get the newest Funambol version 10.0.3 working with OX Funambol 9.0.7 and OX 6.20.0-Rev8 and Funambol Sync Client
                  http://sourceforge.net/projects/funa...nc-client/v10/

                  In this thread, there are some fixes for Funambol and OX 6.18, but the didn't work for OX 6.20.0.

                  I made a maven rebuild of the OX connector according this link
                  http://blog.peter-b.org/2010/12/11/f...ver-error-511/
                  The fixes are inside the SVN code, but the are disabled by remarks. Someone wrote an other code, which works for OX 6.20.
                  The ox-connector has actual the version 9.0.7

                  The build is availabe - see the updated version of my installation guide.
                  http://geizhalsforum.666kb.at/files/2305/funambol.pdf

                  Please report any problems and errors.

                  with regards
                  Peter

                  This is the actual code of ox-core/src/main/java/com/funambol/ox/util/Utility.java

                  // if (h[i].getName().equals("Set-Cookie")){
                  // // < 6.10
                  // // if (h[i].getValue().startsWith("open-xchange-session")){
                  // // 6.18 / 6.20
                  // if (h[i].getValue().startsWith("open-xchange-secret")){
                  // tmp = h[i].getValue();
                  // // test "; path=/"
                  // int postfixlength = "; path=/".length();
                  // sessionIDs[1] = tmp.substring(0,tmp.length()-postfixlength);
                  // }
                  // if (h[i].getValue().startsWith("JSESSIONID")){
                  // tmp = h[i].getValue();
                  // // test "; path=/"
                  // int postfixlength = "; path=/".length();
                  // sessionIDs[2] = tmp.substring(0,tmp.length()-postfixlength);
                  // }
                  // }

                  //
                  if (h[i].getName().equals("Set-Cookie")){
                  tmp = h[i].getValue();
                  // remove "; ..."
                  // in the request during the sync process the Cookie should
                  // have just the first part
                  int firstSemiColon = tmp.indexOf("; ");
                  tmp = tmp.substring(0, firstSemiColon);
                  oxHeaderKeys.getCookies().add(tmp);
                  }


                  }
                  Last edited by pezi; 12-13-2011, 11:20 AM.

                  Comment


                  • #24
                    oxconnector not syncing to OX database

                    Hello Peter,

                    I read your manual http://geizhalsforum.666kb.at/files/2305/funambol.pdf, downloaded and installed everthing as you described. From my android phone the contacts are synced to Funambol DS ServerVersion 10.0.0 (i can see the contacts in the webdemo), but they are not appearing in OX contacts.

                    Please help! what am i missing here?

                    Tim



                    Originally posted by pezi View Post
                    Hi!

                    I get the newest Funambol version 10.0.3 working with OX Funambol 9.0.7 and OX 6.20.0-Rev8 and Funambol Sync Client
                    http://sourceforge.net/projects/funa...nc-client/v10/

                    In this thread, there are some fixes for Funambol and OX 6.18, but the didn't work for OX 6.20.0.

                    I made a maven rebuild of the OX connector according this link
                    http://blog.peter-b.org/2010/12/11/f...ver-error-511/
                    The fixes are inside the SVN code, but the are disabled by remarks. Someone wrote an other code, which works for OX 6.20.
                    The ox-connector has actual the version 9.0.7

                    The build is availabe - see the updated version of my installation guide.
                    http://geizhalsforum.666kb.at/files/2305/funambol.pdf

                    Please report any problems and errors.

                    with regards
                    Peter

                    This is the actual code of ox-core/src/main/java/com/funambol/ox/util/Utility.java

                    // if (h[i].getName().equals("Set-Cookie")){
                    // // < 6.10
                    // // if (h[i].getValue().startsWith("open-xchange-session")){
                    // // 6.18 / 6.20
                    // if (h[i].getValue().startsWith("open-xchange-secret")){
                    // tmp = h[i].getValue();
                    // // test "; path=/"
                    // int postfixlength = "; path=/".length();
                    // sessionIDs[1] = tmp.substring(0,tmp.length()-postfixlength);
                    // }
                    // if (h[i].getValue().startsWith("JSESSIONID")){
                    // tmp = h[i].getValue();
                    // // test "; path=/"
                    // int postfixlength = "; path=/".length();
                    // sessionIDs[2] = tmp.substring(0,tmp.length()-postfixlength);
                    // }
                    // }

                    //
                    if (h[i].getName().equals("Set-Cookie")){
                    tmp = h[i].getValue();
                    // remove "; ..."
                    // in the request during the sync process the Cookie should
                    // have just the first part
                    int firstSemiColon = tmp.indexOf("; ");
                    tmp = tmp.substring(0, firstSemiColon);
                    oxHeaderKeys.getCookies().add(tmp);
                    }


                    }

                    Comment


                    • #25
                      Hello Peter,

                      I tried to install the funambol-Connector according to your installationguide on a Host with opensuse 11.4.
                      You wrote in your guide:
                      To enable and register the Open-Xchange connector at the Funambol server, it has to be
                      added to the configuration file at /opt/Funambol/ds-server/install.properties. The last line
                      of this file should look like this:
                      modules-to-install=content-provider-7.1.2,email-connector-7.1.1,foundation-
                      7.1.1,phones-support-7.1.0, funambol-ox-listener-9.0.7-SNAPSHOT
                      With this config, the install-module failed. Should it be "ox-connector-9.0.7-SNAPSHOT" instead of "funambol-ox-listener-9.0.7-SNAPSHOT"?

                      Ok, Install-Module worked, started funambol, started ox-listener. Status of ox-listener:
                      OXLISTENER_HOME: /opt/Funambol/ox-listener
                      JAVA_OPTS: -Dfile.encoding=UTF-8 -Dfunambol.home=/opt/Funambol -Dfunambol.pushlistener.config.bean=com/funambol/oxlistener/OXListenerConfiguration.xml -Djava.library.path=/opt/Funambol/ox-listener/lib/x86_64 -Djavax.net.ssl.trustStore=/opt/Funambol/ox-listener/lib/security/cacerts
                      Connecting to: localhost:3102
                      PushListener status:
                      > instance: com.funambol.pushlistener.service.PushListenerHeal thStatus@f79f36b
                      > RegistryMonitor status:
                      > instance: com.funambol.pushlistener.service.registry.Registr yMonitor@203e1bc8
                      > current number of threads in the pool: 1
                      > number of running tasks: 0
                      > number of scheduled tasks: 12
                      > number of completed tasks: 11
                      > number of tasks to execute: 1
                      > is shut down: false
                      > ScheduledTaskExecutor status:
                      > instance: com.funambol.pushlistener.service.taskexecutor.Sch eduledTaskExecutor@59e2afb2
                      > current number of threads in the pool: 0
                      > number of running tasks: 0
                      > number of scheduled tasks: 0
                      > number of completed tasks: 0
                      > number of tasks to execute: 0
                      > is shut down: false
                      Seems ok.
                      Then, I tried to configure Funambol.
                      I called "/opt/Funambol/admin/bin/funamboladmin" as root, but there is no process listed. I but a "set -x" in top of the funamboladmin to get further information. The script "/opt/Funambol/admin # cd platform6/lib/nbexec" was not executable. A chmod did the trick. So started the script again....no errors....but also no process in the list.
                      Can you tell me whats wrong here? Any Ideas?

                      Regards

                      Daniel

                      Comment

                      Working...
                      X