Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    OX_visionXY Guest

    Post OpenSuse 10.2 installation

    Hi,
    I'm a novice on Linux and i've a problem with the installation. Every things was ok when an error like this came.
    Code:
    Building Open-Xchange Groupware...
    Buildfile: build.xml does not exist!
    Build failed
    Building Open-Xchange Admindaemon...
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:54: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.Log;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:55: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.LogFactory;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:56: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.BundleActivator;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:57: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.BundleContext;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:58: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.InvalidSyntaxException;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:59: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.ServiceEvent;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:60: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.ServiceListener;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:65: cannot find symbol
        [javac] symbol: class BundleActivator
        [javac] public class Activator implements BundleActivator {
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:67: cannot find symbol
        [javac] symbol  : class Log
        [javac] location: class com.openexchange.admin.daemons.Activator
        [javac]     private static Log log = LogFactory.getLog(AdminDaemon.class);
        [javac]                    ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:78: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.Log;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:79: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.LogFactory;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:80: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.Bundle;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:81: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.BundleContext;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:82: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.BundleEvent;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:83: package org.osgi.framework does not exist
        [javac] import org.osgi.framework.BundleListener;
        [javac]                           ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:77: cannot find symbol
        [javac] symbol  : class BundleContext
        [javac] location: class com.openexchange.admin.daemons.Activator
        [javac]     public void start(BundleContext context) throws Exception {
        [javac]                       ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/Activator.java:146: cannot find symbol
        [javac] symbol  : class BundleContext
        [javac] location: class com.openexchange.admin.daemons.Activator
        [javac]     public void stop(BundleContext context) throws Exception {
        [javac]                      ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:90: cannot find symbol
        [javac] symbol  : class Log
        [javac] location: class com.openexchange.admin.daemons.AdminDaemon
        [javac]     private static final Log log = LogFactory.getLog(AdminDaemon.class);
        [javac]                          ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/PropertyHandler.java:59: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.Log;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/PropertyHandler.java:60: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.LogFactory;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/AdminCache.java:74: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.Log;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/AdminCache.java:75: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.LogFactory;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/AdminCache.java:86: package com.openexchange.groupware.delete does not exist
        [javac] import com.openexchange.groupware.delete.DeleteRegistry;
        [javac]                                          ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/tools/AdminCache.java:87: package com.openexchange.tools.sql does not exist
        [javac] import com.openexchange.tools.sql.DBUtils;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/daemons/AdminDaemon.java:95: cannot find symbol
        [javac] symbol  : class Bundle
        [javac] location: class com.openexchange.admin.daemons.AdminDaemon
        [javac]     private static ArrayList<Bundle> bundlelist = null;
        [javac]                              ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/rmi/impl/OXUser.java:63: package org.apache.commons.io does not exist
        [javac] import org.apache.commons.io.FileUtils;
        [javac]                              ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/rmi/impl/OXUser.java:64: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.Log;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/rmi/impl/OXUser.java:65: package org.apache.commons.logging does not exist
        [javac] import org.apache.commons.logging.LogFactory;
        [javac]                                   ^
        [javac] /usr/src/open-xchange-admin/src/com/openexchange/admin/rmi/impl/OXUser.java:66: package org.apache.jcs does not exist
    
    [....]
    [javac] Note: Some input files use or override a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] 100 errors
    
    
    BUILD FAILED
    /usr/src/open-xchange-admin/build.xml:235: Compile failed; see the compiler error output for details.
    What does it mean ? Thx for your help !
    My configuration OpenSuse 10.2.
    Last edited by OX_visionXY; 01-22-2008 at 09:13 AM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please check out the bf_6_4 branch instead of HEAD.

    Greetings

  3. #3
    OX_visionXY Guest

    Default

    hi martin i 'm really sorry but
    What is bf_6_4 ? Where i write this control ?

    PS : Ok it's with this control cvs : cvs -dserver:anonymous@www.open-xchange.com:/cvsroot co -r bf_6_4 open-xchange
    But i wrote it like this :
    root : cd /usr/src/open-xchange-admin
    root : cvs -dserver:anonymous@www.open-xchange.com:/cvsroot co -r bf_6_4 open-xchange-admin

    Soory i'm a novice in OpenSuse and Linux world ant cvs . Thx for you help
    Last edited by OX_visionXY; 01-22-2008 at 11:50 AM.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    bf_6_4 means "Bugfix Branch 6.4" which is something like a version, a development stream, of the OX sourcecode.

  5. #5
    OX_visionXY Guest

    Default

    ok great ^^. Finally i've fixed up open xchange, i've replace in hyperion-version.sh this line
    REPOSITORY=("-r bf_6_4 open-xchange"
    "-r bf_6_4 open-xchange-admin"
    "-r bf_6_4 open-xchange-admin-console-ee"
    "-r bf_6_4 open-xchange-admin-plugin-imap"
    "-r bf_6_4 open-xchange-admin-plugin-mail"
    "-r bf_6_4 open-xchange-admin-plugin-mailfilter"
    "-r bf_6_4 open-xchange-admin-plugin-context_light"
    "-r bf_6_4 open-xchange-admin-plugin-ca_mgmt_simple"
    "open-xchange-gui")

    but when i want to connect me to open xchange via localhost, an error message came :
    500 internal error.
    I look in the shell to see if everything has been fixup and i've found this line at the end:
    Code:
    initializing database (step 2/2)
    user in context 1 could not be created: 
    Server response:
    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPException: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    done
    setting up the system
    creating certificates
    certificate created
    usermod: Unknown group `sasl'.
    configuring mail system
    using mail.example.com as FQHN of the mail server
    done
    Creating startup scripts... done.
    Creating Groupware user... user in context 1 could not be created: 
    Server response:
     com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPException: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    Starting Open-Xchange Groupware Daemon: (null) already running.

    What's wrong ? thx for you help
    Last edited by OX_visionXY; 01-22-2008 at 01:46 PM.

  6. #6
    Gertjan Guest

    Default

    Quote Originally Posted by OX_visionXY View Post
    ok great ^^.

    What's wrong ? thx for you help
    Take a look at the OpenSUSE 10.3 installer (http://www.feigenblatt.net/ox/ or the mirror mentioned there) how these line look like. I think you are missing parts. (At the moment, you can forget the three admin-gui lines)

  7. #7
    OX_visionXY Guest

    Default

    Ok, thx Gertjan i've already done it.
    But what does it means :
    Code:
    Creating Groupware user... user in context 1 could not be created: 
    Server response:
    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPException: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    Starting Open-Xchange Groupware Daemon: (null) already running.
    Please i need your help !
    Thx for your patience and your help ! euh i'm testing with login : testuser and pass : secret and i can't connect.
    Last edited by OX_visionXY; 01-23-2008 at 06:34 AM.

  8. #8
    OX_visionXY Guest

    Post

    Hello,
    I've found where is the issue. In the file log, i've these lines :
    Code:
    Jan 23 15:44:04 IS-PC005 saslauthd[3986]: PAM unable to dlopen(/lib/security/pam_mysql.so)
    Jan 23 15:44:04 IS-PC005 saslauthd[3986]: PAM [error: /lib/security/pam_mysql.so: cannot open shared obj
    ect file: No such file or directory]
    Jan 23 15:44:04 IS-PC005 saslauthd[3986]: PAM adding faulty module: /lib/security/pam_mysql.so
    Jan 23 15:44:04 IS-PC005 saslauthd[3986]: DEBUG: auth_pam: pam_authenticate failed: Permission denied
    Jan 23 15:44:04 IS-PC005 saslauthd[3986]: do_auth         : auth failure: [user=testeur] [service=imap] 
    [realm=] [mech=pam] [reason=PAM auth error]
    Jan 23 15:44:04 IS-PC005 imap[9725]: badlogin: localhost [127.0.0.1] plaintext testeur SASL(-13): authen
    Apparently, it's this file pam_mysql.so which's the issue.
    I look the manuel to configure pam and cyrus(the files are ok, no problem), i've tested with testsaslauthd -u oxadmin - pass, shell return the message "0: No "authentification failed".
    How i can get pam_mysql ?
    Thx for your help since the beginning !

  9. #9
    Gertjan Guest

    Default

    Normally, the pam_mysql shizzle is build during the installation. Can you check if pam_mysql.so and pam_mysql.la are in /lib/security (or /lib64/security on 64 bit machines)?
    If that is not the case, you have to compile pam_mysql yourself:
    Download this file
    Code:
    mkdir -p /tmp/hyperion-install
    tar -C /tmp/hyperion-install/ --wildcards -xzf opensuse103-hyperion-0.2.1.1.tar.gz src/*.tar
    tar -C /usr/src -xf /tmp/hyperion-install/src/pam_mysql.tar
    cd /usr/src/pam_mysql-0.7RC1
    ./configure
    make
    make install
    In case you run OpenSUSE 10.2 64, add:
    Code:
    cp /lib/security/pam_mysql.la /lib64/security/
    cp /lib/security/pam_mysql.so /lib64/security/
    Last edited by Gertjan; 01-23-2008 at 02:35 PM.

  10. #10
    OX_visionXY Guest

    Default

    Hello Gertjan,
    thx for your reply. No i'm not on a 64 bits machine.
    It's weird. I searched the file and pam_mysql is not in the folder /lib/security but in /usr/lib/security . I copy them and i say you if everything is ok ?

    Edit : it's Ok i tested with testsaslauthd -> message OK
    and i add a new user -> message : "user 16 in context 1 created"

    Thx for you help !
    Last edited by OX_visionXY; 01-23-2008 at 02:44 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •