Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    mackie Guest

    Default Problem with /etc/init.d/open-xchange-groupware startup

    Hi Folks!

    My first Hyperion installation. I've a problem with open-xchange-groupware init on open-xchange user privileges. Look:

    # /etc/init.d/open-xchange-groupware start
    Starting Open-Xchange Groupware: open-xchange-groupware.

    # /etc/init.d/open-xchange-groupware status
    Checking for Open-Xchange Groupware: not running
    So:

    # bash -x /etc/init.d/open-xchange-groupware start
    + set -e
    + STARTSCRIPT=/opt/open-xchange/sbin/open-xchange-groupware
    + NAME=open-xchange-groupware
    + DESC='Open-Xchange Groupware'
    + DEFAULTS=/etc/default/open-xchange-groupware
    + OXFUNCTIONS=/opt/open-xchange/etc/groupware/oxfunctions.sh
    + OXCONFIG=/opt/open-xchange/etc/groupware/ox-scriptconf.sh
    + ENABLED=0
    + test -f /etc/default/open-xchange-groupware
    + . /etc/default/open-xchange-groupware
    ++ ENABLED=1
    + '[' '!' -f /opt/open-xchange/etc/groupware/oxfunctions.sh ']'
    + '[' '!' -f /opt/open-xchange/etc/groupware/ox-scriptconf.sh ']'
    + . /opt/open-xchange/etc/groupware/oxfunctions.sh
    ++ JAVA_BIN=
    + . /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    ++ SYSTEMPROPERTIES=/opt/open-xchange/etc/groupware/system.properties
    ++ LOGGINGPROPERTIES=/opt/open-xchange/etc/groupware/file-logging.properties
    ++ JAVA_XTRAOPTS='-ms50m -mx50m'
    ++ NRFILES=8192
    + '[' 1 = 0 ']'
    + ulimit -n 8192
    + case "$1" in
    + echo -n 'Starting Open-Xchange Groupware: '
    Starting Open-Xchange Groupware: + ox_start_daemon /opt/open-xchange/sbin/open-xchange-groupware
    open-xchange-groupware open-xchange open-xchange
    + local path=/opt/open-xchange/sbin/open-xchange-groupware
    + local name=open-xchange-groupware
    + local user=open-xchange
    + local group=open-xchange
    + test -z /opt/open-xchange/sbin/open-xchange-groupware
    + test -z open-xchange-groupware
    + local runasuser=
    + test -n open-xchange
    + runasuser='--chuid open-xchange'
    + local runasgroup=
    + test -n open-xchange
    + runasgroup='--group open-xchange'
    + start-stop-daemon --chuid open-xchange --group open-xchange --background --start --oknodo --startas
    /opt/open-xchange/sbin/open-xchange-groupware --make-pidfile --pidfile /var/run/open-xchange-groupware.pid
    + echo open-xchange-groupware.
    open-xchange-groupware.
    + exit 0
    Ok, when i try:

    start-stop-daemon -v --chuid root --group root --background --start --oknodo --startas
    /opt/open-xchange/sbin/open-xchange-groupware --make-pidfile --pidfile /var/run/open-xchange-groupware.pid
    Everything seems fine:
    # ps axu |grep java
    root 27543 35.3 12.0 237668 38656 pts/11 Sl 12:59 0:05 /usr/lib/jvm/java/bin/java -ms50m -mx50m -Djava.awt.headless=true
    -Dopenexchange.propfile=/opt/open-xchange/etc/groupware/system.properties -Djava.util.logging.config.file=
    /opt/open-xchange/etc/groupware/file-logging.properties -classpath /opt/open-xchange/lib/mysql-connector-java-3.1.13-bin.jar:/opt/open-xchange/lib/mail.jar
    :/opt/open-xchange/lib/activation.jar:/opt/open-xchange/lib/jdom.jar:/opt/open-xchange/lib/jsdk.jar:
    /opt/open-xchange/lib/jcs-1.2.7.9.2.jar:/opt/open-xchange/lib/concurrent.jar:/opt/open-xchange/lib/commons-logging.jar
    :/opt/open-xchange/lib/json.jar:/opt/open-xchange/lib/commons-fileupload.jar:/opt/open-xchange/lib/commons-io.jar:
    /opt/open-xchange/lib/jakarta-slide-webdavlib-2.1.jar:/opt/open-xchange/lib/commons-httpclient-2.0.2.jar:
    /opt/open-xchange/lib/:/opt/open-xchange/lib/:/opt/open-xchange/lib/tnef.jar:
    /opt/open-xchange/lib/spring-beans_1.2.7.jar:/opt/open-xchange/lib/spring-core_1.2.7.jar:
    /opt/open-xchange/lib/ox_server.jar:/opt/open-xchange/lib/ox_languages.jar: ComfireServer
    Ok, now i try on openxchange:

    #grep open-xchange /etc/passwd /etc/group
    /etc/passwdpen-xchange:x:1004:1003::/opt/open-xchange:/bin/bash
    /etc/grouppen-xchange:x:1003:

    # start-stop-daemon -v --chuid open-xchange --group open-xchange --background --start --oknodo --startas /opt/open-xchange/sbin/open-xchange-groupware --make-pidfile --pidfile /var/run/open-xchange-groupware.pid
    Starting /opt/open-xchange/sbin/open-xchange-groupware...
    Detaching to start /opt/open-xchange/sbin/open-xchange-groupware...done.

    # ps axu |grep java
    root 27623 0.0 0.1 3804 620 pts/11 R+ 13:03 0:00 grep java
    So whats wrong ? Any ideas ? Please help
    Last edited by mackie; 03-21-2007 at 02:20 PM. Reason: Quotes mess

  2. #2
    Francisco Laguna Guest

    Default

    It might be interesting what the java process whines about before starting up. Can you run the script /opt/open-xchange/sbin/open-xchange-groupware as user open-xchange? Also there might me some interesting hints in /var/log/open-xchange/openexchange-console.log

  3. #3
    mackie Guest

    Default re

    No, i cant run script as open-xchange. Bad file and dir permissions. Everywhere in /opt/open-xchange/ is 700 for dirs and 600 for files. Owner and group is root:root . Ok, is that wrong ? Shouldn't ant make property chmod during installation ?
    And /var/log/open-xchange/open-xchange-console.log is empty. Only:

    mar 21 14:32:08 localhost openexchange: Loglevel set to: 5

  4. #4
    Francisco Laguna Guest

    Default

    Yes the ant installation should take care of that, why it didn't is anyones guess.

    The permissions for the open-xchange-groupware script should be 0755, but the install target should chmod them. Try changing this manually and give it another try, please?

  5. #5
    mackie Guest

    Default

    Ok, lets try new install:

    # ant -v -Dlib.dir=/opt/open-xchange/lib install

    Code:
    build-structure:
         [<<cut>>
        [chmod] Current OS is Linux
        [chmod] Executing 'chmod' with arguments:
        [chmod] '755'
        [chmod] '/opt/open-xchange/sbin/open-xchange-groupware'
        [chmod]
        [chmod] The ' characters around the executable and arguments are
        [chmod] not part of the command.
        [chmod] Applied chmod to 1 file and 0 directories.
    
    install:
         [copy] Copying 2 files to /
         [copy] Copying /tmp/open-xchange/system/etc/default/open-xchange-groupware.debian to /etc/default/open-xchange-groupware
         [copy] Copying /tmp/open-xchange/system/etc/init.d/open-xchange-groupware.debian to /etc/init.d/open-xchange-groupware
        [chmod] Current OS is Linux
        [chmod] Executing 'chmod' with arguments:
        [chmod] '755'
        [chmod] '/etc/init.d/open-xchange-groupware'
        [chmod]
        [chmod] The ' characters around the executable and arguments are
        [chmod] not part of the command.
        [chmod] Applied chmod to 1 file and 0 directories.
        [chmod] Current OS is Linux
        [chmod] Executing 'chmod' with arguments:
        [chmod] '755'
        [chmod] '/opt/open-xchange/sbin/checkConsistency'
        [chmod]
        [chmod] The ' characters around the executable and arguments are
        [chmod] not part of the command.
        [chmod] Applied chmod to 1 file and 0 directories.
    Check:

    Code:
    # find /opt/open-xchange -type d |xargs ls -lad
    drwxr-xr-x  5 root root  144 2007-03-23 13:25 /opt/open-xchange
    drwx------  4 root root  112 2007-03-23 13:25 /opt/open-xchange/etc
    drwx------  2 root root  120 2007-03-23 13:27 /opt/open-xchange/etc/consistency
    drwx------  2 root root 1024 2007-03-23 13:27 /opt/open-xchange/etc/groupware
    drwxr-xr-x  2 root root 1144 2007-03-23 13:27 /opt/open-xchange/lib
    drwx------  2 root root  120 2007-03-23 13:27 /opt/open-xchange/sbin
    And files:

    Code:
    # find /opt/open-xchange -type f |xargs ls -la
    -rwxr-xr-x  1 root root     329 2007-03-23 12:55 /opt/open-xchange/add_user
    -rw-------  1 root root     448 2007-03-23 13:27 /opt/open-xchange/etc/consistency/file-logging.properties
    -rw-------  1 root root     145 2007-03-23 13:27 /opt/open-xchange/etc/consistency/ox-scriptconf.sh
    -rw-------  1 root root    1918 2007-03-23 13:27 /opt/open-xchange/etc/groupware/ajp.properties
    -rw-------  1 root root     431 2007-03-23 13:27 /opt/open-xchange/etc/groupware/attachment.properties
    -rw-------  1 root root   11248 2007-03-23 13:27 /opt/open-xchange/etc/groupware/cache.ccf
    -rw-------  1 root root      21 2007-03-23 13:27 /opt/open-xchange/etc/groupware/calendar.properties
    -rw-------  1 root root    2321 2007-03-23 13:27 /opt/open-xchange/etc/groupware/configdb.properties
    -rw-------  1 root root     590 2007-03-23 13:27 /opt/open-xchange/etc/groupware/contact.properties
    -rw-------  1 root root     267 2007-03-23 13:27 /opt/open-xchange/etc/groupware/event.properties
    -rw-------  1 root root     456 2007-03-23 13:27 /opt/open-xchange/etc/groupware/file-logging.properties
    -rw-------  1 root root     534 2007-03-23 13:27 /opt/open-xchange/etc/groupware/foldercache.properties
    -rw-------  1 root root    3084 2007-03-23 13:27 /opt/open-xchange/etc/groupware/imap.properties
    -rw-------  1 root root    3630 2007-03-23 13:27 /opt/open-xchange/etc/groupware/importerExporter.xml
    -rw-------  1 root root     431 2007-03-23 13:27 /opt/open-xchange/etc/groupware/infostore.properties
    -rw-------  1 root root   22915 2007-03-23 13:27 /opt/open-xchange/etc/groupware/javamail.properties
    -rw-------  1 root root     333 2007-03-23 13:27 /opt/open-xchange/etc/groupware/ldaplogin.properties
    -rw-------  1 root root   11375 2007-03-23 13:27 /opt/open-xchange/etc/groupware/ldap.properties
    -rw-------  1 root root     878 2007-03-23 13:27 /opt/open-xchange/etc/groupware/logging.properties
    -rw-------  1 root root    2101 2007-03-23 13:27 /opt/open-xchange/etc/groupware/notification.properties
    -rw-------  1 root root     188 2007-03-23 13:27 /opt/open-xchange/etc/groupware/oxadapter.properties
    -rw-------  1 root root    5564 2007-03-23 13:27 /opt/open-xchange/etc/groupware/oxfunctions.sh
    -rw-------  1 root root     189 2007-03-23 13:27 /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    -rw-------  1 root root     647 2007-03-23 13:27 /opt/open-xchange/etc/groupware/push.properties
    -rw-------  1 root root    1279 2007-03-23 13:27 /opt/open-xchange/etc/groupware/server.properties
    -rw-------  1 root root    1559 2007-03-23 13:27 /opt/open-xchange/etc/groupware/servletmapping.properties
    -rw-------  1 root root    1382 2007-03-23 13:27 /opt/open-xchange/etc/groupware/sessiond.properties
    -rw-------  1 root root     647 2007-03-23 13:27 /opt/open-xchange/etc/groupware/spellcheck.cfg
    -rw-------  1 root root    2915 2007-03-23 13:27 /opt/open-xchange/etc/groupware/system.properties
    -rw-r--r--  1 root root  222618 2004-02-18 04:39 /opt/open-xchange/lib/commons-httpclient-2.0.2.jar
    -rw-r--r--  1 root root   83613 2007-02-10 02:33 /opt/open-xchange/lib/commons-io.jar
    -rw-r--r--  1 root root  344479 2007-02-10 02:33 /opt/open-xchange/lib/commons-io-javadoc.jar
    -rw-r--r--  1 root root  123164 2007-02-10 02:33 /opt/open-xchange/lib/commons-io-sources.jar
    -rw-------  1 root root  188985 2007-03-12 12:01 /opt/open-xchange/lib/concurrent.jar
    -rw-r--r--  1 root root  172713 2004-12-23 22:08 /opt/open-xchange/lib/jakarta-slide-webdavlib-2.1.jar
    -rw-------  1 root root  444442 2007-03-12 11:50 /opt/open-xchange/lib/jcs-1.2.7.9.2.jar
    -rw-r--r--  1  501 root  153253 2004-09-10 01:32 /opt/open-xchange/lib/jdom.jar
    -rw-------  1 root root   31362 2007-03-12 12:08 /opt/open-xchange/lib/jsdk.jar
    -rw-------  1 root root   15941 2007-03-13 14:34 /opt/open-xchange/lib/json.jar
    -rw-r--r--  1 root root  459094 2006-10-18 23:35 /opt/open-xchange/lib/mysql-connector-java-3.1.13-bin.jar
    -rwxr-xr-x  1 root root  849471 2007-03-12 12:38 /opt/open-xchange/lib/org.eclipse.osgi_3.2.1.R32x_v20060919.jar
    -rw-------  1 root root  186779 2007-03-20 14:36 /opt/open-xchange/lib/ox_admindaemon.jar
    -rw-------  1 root root   41844 2007-03-20 14:38 /opt/open-xchange/lib/ox_admin_plugin_context_light.jar
    -rw-------  1 root root   11637 2007-03-20 14:37 /opt/open-xchange/lib/ox_admin_plugin_imap.jar
    -rw-------  1 root root    8374 2007-03-23 13:27 /opt/open-xchange/lib/ox_languages.jar
    -rw-------  1 root root 2900139 2007-03-23 13:27 /opt/open-xchange/lib/ox_server.jar
    -rw-------  1 root root  210302 2007-03-06 13:45 /opt/open-xchange/lib/pg74.215.jdbc3.jar
    -rw-------  1 root root  210371 2005-04-22 17:11 /opt/open-xchange/lib/pg74.216.jdbc3.jar
    -rw-r--r--  1 root root 3730655 2007-02-15 21:51 /opt/open-xchange/lib/saxon8.jar
    -rw-r--r--  1 root root  230640 2006-02-27 21:37 /opt/open-xchange/lib/spring-beans_1.2.7.jar
    -rw-r--r--  1 root root  121409 2006-02-27 21:37 /opt/open-xchange/lib/spring-core_1.2.7.jar
    -rw-r--r--  1 root root   46000 2006-11-19 11:51 /opt/open-xchange/lib/tnef.jar
    -rwxr-xr-x  1 root root    1324 2007-03-23 13:27 /opt/open-xchange/sbin/checkConsistency
    -rwxr-xr-x  1 root root    1557 2007-03-23 13:27 /opt/open-xchange/sbin/open-xchange-groupware

    Permissions in /opt/open-xchange/lib is made by myself.

    Ok permision for sbin/open-xchange-groupware is fine. But, still user open-xchange cant read files:

    /opt/open-xchange/etc/groupware/oxfunctions.sh
    /opt/open-xchange/etc/groupware/ox-scriptconf.sh

    After chmod (#su open-xchange):

    Code:
    $ bash -x /etc/init.d/open-xchange-groupware start
    + set -e
    + STARTSCRIPT=/opt/open-xchange/sbin/open-xchange-groupware
    + NAME=open-xchange-groupware
    + DESC='Open-Xchange Groupware'
    + DEFAULTS=/etc/default/open-xchange-groupware
    + OXFUNCTIONS=/opt/open-xchange/etc/groupware/oxfunctions.sh
    + OXCONFIG=/opt/open-xchange/etc/groupware/ox-scriptconf.sh
    + ENABLED=1
    + test -f /etc/default/open-xchange-groupware
    + '[' '!' -f /opt/open-xchange/etc/groupware/oxfunctions.sh ']'
    + '[' '!' -f /opt/open-xchange/etc/groupware/ox-scriptconf.sh ']'
    + . /opt/open-xchange/etc/groupware/oxfunctions.sh
    ++ JAVA_BIN=
    + . /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    ++ SYSTEMPROPERTIES=/opt/open-xchange/etc/groupware/system.properties
    ++ LOGGINGPROPERTIES=/opt/open-xchange/etc/groupware/file-logging.properties
    ++ JAVA_XTRAOPTS='-ms50m -mx50m'
    ++ NRFILES=8192
    + '[' 1 = 0 ']'
    + ulimit -n 8192
    /etc/init.d/open-xchange-groupware: line 34: ulimit: open files: cannot modify limit: Operacja niedozwolona
    Maybe i should add user open-xchange to root group ;-) ?

  6. #6
    Francisco Laguna Guest

    Default

    I take it you're going for the minimal set of user access permissions. Apparently it'd be a good idea if the ant script also set the permissions on oxfunctions.sh and ox-scriptconf.sh like you found out. Pretty much every file in /opt/open-xchange/etc has to be read by either the groupware or the admin at one point for another, so it'd probably be a good idea to make those world-readable.

    We might have to add this to the ant script. Could you do me the favor and change this manually to find out whether some more permission problems lurk behind some corner?

  7. #7
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by mackie View Post
    Hi Folks!

    My first Hyperion installation. I've a problem with open-xchange-groupware init on open-xchange user privileges. Look:

    So:

    Ok, when i try:

    Everything seems fine:
    Ok, now i try on openxchange:


    So whats wrong ? Any ideas ? Please help
    Code:
    start-stop-daemon -v --chuid root --group root --background --start --oknodo --startas
    /opt/open-xchange/sbin/open-xchange-groupware --make-pidfile --pidfile /var/run/open-xchange-groupware.pid
    When you run this script, there'll be a pid file with ownership root I could imagine and owner open-xchange does not have permission to override it.

  8. #8
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by mackie View Post
    Hi Folks!


    Code:
    $ bash -x /etc/init.d/open-xchange-groupware start
    + set -e
    + STARTSCRIPT=/opt/open-xchange/sbin/open-xchange-groupware
    + NAME=open-xchange-groupware
    + DESC='Open-Xchange Groupware'
    + DEFAULTS=/etc/default/open-xchange-groupware
    + OXFUNCTIONS=/opt/open-xchange/etc/groupware/oxfunctions.sh
    + OXCONFIG=/opt/open-xchange/etc/groupware/ox-scriptconf.sh
    + ENABLED=1
    + test -f /etc/default/open-xchange-groupware
    + '[' '!' -f /opt/open-xchange/etc/groupware/oxfunctions.sh ']'
    + '[' '!' -f /opt/open-xchange/etc/groupware/ox-scriptconf.sh ']'
    + . /opt/open-xchange/etc/groupware/oxfunctions.sh
    ++ JAVA_BIN=
    + . /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    ++ SYSTEMPROPERTIES=/opt/open-xchange/etc/groupware/system.properties
    ++ LOGGINGPROPERTIES=/opt/open-xchange/etc/groupware/file-logging.properties
    ++ JAVA_XTRAOPTS='-ms50m -mx50m'
    ++ NRFILES=8192
    + '[' 1 = 0 ']'
    + ulimit -n 8192
    /etc/init.d/open-xchange-groupware: line 34: ulimit: open files: cannot modify limit: Operacja niedozwolona
    Maybe i should add user open-xchange to root group ;-) ?
    You do not seem to have the latest code running.
    Please check out latest sources.

  9. #9
    mackie Guest

    Default

    Quote Originally Posted by Carsten Hoeger View Post
    You do not seem to have the latest code running.
    Please check out latest sources.

    Ok, but how do i check what version of ox i am running ?

  10. #10
    neo Guest

    Default

    Quote Originally Posted by mackie View Post
    Ok, but how do i check what version of ox i am running ?
    Have a look at the timestamp of build.xml everywhere. Currently there is no build_number available.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •