Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    TomL Guest

    Default CVS compiles but doesn't run

    Some months ago I installed Hyperion by hand and got everything working, but had some postfix issues. I put the project aside due to some changing priorities.

    Recently I started working on it again and sorted out the postfix issues. I had open-xchange working, but I noticed that in the months of my absence the admin GUI had been released, so I tried to add it in. I couldn't get it to compile, so I thought I might need to refresh the code from months ago and recompile.

    So now I have removed all the old build directories and re-checked out everything. The admin daemon builds and runs fine. The groupware builds sucessfully, but when I start it up the java process dies after a few seconds without writing anything at all to /var/log/open-xchange/open-xchange-console.log. It terminates and the log file size is zero.

    I've deleted and re-checked out the CVS again, and it still does the same thing. I suspect that the CVS from today is horribly broken somehow. checkout command was

    Code:
    cvs -d :pserver:anonymous@www.open-xchange.com:/cvsroot/ co -r bf_6_4 open-xchange

  2. #2
    TomL Guest

    Default older code doing same thing

    I tried checking out older code, with
    Code:
    cvs -d :pserver:anonymous@www.open-xchange.com:/cvsroot/ co -D 8/28/2007  open-xchange
    which should give me the same version I had working before, but its doing the same thing. The java process dies, and the console log is size 0. How do I figure out what's wrong if nothing gets logged at all?

  3. #3
    TomL Guest

    Default Fixed!

    Interestingly, the build.xml overwrites the configdb.properties, wiping out my database password. Grrr... Build scripts shouldn't whack config files, IMO.

  4. #4
    eric-leleu Guest

    Default Your reply solved my problem

    Your reply solved my problem


    THANKS !!!


    Now i bug to create user, i follow wiki page, but terminal replay that localhost do not reply...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •