Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    alessandrop Guest

    Default problem with spam filters

    i have found this bug:

    when i create a user with the admin web graphic interface and i check the enable spamfilter option for the user, al works fine.

    When i make the same thing from the command line tool
    /opt/open-xchange/sbin/createuser -A oxadmin -P changeme -u myuser -d "myuser" -g myuser -s myuser -p myuser -e myuser@myuser.com -l it_IT -t "Europe/Rome" -I 51200 -S on -c 1

    and with the change user too

    /opt/open-xchange/sbin/changeuser -c 1 -A oxadmin -P changeme -u myuser --spamfilter on

    or

    /opt/open-xchange/sbin/changeuser -c 1 -A oxadmin -P changeme -u myuser -S on

    the config test is that from the web gui the sieve filter is without comments

    cat /etc/sieve/m/myuser/oxfilterscript.script

    # Generated by OX (remove this line if you edit this manually)
    require "fileinto";
    require "vacation";

    if header :is ["X-Spam-Flag"] ["Yes"]
    {
    fileinto "Spam";
    stop ;
    }

    #vacation :days 1 ;

    and with the command line tool the sieve filter for the user is is

    cat /etc/sieve/m/myuser/oxfilterscript.script
    # Generated by OX (remove this line if you edit this manually)
    require "fileinto";
    require "vacation";

    #if header :is ["X-Spam-Flag"] ["Yes"]
    #{
    #fileinto "Spam";
    #stop ;
    #}

    #vacation :days 1 ;


    my problem is that i have to create a lot of users in a batch way, with the spamfilters enabled.

    The command line is now the simpler way to do this.
    Any hint?
    Workaround too are well accepted..

  2. #2
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    199

    Default

    Workaround:
    You could modify every oxfilterscript.script after creating the users.

    Something like:

    #Untested, test and modify first!!!

    Code:
    for i in `find /etc/sieve/ -name oxfilterscript.script`: do cp "/path/to/working/script" $i; done
    Daniel

  3. #3
    alessandrop Guest

    Default

    and this workaround does shows the "enable spamfilter" user attribute checkbox in the admin console (to see if the user has the spamchek enabled from gui)?

    Thanks a lot!

  4. #4
    alessandrop Guest

    Default

    i have tried to change manually the filter settings.
    The admin gui changes consequentially, and the "spamfilter" flag changes when the filter is changed manually. This is OK

    But i'm in trouble because, after changing the config from filesystem, the spam is not moved in the right folder.
    I have tried to restart cyrus2.2 postfix and openx-xchange-groupware services, but the spam is not moved in the folder too.

    Enabling the spamfilter from gui all works fine.

    I have a doubt: could be that the oxfilterscript.script must be in some way "installed".

    I see the file a/myuser/oxfilterscript.bc that is different when using gui and changing manually the oxfilterscript.script file.

    Any hint?
    Newly thanks a lot .

  5. #5
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    199

    Default

    Quote Originally Posted by alessandrop View Post
    I see the file a/myuser/oxfilterscript.bc that is different when using gui and changing manually the oxfilterscript.script file.
    Please attach both files.

    Thanks,
    Daniel

  6. #6
    imoran Guest

    Default

    Lauch this for update your oxfilterscript.bc

    su - cyrus -c "/usr/lib/cyrus/upgrade/masssievec /usr/lib/cyrus/bin/sievec /etc/imapd.conf"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •