Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5

Thread: Change language

  1. #1
    Nildur Guest

    Default Change language

    Hi all,

    Could someone explain me how to change OX's language to catalan or spanish?

    I installed OX:CE using the debian installer. I found out ca_ES.js and es_ES.js at /var/www/ox/lang/ and I added this line in the file languages.js of the same directory.

    "ca_ES": "Catalan"

    I rebooted, but still doesn't appear Catalan in language options.

    Thanks in advance.

  2. #2
    Join Date
    Oct 2007
    Location
    XiaMen, FuJian ,China
    Posts
    47

    Default

    Quote Originally Posted by Nildur View Post
    Hi all,

    Could someone explain me how to change OX's language to catalan or spanish?

    I installed OX:CE using the debian installer. I found out ca_ES.js and es_ES.js at /var/www/ox/lang/ and I added this line in the file languages.js of the same directory.

    "ca_ES": "Catalan"

    I rebooted, but still doesn't appear Catalan in language options.

    Thanks in advance.
    Please note that each language line except the last one must end with a comma.
    languages.js as
    var all_languages = {

    "ca_ES": "CatalÓ",
    "de_DE": "Deutsch",
    "en_US": "English",
    "fr_FR": "Franšais",
    "ja_JP": "日本語",
    "xx_XX": "Language name"


    };

  3. #3
    Join Date
    Oct 2007
    Location
    XiaMen, FuJian ,China
    Posts
    47

    Default

    Quote Originally Posted by liuxulin View Post
    Please note that each language line except the last one must end with a comma.
    languages.js as
    var all_languages = {

    "ca_ES": "CatalÓ",
    "de_DE": "Deutsch",
    "en_US": "English",
    "fr_FR": "Franšais",
    "ja_JP": "日本語",
    "xx_XX": "Language name"


    };
    i successful

  4. #4
    Nildur Guest

    Default

    Quote Originally Posted by liuxulin View Post
    Please note that each language line except the last one must end with a comma.
    I know...

    It's a curious thing, a day later, the new language is now available altough yesterday I didn't do more changes.

    Maybe it has been a navigator's cache issue?

    By the way, thanks for reply.

  5. #5
    Join Date
    Feb 2007
    Location
    Dortmund, Germany
    Posts
    168

    Default

    Yes, i think this is a caching problem. After an update of the GUI, please make sure your clear your browser cache!
    Markus Wagner
    Open-Xchange Quality Assurance

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •