Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Sunny-Group Guest

    Default 503 Service Temporarily Unavailable

    Hey Leute

    ich habe gerade auf einen VServer von mir mit einen Debian etch sowie mit den Open-Xchange Community Edition Installer OpenXchange installiert.

    Der Installier lief ohne Probleme durch.

    Unter http://IP/ox kann ich das Login sehen. Beim Login aber kommt nichts sondern nur ein Popup mit 503 bla bla bla.

    Die Test mit ajax usw laufen alle schief da kommt dann nur ein 503 Fehler. Leider bin ich im Bezug auf mod_jk sowie serverapplets nicht so firm daher frage ich euch.

    Hier ein paar Logs:

    cat mod_jk.log
    Code:
    [Thu Mar 13 13:16:31 2008] [15816:27568] [error] ajp_service::jk_ajp_common.c (1794): Error connecting to tomcat. Tomcat is probably not started or is listening on the wrong port. worker=ajp13_worker failed
    [Thu Mar 13 13:16:32 2008] [15814:27568] [error] ajp_service::jk_ajp_common.c (1794): Error connecting to tomcat. Tomcat is probably not started or is listening on the wrong port. worker=ajp13_worker failed
    Der Fehler Tomcat is not started, ist mir klar: Nur in einen anderen Post (habe den Link nicht hier habe ich gelesen das dieser nicht gebraucht wird, oder habe ich das verkehrt verstanden?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    mod_jk wurde primär für Tomcat entwickelt, jedoch benutzt Open-Xchange eine eigene Implementierung einiger Dienste die Tomcat anbietet, daher ist diese Meldung recht uninteressant.
    Was interessanter wäre

    1. Läuft der Groupware prozess? (ps axf | grep java -> 2 Java Prozesse)

    2. Was sagen die Logfiles? (/var/log/open-xchange/)


    mfg

  3. #3
    Sunny-Group Guest

    Default

    Also 2 Sachen laufen nicht.

    Aber hier noch was anderes was ich gefunden habe.

    ps axf | grep java
    20393 pts/0 S+ 0:00 \_ grep java

    cat /var/log/open-xchange/open-xchange.log.0
    Code:
    ** BEGIN NESTED EXCEPTION ** 
    
    java.sql.SQLException
    MESSAGE: Access denied for user 'openexchange'@'localhost' (using password: YES)
    
    STACKTRACE:
    
    java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:946)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2870)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:812)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3269)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1182)
            at com.mysql.jdbc.Connection.createNewIO(Connection.java:2818)
            at com.mysql.jdbc.Connection.<init>(Connection.java:1531)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:266)
            at java.sql.DriverManager.getConnection(DriverManager.java:525)
            at java.sql.DriverManager.getConnection(DriverManager.java:140)
            at com.openexchange.database.ConnectionPool$ConnectionLifecycle.create(ConnectionPool.java:210)
            at com.openexchange.database.ConnectionPool$ConnectionLifecycle.create(ConnectionPool.java:151)
            at com.openexchange.pooling.ReentrantLockPool.get(ReentrantLockPool.java:379)
            at com.openexchange.database.Database.get(Database.java:116)
            at com.openexchange.database.Server.loadServerId(Server.java:135)
            at com.openexchange.database.Server.getServerId(Server.java:97)
            at com.openexchange.database.DatabaseInit.init(DatabaseInit.java:85)
            at Starter.<init>(Starter.java:146)
            at ComfireServer.main(ComfireServer.java:62)
    
    
    ** END NESTED EXCEPTION **
    
    
    Attempted reconnect 3 times. Giving up.
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:888)
            at com.mysql.jdbc.Connection.createNewIO(Connection.java:2890)
            at com.mysql.jdbc.Connection.<init>(Connection.java:1531)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:266)
            at java.sql.DriverManager.getConnection(DriverManager.java:525)
            at java.sql.DriverManager.getConnection(DriverManager.java:140)
            at com.openexchange.database.ConnectionPool$ConnectionLifecycle.create(ConnectionPool.java:210)
            at com.openexchange.database.ConnectionPool$ConnectionLifecycle.create(ConnectionPool.java:151)
            at com.openexchange.pooling.ReentrantLockPool.get(ReentrantLockPool.java:379)
            ... 6 more
    Kann er den Dienst nicht starten da er keine Verbindung zum SQL hat?

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    "access denied for user 'openexchange'@'localhost'"

    -> MySQL lässt die groupware nicht mit dem User "openexchange" an die Datenbank

    Hattest du vor der Installation per Installer ein passwort für den Benutzer "root" in MySQL angelegt? Das würde erklären wieso weder in User noch eine Datenbank angelegt wurde.
    Das kannst du ziemlich leicht prüfen mit:
    mysql -uroot

    mfg

  5. #5
    lendrod Guest

    Default

    Ich habe das selbe Problem.
    Ich habe versucht die installation erneut durchzuführen.
    Am Ende steht folgende Fehlerzeilen...nur weiss ich cniht was sie bedeuten


    Code:
    BUILD FAILED
    /tmp/open-xchange-admin-gui-ee/build.xml:106: Compile failed; see the compiler error output for details.
    
    Total time: 12 seconds
    
    BUILD SUCCESSFUL
    Total time: 9 seconds
    
    BUILD SUCCESSFUL
    Total time: 1 second
    awk: Kommandozeile:1: Fatal: Kann Datei '/opt/open-xchange/etc/admindaemon/ox-admin-scriptconf.sh' nicht zum Lesen öffnen (Datei oder Verzeichnis nicht gefunden).
    awk: Kommandozeile:1: Fatal: Kann Datei '/opt/open-xchange/etc/groupware/ox-scriptconf.sh' nicht zum Lesen öffnen (Datei oder Verzeichnis nicht gefunden).
    
    Restarting services...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..
    Stopping Cyrus IMAPd: cyrmaster.
    Waiting for complete shutdown...
    Starting Cyrus IMAPd: cyrmaster.
    Restarting SASL Authentication Daemon: saslauthd.
    Stopping Postfix Mail Transport Agent: postfix.
    Starting Postfix Mail Transport Agent: postfix.
    Stopping Munin-Node: done.
    Starting Munin-Node: done.
    [Fri Apr 04 03:41:57 2008] [warn] Useless use of AllowOverride in line 22.
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    ./hyperion-debian_etch.sh: line 407: /opt/open-xchange/sbin/oxinstaller: Datei oder Verzeichnis nicht gefunden
    
    Creating startup scripts... done.
    
    Creating Groupware user... ./hyperion-debian_etch.sh: line 420: /opt/open-xchange/sbin/createuser: Datei oder Verzeichnis nicht gefunden
    ./hyperion-debian_etch.sh: line 422: /etc/init.d/open-xchange-admin: Datei oder Verzeichnis nicht gefunden
    Open-Xchange Groupware Daemon: /opt/open-xchange/etc/groupware/oxfunctions.sh missing, exiting
    Kann mir wer sagen was da schief läuft?
    Ich finde auch keine ensprechende Log Datei. unter /var/log/open-xchange is mal garnichts drinne

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    das kompilieren der admin Komponente ist fehlgeschlagen, daher werden Tools die man zum initialen Befüllen der Datenbank und anpassung der Konfiguration nicht gefunden. Im open-xchange-admin Verzeichniss solltest du ein logfile des kompilierprozesses finden - oder die Fehler wurden bereits vor dem BUILD FAILED ausgegeben.

    mfg

  7. #7
    lendrod Guest

    Default

    Ich habe die installation mal neue gemacht und gesehen das ich vorher die unstable genommen habe.
    Nun habe ich mal die stable genommen und es schien alles viele besser auszusehen, bis zu dem Punkt wo er folgendes immer wiederholte.

    Code:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
            at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    admindaemon startup still in progress, waiting...
    Und da machte er dann auch nicht weiter.
    Das Error Log vom kompilieren habe ich nicht gefunden....wo ist das den?

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    the installer script currently does NOT work for the head, nor does the installation wiki instructions work with that branch. If the current head (version 6.5) becomes stable, i'll update those resources but currently there are too many changes to keep a guide up to date.

    The compile error message should show up while the script runs trough the "Compiling <component>" stuff, but i think with stable you should not encounter any build problems.

    Regarding the "java.lang.UnsupportedClassVersionError:" error at the stable build - i guess there are fragments left of the HEAD version that cause problems with stable. Please take a look at /opt/open-xchange/* and /tmp/open-xchange/* and do clean up (delete all files there). Then restart the installer.

  9. #9
    lendrod Guest

    Default

    So komplett neuer Server und gleiches spiel von vorne.
    Wieder eine Debian... ahbe gerade eine dist-upgrade gemacht und nun kommt folgender install abbruch und wieder fehler 503

    BUILD FAILED
    /tmp/open-xchange-admin-gui-ee/build.xml:50: Compile failed; see the compiler er ror output for details.

    Leider finde ich die compiler log nicht.
    Meno..ich will das es endlich läuft ;(

  10. #10
    lendrod Guest

    Default

    der erste fehler war schon hier:

    Fehler traten auf beim Bearbeiten von:
    sun-java5-bin
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Nächster:

    Compiling Open-Xchange Groupware...
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.

    Compiling Open-Xchange Admindaemon...
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.

    Nächster:

    BUILD FAILED
    /tmp/open-xchange-admin-gui-ee/build.xml:106: Compile failed; see the compiler error output for details.


    Nächster:

    awk: Kommandozeile:1: Fatal: Kann Datei '/opt/open-xchange/etc/admindaemon/ox-admin-scriptconf.sh' nicht zum Lesen öffnen (Datei oder Verzeichnis nicht gefunden).
    awk: Kommandozeile:1: Fatal: Kann Datei '/opt/open-xchange/etc/groupware/ox-scriptconf.sh' nicht zum Lesen öffnen (Datei oder Verzeichnis nicht gefunden).

    Das sollten alle fehler bei der installation sein bisher
    Wie gesagt das ist eine frisch aufgesetzter Server der auf etch 4 upgegradet wurde

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •