Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    heinb Guest

    Default Install at vServer without 127.0.0.1

    Hello,

    I want to install OX at a vServer without a interface 127.0.0.1. His local loop interface is 127.0.0.30 and it also insert in /etc/hosts. OX is completly correct installed (without any error messages) but when I want to initializing the database with

    Code:
    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=secret --admin-pass=secret --maildomain example.com
    i get
    Code:
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    setting AUTO_TO_LOWERCASE_UID in /opt/open-xchange/etc/admindaemon/User.properties
    (Re)Starting Admin Daemon
    and the logfile says

    Code:
    21.04.2008 13:14:51 org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService <init>
    SCHWERWIEGEND: Could not create sender to [127.0.0.1:57462] -- Socket is null, cannot connect to 127.0.0.1:57462
    21.04.2008 13:14:51 org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager fixService
    SCHWERWIEGEND: Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    21.04.2008 13:14:51 org.apache.jcs.auxiliary.lateral.LateralCacheRestore canFix
    SCHWERWIEGEND: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.1:57462
    21.04.2008 13:14:51 org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService <init>
    I changed the ip address in several files to 127.0.0.30, the logfile entrys change to
    Code:
    SCHWERWIEGEND: Could not create sender to [127.0.0.30:57462] -- Socket is null, cannot connect to 127.0.0.30:57462
    21.04.2008 14:09:34 org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPCacheManager fixService
    SCHWERWIEGEND: Can't fix Socket is null, cannot connect to 127.0.0.30:57462
    21.04.2008 14:09:34 org.apache.jcs.auxiliary.lateral.LateralCacheRestore canFix
    SCHWERWIEGEND: Can't fix Can't fix Socket is null, cannot connect to 127.0.0.30:57462
    Does anybody has some ideas?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    those messages are related to JCS which is used to set up groupware clusters - should be unrelated to your setup, or did you encounter some serious problems besides those log entry?

    Greetings

  3. #3
    heinb Guest

    Default

    Hi,

    i donīt what the problem exactly is, but as i described, the server stands at the following messages

    Code:
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    setting AUTO_TO_LOWERCASE_UID in /opt/open-xchange/etc/admindaemon/User.properties
    (Re)Starting Admin Daemon
    and nothing happens.

    Do you know this problem? For your informations: i want to install it at a clean debian etch.

  4. #4
    Dorowan Guest

    Default

    I have OX running on a fresh Ubuntu 8.04 Linux-Vserver without local loopback 127.0.0.1. I made some notes for myself - in german - with all the needed steps for a manual installation. If you are interested I can send you my notes. They should work for Debian too.

    I had some problems with the setup too. At the moment I can think of two things you could check: Is the bind-adress of your mysql Server set to 127.0.0.30 as your setup request? Did you leave the root password for the mysql-server blank when you installed it? Ubuntu asks three times for a password but you should not set one at that point.
    Last edited by Dorowan; 05-11-2008 at 01:05 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •