Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    rjenster Guest

    Default oxinstaller - no maildomain

    Hi,

    I'm currently writing an install skript for open-xchange on gentoo.
    Unfortunately I can't figure out why the oxinstaller isn't working
    properly (see output below). Mainly I'm concerned about the fact that the database contains no maildomain after the installation, and I have to enter it manually in the admin interface. Any idea what goes wrong here?

    Regards,
    Ruben

    initializing database (step 2/2)
    Server response:
    Authentication failed
    done
    setting up the system
    creating certificates
    certificate could not be created:
    Server response:
    Authentication failed
    chmod: cannot access `/etc/ssl/certs/eecert.pem': No such file or directory
    chmod: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
    WARNING: no group ssl-cert found. System might not work.
    configuring mail system
    using mail.ocotec.de as FQHN of the mail server
    Server response:
    Authentication failed
    done

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    did you install a openssl binary?

    Greetings

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by rjenster View Post
    Hi,

    I'm currently writing an install skript for open-xchange on gentoo.
    Unfortunately I can't figure out why the oxinstaller isn't working
    properly (see output below). Mainly I'm concerned about the fact that the database contains no maildomain after the installation, and I have to enter it manually in the admin interface. Any idea what goes wrong here?

    Regards,
    Ruben

    initializing database (step 2/2)
    Server response:
    Authentication failed
    done
    setting up the system
    creating certificates
    certificate could not be created:
    Server response:
    Authentication failed
    chmod: cannot access `/etc/ssl/certs/eecert.pem': No such file or directory
    chmod: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
    WARNING: no group ssl-cert found. System might not work.
    configuring mail system
    using mail.ocotec.de as FQHN of the mail server
    Server response:
    Authentication failed
    done
    There seem to be multiple problems.
    Please check /var/log/open-xchange/open-xchange-admin.log.0

  4. #4
    rjenster Guest

    Default

    @Martin
    yes openssl is installed - version 0.9.8g but I think that doesn't matter.

    Im currently doing a fresh installation with my install script and will provide you with the logging output later.

    Regards,
    Ruben

  5. #5
    rjenster Guest

    Default

    hi,
    since the log is quite long I uploaded it to my server
    It is taken directly after issueing the oxinstaller command.
    open-xchange-admin.log.0
    If you want me to post the log - just tell me.

    Goodnight!
    Ruben

  6. #6
    rjenster Guest

    Default admin - messes up config files

    hi,
    I just added a new mail domain through the admin GUI.
    unfortunately this messes up the following config files

    /etc/imapd.conf
    /etc/postfix/main.cf
    /etc/postfix/master.cf

    Even though the 'Enable Mailscanner' checkbox was unchecked the
    amavisd configuration was added to /etc/imapd.conf.
    I don't have amavisd running so this causes the whole mailsystem not
    working after postfix is restarted.
    Furthermore I've a custom path for my ssl certifcates and I don't want the admin gui to change it automatically.

    If the oxinstaller skript would work properly here it would add the maildomain automatically - then I could disable all elements except the 'Management' and 'Monitoring' sections in the admin gui to avoid such problems.

    Are you planning to change these hardcoded values/paths in the admin gui?

    diff -ur etc.bak/imapd.conf etc/imapd.conf
    --- etc.bak/imapd.conf 2008-05-09 02:37:19.000000000 +0200
    +++ etc/imapd.conf 2008-05-09 02:37:28.000000000 +0200
    @@ -10,7 +10,7 @@
    # do not allow the use of cleartext passwords on the wire.
    # need to be enabled for open-xchange
    allowanonymouslogin: no
    -allowplaintext: yes
    +allowplaintext: yes
    unixhierarchysep: yes

    # Use saslauthd if you want to use pam for imap.
    @@ -28,5 +28,5 @@
    #tls_ca_file: /etc/ssl/mycert/ca.crt


    -tls_cert_file: /etc/ssl/vhosts/mail.ocotec.de.cert
    -tls_key_file: /etc/ssl/vhosts/mail.ocotec.de.key
    +tls_cert_file: /etc/ssl/certs/eecert.pem
    +tls_key_file: /etc/ssl/private/eekey.pem
    diff -ur etc.bak/postfix/main.cf etc/postfix/main.cf
    --- etc.bak/postfix/main.cf 2008-05-09 02:37:19.000000000 +0200
    +++ etc/postfix/main.cf 2008-05-09 02:37:28.000000000 +0200
    @@ -66,5 +66,7 @@

    # encryption
    smtpd_use_tls = yes
    -smtpd_tls_cert_file = /etc/ssl/vhosts/mail.ocotec.de.cert
    -smtpd_tls_key_file = /etc/ssl/vhosts/mail.ocotec.de.key
    +smtpd_tls_cert_file = /etc/ssl/certs/eecert.pem
    +smtpd_tls_key_file = /etc/ssl/private/eekey.pem
    +procmail_destination_concurrency_limit = 1
    +procmail_destination_recipient_limit = 1
    diff -ur etc.bak/postfix/master.cf etc/postfix/master.cf
    --- etc.bak/postfix/master.cf 2008-05-09 02:37:19.000000000 +0200
    +++ etc/postfix/master.cf 2008-05-09 02:37:28.000000000 +0200
    @@ -6,7 +6,8 @@
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ================================================== ========================
    -smtp inet n - n - - smtpd
    +smtp inet n - n - - smtpd
    + -o content_filter=smtp-amavis:[127.0.0.1]:10024
    #submission inet n - n - - smtpd
    # -o smtpd_enforce_tls=yes
    # -o smtpd_sasl_auth_enable=yes
    @@ -97,3 +98,32 @@
    #mailman unix - n n - - pipe
    # flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    # ${nexthop} ${user}
    +procmail unix - n n - 5 pipe
    + flags=R user=nobody argv=/usr/bin/procmail -t -m /opt/open-xchange/etc/admindaemon/procmailrc ${sender} ${user} ${recipient}
    +smtp-amavis unix - - n - 2 smtp
    + -o smtp_data_done_timeout=1200
    + -o smtp_send_xforward_command=yes
    + -o disable_dns_lookups=yes
    + -o max_use=20
    +127.0.0.1:10025 inet n - n - - smtpd
    + -o content_filter=procmail:spamcheck
    + -o local_recipient_maps=
    + -o relay_recipient_maps=
    + -o smtpd_restriction_classes=
    + -o smtpd_delay_reject=no
    + -o smtpd_client_restrictions=permit_mynetworks,reject
    + -o smtpd_helo_restrictions=
    + -o smtpd_sender_restrictions=
    + -o smtpd_recipient_restrictions=permit_mynetworks,rej ect
    + -o mynetworks_style=host
    + -o mynetworks=127.0.0.0/8
    + -o strict_rfc821_envelopes=yes
    + -o smtpd_error_sleep_time=0
    + -o smtpd_soft_error_limit=1001
    + -o smtpd_hard_error_limit=1000
    + -o smtpd_client_connection_count_limit=0
    + -o smtpd_client_connection_rate_limit=0
    + -o receive_override_options=no_header_body_checks,no_ unknown_recipient_checks
    +smtps inet n - n - - smtpd
    + -o smtpd_tls_wrappermode=yes
    + -o content_filter=smtp-amavis:[127.0.0.1]:10024
    diff: etc.bak/ssl/certs/5ed36f99.0: No such file or directory
    diff: etc/ssl/certs/5ed36f99.0: No such file or directory
    diff: etc.bak/ssl/certs/cacert.org.pem: No such file or directory
    diff: etc/ssl/certs/cacert.org.pem: No such file or directory

  7. #7
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by rjenster View Post
    hi,
    I just added a new mail domain through the admin GUI.
    unfortunately this messes up the following config files

    /etc/imapd.conf
    /etc/postfix/main.cf
    /etc/postfix/master.cf

    Even though the 'Enable Mailscanner' checkbox was unchecked the
    amavisd configuration was added to /etc/imapd.conf.
    I don't have amavisd running so this causes the whole mailsystem not
    working after postfix is restarted.
    Furthermore I've a custom path for my ssl certifcates and I don't want the admin gui to change it automatically.

    If the oxinstaller skript would work properly here it would add the maildomain automatically - then I could disable all elements except the 'Management' and 'Monitoring' sections in the admin gui to avoid such problems.

    Are you planning to change these hardcoded values/paths in the admin gui?

    [...]
    We are not going to make any such changes to the current stable branch as it is the code base for OX EE.

    I noticed, that you opened a bug. That's the right way to report such issues.

    If you have any patches, you could attach them to your bug reports.

    Please use severity enhancement to report missing features.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •