Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Dede Guest

    Thumbs down Problems on level "Open-Xchange Database"

    Hi everyone,

    I'm trying to get thru the OX installation, but after doing the hole set right, there is a problem when i execute this line in the Database section of the HOW TO:
    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=secret --admin-pass=secret --maildomain example.com
    the system give me this error :
    Server response:
    Unknown host: localhost; nested exception is:
    java.net.UnknownHostException: localhost
    admindaemon startup still in progress, waiting...
    keeps on trying to get thru? I had to ctrl+c out this loop ?

    if anyone can help

    When i installed my system (debian etch) i entered my domain name, i tryed to change the comand line with my domain at the end but nothing changed?

    in witch file can i change the host? where can i check the host?
    thx for u're help.

  2. #2
    sealtera Guest

    Default

    Quote Originally Posted by Dede View Post
    Hi everyone,

    I'm trying to get thru the OX installation, but after doing the hole set right, there is a problem when i execute this line in the Database section of the HOW TO:


    the system give me this error :

    keeps on trying to get thru? I had to ctrl+c out this loop ?

    if anyone can help

    When i installed my system (debian etch) i entered my domain name, i tryed to change the comand line with my domain at the end but nothing changed?

    in witch file can i change the host? where can i check the host?
    thx for u're help.
    Same error here. Could you help me?

    Thanks in advance

  3. #3
    dozoo Guest

    Exclamation one more....

    Hello,
    i used the manual at: "http://typo3.open-xchange.com/wiki/index.php?title=Open_Xchange_Installation" for installation.

    When i got to this point: "/opt/open-xchange/sbin/oxinstaller --oxdb-pass=xxxxx --admin-pass=xxxx --maildomain xxxx.dyndns.org"

    It ends nearly with the same wich was statet in first post!

    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    setting AUTO_TO_LOWERCASE_UID in /opt/open-xchange/etc/admindaemon/User.properties
    (Re)Starting Admin Daemon
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection timed out
    admindaemon startup still in progress, waiting...
    Pls help!!



    open-xchange-admin.log.0:
    05.08.2008 18:48:39 com.openexchange.admin.daemons.AdminDaemon initRMI
    SCHWERWIEGEND: Error creating RMI registry!
    java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection timed out
    at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEnd point.java:574)
    at sun.rmi.transport.tcp.TCPChannel.createConnection( TCPChannel.java:185)
    at sun.rmi.transport.tcp.TCPChannel.newConnection(TCP Channel.java:171)
    at sun.rmi.server.UnicastRef.newCall(UnicastRef.java: 306)
    at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)
    at com.openexchange.admin.daemons.AdminDaemon.initRMI (AdminDaemon.java:194)
    at com.openexchange.admin.daemons.Activator.start(Act ivator.java:91)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.start(AbstractBundle.java:256)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.st artBundles(EclipseStarter.java:1094)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.lo adBasicBundles(EclipseStarter.java:657)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.st artup(EclipseStarter.java:305)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:173)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ma in(EclipseStarter.java:150)
    Caused by: java.net.ConnectException: Connection timed out
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:520)
    at java.net.Socket.connect(Socket.java:470)
    at java.net.Socket.<init>(Socket.java:367)
    at java.net.Socket.<init>(Socket.java:180)
    at sun.rmi.transport.proxy.RMIDirectSocketFactory.cre ateSocket(RMIDirectSocketFactory.java:22)
    at sun.rmi.transport.proxy.RMIMasterSocketFactory.cre ateSocket(RMIMasterSocketFactory.java:128)
    at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEnd point.java:569)
    ... 17 more

    Thanks
    Dozoo
    Last edited by dozoo; 08-05-2008 at 06:50 PM.

  4. #4
    quentin Guest

    Smile Re:

    Try to check:
    1. # vim /etc/hosts
    127.0.0.1 localhost

    2. Try to login to mysql without pass
    # mysql
    You should get
    mysql>

    after run sudo /opt/open-xchange/sbin/oxinstaller --oxdb-pass=secret --admin-pass=secret --maildomain example.com

    Quentin



    Quote Originally Posted by Dede View Post
    Hi everyone,

    I'm trying to get thru the OX installation, but after doing the hole set right, there is a problem when i execute this line in the Database section of the HOW TO:


    the system give me this error :

    keeps on trying to get thru? I had to ctrl+c out this loop ?

    if anyone can help

    When i installed my system (debian etch) i entered my domain name, i tryed to change the comand line with my domain at the end but nothing changed?

    in witch file can i change the host? where can i check the host?
    thx for u're help.
    Last edited by quentin; 08-06-2008 at 10:25 AM. Reason: bad english

  5. #5
    dbalandin Guest

    Default java.net.UnknownHostException problem

    hi guys.
    I'm simply delete string:
    search localdomain
    in /etc/resolv.conf file and problem was fixed.
    It's problem of java name resolved mechanism.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •