Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2008
    Location
    Hamburg, Germany
    Posts
    50

    Default Beta 7, IMAP access broken or mis-configured

    After installing beta7 released today, I can't use IMAP anymore.

    10.07.2008 18:59-->Fehlermeldung: Missing parameter folder (MSG-0030,-2043158149-35)

    That's probably because some options in imap.properties might have changed or moved, but I don't know how...

    Code:
    # imap.properties
    # [...]
    imapLoginType=user
    imapMasterPassword=secret
    imapServer=127.0.0.1
    smtpServer=127.0.0.1
    smtpLocalhost=null
    imaps=false
    smtps=false
    imapCredSrc=session
    Worked flawlessly with beta 4

    Tanks in advance
    Sven

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Sven,

    did you cleared the browsercache after updating the whole stuff? Just in case...

    is there any .dpkg-old (in case you're using debian) or .rpmnew (in case you're using sles/rhel)
    available? Those files contain the previous or updated configuration.

    It would be very helpful if you could provide the error message (stacktrace) from the logfile at
    /var/log/open-xchange/open-xchange.log.0 when this error happens.

    Is it possible to get any network traffic information between ox and the IMAP server when this issue occurs?

    Greetings and thanks for reporting
    Last edited by Martin Heiland; 07-10-2008 at 07:00 PM.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi again,

    guess i've got the same issue like you when updating from 6.4.2 to 6.5... going to check that.

    SEVERE: MSG-0005 Category=10 Message=Configuration error: Missing user mail login exceptionID=-1260595392-32
    MSG-0005 Category=10 Message=Configuration error: Missing user mail login exceptionID=-1260595392-32
    at com.openexchange.mail.api.MailConfig.getLocalMailL ogin(MailConfig.java:320)
    at com.openexchange.mail.api.MailConfig.fillLoginAndP assword(MailConfig.java:286)
    at com.openexchange.mail.api.MailConfig.getConfig(Mai lConfig.java:196)
    at com.openexchange.mail.api.MailAccess.createMailCon fig(MailAccess.java:432)
    at com.openexchange.mail.api.MailAccess.getMailConfig (MailAccess.java:418)
    at com.openexchange.mail.api.MailAccess.connect(MailA ccess.java:304)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tConnection(MailServletInterfaceImpl.java:735)
    at com.openexchange.mail.MailServletInterfaceImpl.get Quotas(MailServletInterfaceImpl.java:565)
    at com.openexchange.ajax.request.QuotaRequest.mail(Qu otaRequest.java:161)
    at com.openexchange.ajax.request.QuotaRequest.action( QuotaRequest.java:115)
    at com.openexchange.ajax.Quota.doGet(Quota.java:107)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:596)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:414)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:156)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:120)
    at com.openexchange.ajp13.AJPv13RequestHandler.create Response(AJPv13RequestHandler.java:466)
    at com.openexchange.ajp13.AJPv13Connection.createResp onse(AJPv13Connection.java:197)
    at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:259)
    at java.lang.Thread.run(Thread.java:595)

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Got it,

    the previous OX 6.4.2 was configured OX:EE like, including mailserver configuration and all
    that stuff. Therefor another IMAP login mechanism was used, adding the users IMAP account
    name solved the problem for me - could you try this?

    etch:~# /opt/open-xchange/sbin/listuser -c 1 testuser -A oxadmin -P secret
    Id Name Displayname Email
    2 oxadmin Open-Xchange Administrator oxadmin@example.com
    3 postmaster Postmaster postmaster@example.com
    4 testuser Test User testuser@example.com


    /opt/open-xchange/sbin/changeuser -c 1 -i 4 --imaplogin testuser -A oxadmin -P secret

    greetings

  5. #5
    Join Date
    Jul 2008
    Location
    Hamburg, Germany
    Posts
    50

    Default

    Hi Martin,

    that was fast!

    /opt/open-xchange/sbin/changeuser -c 1 -i 4 --imaplogin testuser -A oxadmin -P secret
    That did the trick, thanks very much!

    So when adding new users with I have to make sure to create IMAP mailboxes on my own and also set --imapuser accordingly. Is this a bug or a feature?

    Regards,
    Sven

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Sven,

    this is neither a feature nor a bug, it's just plain reality that there are dozen of different mailservers out there and it is just not possible (or desirable) to interact with any mailserver configuration out of the box. Just to remember, with Open-Xchange 6.5 you get the same software hosting providers and system integration specialists use, it is no longer a one-platform solution.
    I can understand that it means additional work for a administrator to maintain mailboxes separately, but our goal is integration and enhancement, not replacement of an existing mail system.
    Greetings
    Last edited by Martin Heiland; 07-10-2008 at 08:16 PM.

  7. #7
    Join Date
    Jul 2008
    Location
    Hamburg, Germany
    Posts
    50

    Default

    Martin,

    I agree in having a collaboration server designed for this scale to be as individually configurable as possible.

    In my opinion, however, one might find a configuration option like imapCredSrc=session quite useful, so if an imaplogin is missing in the per-user options, the groupware could fall back to globally defined rules, e.g. use the session login credentials (testuser@context1.de, testpass1)

    in a hosting scenario, a per-context setting might also be quite useful.

    But that's your decision to make, not mine

    Regards, Sven

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •