Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Aug 2008
    Posts
    107

    Default Problem mit Attachments und Ansichten

    Hallo,

    die Installation von ox 6.5 hat dank der vielen Hinweise aus diesem Forum gut geklappt. Vielen Dank dafür.

    Nun habe ich aber zwei Probleme:

    1. Ich kann keine Mails mit Attachments verschicken. Im /var/log/open-xchange/open-xchange.log.0 steht:
    Code:
    Aug 7, 2008 7:53:54 PM com.openexchange.ajax.Mail$UploadQuotaChecker <init>
    WARNING: Upload Quota is less than zero. Using global server property "MAX_UPLOAD_SIZE" instead.
    Aug 7, 2008 7:53:54 PM com.openexchange.ajp13.AJPv13Listener run
    SEVERE: AJP-0001 Category=7 Message=loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(Ljavax/activation/DataHandler;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature exceptionID=-574543849-6
    AJP-0001 Category=7 Message=loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(Ljavax/activation/DataHandler;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature exceptionID=-574543849-6
            at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Listener.java:301)
            at java.lang.Thread.run(Thread.java:619)
    Caused by: java.lang.LinkageError: loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(Ljavax/activation/DataHandler;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature
            at com.openexchange.mail.mime.filler.MIMEMessageFiller.addMessageBodyPart(MIMEMessageFiller.java:958)
            at com.openexchange.mail.mime.filler.MIMEMessageFiller.fillMailBody(MIMEMessageFiller.java:672)
            at com.openexchange.smtp.filler.SMTPMessageFiller.fillMail(SMTPMessageFiller.java:165)
            at com.openexchange.smtp.SMTPTransport.sendMailMessage(SMTPTransport.java:424)
            at com.openexchange.mail.transport.MailTransport.sendMailMessage(MailTransport.java:142)
            at com.openexchange.mail.MailServletInterfaceImpl.sendMessage(MailServletInterfaceImpl.java:895)
            at com.openexchange.ajax.Mail.action(Mail.java:2729)
            at com.openexchange.ajax.AJAXServlet.fireUploadEvent(AJAXServlet.java:913)
            at com.openexchange.ajax.Mail.doPost(Mail.java:2636)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:616)
            at com.openexchange.ajax.AJAXServlet.service(AJAXServlet.java:414)
            at com.openexchange.ajax.SessionServlet.service(SessionServlet.java:156)
            at com.openexchange.ajax.PermissionServlet.service(PermissionServlet.java:98)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
            at com.openexchange.ajp13.AJPv13Request.response(AJPv13Request.java:120)
            at com.openexchange.ajp13.AJPv13RequestHandler.createResponse(AJPv13RequestHandler.java:466)
            at com.openexchange.ajp13.AJPv13Connection.createResponse(AJPv13Connection.java:197)
            at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Listener.java:259)
            ... 1 more
    Aug 7, 2008 7:54:08 PM com.openexchange.mail.mime.MIMEType2ExtMap init
    INFO: Loading MIME type file "file:/usr/lib/jvm/java-1.6.0-sun-1.6.0.u6/jre/lib/resources.jar!/META-INF/mimetypes.default"
    Aug 7, 2008 7:54:08 PM com.openexchange.mail.mime.MIMEType2ExtMap init
    INFO: Loading MIME type file "/opt/open-xchange/etc/groupware/mime.types"
    Aug 7, 2008 7:54:08 PM com.openexchange.mail.mime.MIMEType2ExtMap init
    INFO: MIMEType2ExtMap successfully initialized
    Den Parameter "Max_Upload_Size" hab ich auf 0 gestellt, nachdem mich auch ein Wert von 10000000 nicht weiter gebracht hat.

    2. Im Ordner "gesendete Objekte" in OX wird immer nur die letzte Mail angezeigt, obwohl bereits mehrere Mail (ohne Attachment) gesendet wurden und auch in entsprechenden Imap-Ordner liegen.

    Hoffentlich kann mir einer der schlauen Köpfe hier helfen ...

    Gruß
    881822

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    hast du vielleicht irgendwelche .jar Dateien aus anderen Quellen als den Paketen installiert? (in das ox verzeichniss kopiert)

    Laut http://java.sun.com/j2se/1.4.2/docs/...kageError.html:

    "... indicate that a class has some dependency on another class; however, the latter class has incompatibly changed after the compilation of the former class."

    Gruß
    Last edited by Martin Heiland; 08-07-2008 at 08:48 PM.

  3. #3
    Join Date
    Aug 2008
    Posts
    107

    Default

    Hallo,

    vielen Dank für die schnelle Antwort, Martin.

    Ich hab gerade nochmals mit einem frischen, minimalen SuSE11 installiert und keine .jar-Files aus anderen Quwellen hinzugefügt. Der Fehler bleibt der gleiche .

    Grz
    Rene

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Ok guck ich mir mal an, vielleicht kann man es reproduzieren

    Gruß

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo Rene,

    ich konnte das beschriebene Phänomen auf einem openSUSE11 nachstellen. Vermutlich liegt ein Problem im Bezug auf die Sun Java Version 1.6 bzw. IcedTea Java 1.7 vor. Als Workaround kannst du Sun Java 1.5 installieren, das hat zumindest bei mir den Fehler behoben.

    zypper rm java-1_6_0-sun
    zypper in java-1_5_0-sun

    rcopen-xchange-groupware restart
    rcopen-xchange-admin restart

    Gruß und danke für die Meldung
    Martin Braun
    Last edited by Martin Heiland; 08-08-2008 at 12:16 AM.

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    so, wir haben das Problem analysiert und können es auf folgenden Sachverhalt zurückführen:
    Es gibt eine Java-Komponente "JAF" aka. Java Activation Framework. Diese Komponente liefern wir mit den OX Paketen mit da sie unter Sun Java 1.5 nicht mitgeliefert wird. In diesem Fall wird also die von uns gelieferte Version genutzt.
    Mit Sun Java 1.6 bzw. IcedTea 1.7 ist diese Komponente nun direkt in die Java Distribution gewandert, so das wir eine Koexistenz von zwei Klassen haben die durch den Upload von Dateien als E-Mail Anhang eine Kollision auslösen. Ich habe das als Bug bei uns reported und hoffe das man bis zu einer Lösung des Problems den Workaround mit Java 1.5 in Erwägung zieht.

    Gruß und Danke nochmal
    Martin Braun
    Last edited by Martin Heiland; 08-08-2008 at 10:18 AM.

  7. #7
    Join Date
    Aug 2008
    Posts
    107

    Default

    Ich muss mich bedanken für die schnelle Lösung - tolles Forum und ein hilfsbereiter Martin!

    Grz
    Rene

  8. #8
    Join Date
    Aug 2008
    Posts
    107

    Default

    Toll, das Problem mit dem Versand von Mails mit Attachment ist damit erstmal vom Tisch. Leider sehe ich in ox im Ordner "gesendete Objekte" weiterhin nur die letzte Mail.

    Im File-System sind im Ordner aber viele Mails zu sehen.

    Wie kann denn das sein? In den Log-Files finde ich nichts.

    Grz
    Rene

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Welchen IMAP Server verwendest du denn?

  10. #10
    Join Date
    Aug 2008
    Posts
    107

    Default

    Welchen IMAP Server verwendest du denn?
    cyrus


    Hab doch was in der /var/log/open-xchange/open-xchange.log.0 gefunden:

    Aug 8, 2008 7:30:02 PM com.openexchange.control.internal.GeneralControl list
    INFO: control command: list
    Aug 8, 2008 7:32:59 PM com.openexchange.imap.command.FetchIMAPCommand handleResponse
    WARNING: Unexpected sequence number during FETCH command: Expected 3 but was 1
    Aug 8, 2008 7:32:59 PM com.openexchange.imap.command.FetchIMAPCommand handleResponse
    WARNING: Unexpected sequence number during FETCH command: Expected 3 but was 2
    Grz
    Rene
    Last edited by 881822; 08-08-2008 at 08:19 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •