Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    kld Guest

    Default oxinstaller on debian ecth

    hi ,
    When i try to run the oxinstaller on debian Etch i have the following error :


    initializing database (step 1/2)ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=-599192847-5
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Can't get connection to config DB. exceptionID=-599192847-6
    Exception in thread "main" java.lang.NullPointerException
    at com.openexchange.admin.storage.mysqlStorage.OXMail ServerMySQLStorage.addMailDomain(OXMailServerMySQL Storage.java:104)
    at com.openexchange.admin.rmi.impl.OXMailServerImpl.a ddMailDomain(OXMailServerImpl.java:299)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:247)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:223)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 26)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 179)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:132)
    at $Proxy0.addMailDomain(Unknown Source)
    at com.openexchange.admin.console.maildomain.Add.<ini t>(Add.java:104)
    at com.openexchange.admin.console.maildomain.Add.main (Add.java:152)
    done



    does anyone have an Idea ? did i missed some steps?
    NB: I tried without a password and with a password for mysql the mysql server at the install and when running the oxinstaller script.
    Last edited by kld; 03-27-2007 at 11:10 PM.

  2. #2
    neo Guest

    Default

    Hello

    did you recognize that the root user should have no password for mysql?

    There are several threads concerning this error.

  3. #3
    kld Guest

    Default

    thanks neo!
    i think i had a another problem with the workers properties two .. now i passed the config of mysql with some errors again but i will check on others threads beacause a saw tha i was not the only one . sorry for answering so late..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •