Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    techgoonsquad Guest

    Thumbs down Error: Connection refused to host: - when trying to registerserver

    Ubuntu 8.04 server with standard lamp install.

    I've been following the wiki and I've come to the step where registerserver is run. I run the following command:

    Code:
    sudo /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P password
    and I receive this error :

    Code:
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused
    If I restart the service (sudo /etc/init.d/open-xchange-admin stop/start) then it just sits and times for me and then kicks back the same error but instead of localhost it kicks out the IP of my dns (OpenDNS). I've tried restarting the open-xchange-groupware as well with the same results.

    there doesn't appear to be anything in var/logs/open-xchange

    my etc/hosts reads:

    Code:
    127.0.0.1 localhost
    my ifconfig reads:

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:07:95:d6:4f:82
              inet addr:192.168.0.225  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::207:95ff:fed6:4f82/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:423 errors:0 dropped:0 overruns:0 frame:0
              TX packets:386 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:42159 (41.1 KB)  TX bytes:112381 (109.7 KB)
              Interrupt:16 Base address:0xc800
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:47 errors:0 dropped:0 overruns:0 frame:0
              TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:3360 (3.2 KB)  TX bytes:3360 (3.2 KB)


    Any help would be much appreciated, thankyou.

  2. #2
    techgoonsquad Guest

    Default

    Well, still same problem, been working on this one all day. looks like apache wasn't detecting the server name correctly. I hard coded it to my domain in the apache conf with ServerName but it's still giving me the same error. The command takes 3-4 minutes to timeout. Erghh...

    Both services (admin/groupware) are starting fine. I'm really stumped by this one.

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    As long as the admindaemon does not start, the connection refuse error will persist.

    You need to find out, why the admin daemon does not start.

    The answer might be in the trace in the admin log /var/log/open-xchange/open-xchange-admin.log.0.

    P.S.: no need to use sudo

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •