Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    altariq Guest

    Default New clean install, new errors :(

    A complete clean new install, step by step to wiki and now this:

    Code:
    root@wullbrandtundseele:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pas
    s=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon
    done
    initializing database (step 2/2)
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    done
    setting up the system
    creating certificates
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    chmod: Zugriff auf â/etc/ssl/certs/eecert.pemâ nicht möglich: No such file or directory
    chmod: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    chgrp: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    done

  2. #2
    spiekey Guest

    Default

    Quote Originally Posted by altariq View Post
    A complete clean new install, step by step to wiki and now this:

    Code:
    root@wullbrandtundseele:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pas
    s=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
    initializing database (step 1/2)
    done
    Have a look in the wiki, i added a note yesterday about mysql auth:

    IV.3. Open-Xchange Database

    ... Adjust your MySQL authentification information (OXDB_USER_*) in /opt/open-xchange/sbin/oxinstaller and execute: ....

  3. #3
    sledge0303 Guest

    Default

    The first error with mysql isn´t that bad.

    You must configure first after basic OX installments:
    1. sasl
    2. cyrus

    THEN, all steps have finished just perform this

    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=....
    Of course it reporst first a mysql error, you can ignore safely.

    If you want be sure it is working, force reinstall of usernames/passwords with

    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=....-f
    HTH

    Bei mir hat es so immer geklappt

    Nochmal auf deutsch, erst alles konfigurieren, danach oxinstaller ausführen.
    MySQL Fehler kannst ignorieren oder mit der Option '-f' erneut durchführen. Es wird definitiv keine Fehlermeldung erscheinen bei -f wenn alles korrekt eingerichtet wurde... es sei denn die Jungs haben die Sourcen wieder umgeschmissen im laufe des Vormittags
    Last edited by sledge0303; 03-30-2007 at 11:42 AM.

  4. #4
    altariq Guest

    Default

    Also soll ich zuerst die Mailserverconfig durchführen?
    Dann währe es doch schön, wenn es im Wiki auch so angeordnet ist. Ich trau mich nicht, darin rumzueditieren sonst siehts nachher blöd aus.
    Das, was spiekey geschrieben hat, versteh ich irgendwie überhaupt nicht...

  5. #5
    sledge0303 Guest

    Default

    Ich versteh schon was er meint, versuche aber zuerst die Basispakete zu installieren, danach fängst an mit dem sasl und danach Cyrus, genauso wie es im Wiki beschrieben ist.
    Mal eine andere Frage, welches OS benutzt du? Etch?

    Bei Etch musste erstmal das durchführen

    nano /etc/default/saslauthd
    START=yes
    /etc/init.d/saslauthd start
    Damit hast schon mal eine Fehlerquelle ausgeräumt.

    Danach installierst komplett die Basispakete incl. Docroot incl. Webdaemon.

    danach in Schritten:

    /etc/init.d/open-xchange-admin start
    /etc/imapd.conf
    /etc/init.d/cyrus2.2 restart
    /etc/pam.d/imap
    /etc/libnss-mysql.cfg
    /etc/libnss-mysql-root.cfg
    /etc/init.d/saslauthd restart
    /etc/init.d/cyrus2.2 restart
    /opt/open-xchange/sbin/oxinstaller.... [-f]
    /etc/init.d/open-xchange-groupware start

    Danach dürftest dich mit 'oxadmin' einloggen können.

    Ich kann es momentan nicht, weil irgendetwas bei der Config des Ligties fehlt...
    Muss mir den Fall heute nochmal genau ansehen.
    Das Wiki kannst als Howto nicht nehmen, du musst zuerst durchlesen was gemacht werden muss und danach die Schritte einplanen. Wichtig ist auch die Ausgaben während der Installation von Basispaketen zu beobachten, da kannst auch ersehen wo was klemmen könnte später
    Last edited by sledge0303; 03-30-2007 at 12:00 PM.

  6. #6
    altariq Guest

    Default

    Hab ich jetzt gemacht. Bei installer kommen trotzdem diese Medlungen:
    Ich hoffe, dass die nicht relevant sind.

    Code:
    (Re)Starting Admin Daemon
    done
    initializing database (step 2/2)
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    done
    setting up the system
    creating certificates
    Error:
     Connection refused to host: 82.165.97.31; nested exception is:
            java.net.ConnectException: Connection refused
    chmod: Zugriff auf â/etc/ssl/certs/eecert.pemâ nicht möglich: No such file or directory
    chmod: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    chgrp: Zugriff auf â/etc/ssl/private/eekey.pemâ nicht möglich: No such file or directory
    done

  7. #7
    altariq Guest

    Default

    Anmelden geht auch nicht. Was mich schon bei meiner letzten Installation gewundert hat ist das hier:

    Build: 0, 2007-03-30 12:48:01

    im Anmeldefenster.

    Der will auf var/www/ajax/ox.html zugreifen und die gibt es nicht.
    Ich glaub ich verpass mir selbst Urlaub ...

  8. #8
    robotronick Guest

    Default

    Hallo,

    kann sein, dass die concurrent.jar nicht in Ordnung ist...
    Versuch es mal mit der im Anhang (.zip in .jar umbennen).

    Einfach nach /opt/open-xchange/lib/ kopieren und die bestehende überschreiben (bzw. vorher ne sicherungskopie machen)

    Danach noch mal oxinstall versuchen...

    Viele Grüße
    Axel
    Attached Files Attached Files
    Last edited by robotronick; 03-30-2007 at 03:18 PM.

  9. #9
    altariq Guest

    Default

    nach vielen Versuchen haben wir es doch rausbekommen. Es war eigentlich nur eine falsche Namensauflösung in der /etc/hosts
    Jetzt klappt es

  10. #10
    RockHound Guest

    Default

    Was genau hast du geändert? Ich hänge hier am gleichen Problem.

    Gruß

    Martin

    -- bei mir war es die concurrent.jar --
    Last edited by RockHound; 04-26-2007 at 02:21 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •