Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    oprocopio Guest

    Default open-xchange-groupware doesn't start with latest release

    Hi there,

    Today I have downloaded the latest sources and successfully compiled.

    But now I can't start open-xchange-groupware

    Code:
    /etc/init.d/open-xchange-groupware status
    Checking for Open-Xchange Groupware: not running
    do you made some changes at the DB?
    If yes, how I can update the DB without delete everything?

    thanks,

    orlando

  2. #2
    mackie Guest

    Default

    Yea, same here. No log errors. End of the strace:

    Code:
    tail -n 100 strace_output |grep -v gettimeofday
    futex(0x80c87bc, FUTEX_WAKE, 1)         = 1
    futex(0x80c87b8, FUTEX_WAKE, 1)         = 1
    futex(0x805cab0, FUTEX_WAKE, 1)         = 1
    stat64("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/sunjce_provider.jar", {st_mode=S_IFREG|0644, st_size=158417, ...}) = 0
    stat64("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/sunjce_provider.jar", {st_mode=S_IFREG|0644, st_size=158417, ...}) = 0
    open("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/sunjce_provider.jar", O_RDONLY|O_LARGEFILE) = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=158417, ...}) = 0
    _llseek(3, 0, [158417], SEEK_END)       = 0
    mmap2(NULL, 158417, PROT_READ, MAP_SHARED, 3, 0) = 0xaad10000
    close(3)                                = 0
    stat64("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/localedata.jar", {st_mode=S_IFREG|0644, st_size=803846, ...}) = 0
    stat64("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/localedata.jar", {st_mode=S_IFREG|0644, st_size=803846, ...}) = 0
    open("/usr/lib/jvm/java-sun-1.5.0.10/jre/lib/ext/localedata.jar", O_RDONLY|O_LARGEFILE) = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=803846, ...}) = 0
    _llseek(3, 0, [803846], SEEK_END)       = 0
    mmap2(NULL, 803846, PROT_READ, MAP_SHARED, 3, 0) = 0xaac4b000
    close(3)                                = 0
    futex(0x80c87bc, FUTEX_WAKE, 1)         = 1
    futex(0x80c87b8, FUTEX_WAKE, 1)         = 1
    futex(0x805cab0, FUTEX_WAKE, 1)         = 1
    futex(0x80c87bc, FUTEX_WAKE, 1)         = 1
    futex(0x80c87b8, FUTEX_WAKE, 1)         = 1
    futex(0x805cab0, FUTEX_WAKE, 1)         = 1
    stat64("/opt/open-xchange/@libdirpath@/*.jar", 0xbfe1de18) = -1 ENOENT (No such file or directory)
    stat64("/opt/open-xchange/ComfireServer.class", 0xbfe1e29c) = -1 ENOENT (No such file or directory)
    write(2, "Exception ", 10)              = 10
    write(2, "in thread \"main\" ", 17)     = 17
    write(2, "java.lang.NoClassDefFoundError: "..., 45) = 45
    write(2, "\n", 1)                       = 1
    futex(0x80eb854, FUTEX_WAIT, 1, NULL)   = 0
    futex(0x805c360, FUTEX_WAKE, 1)         = 0
    futex(0xb79c8ce0, FUTEX_WAKE, 1)        = 1
    mmap2(0xbfc22000, 12288, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = 0xbfc22000
    futex(0x80bbe7c, FUTEX_WAKE, 1)         = 1
    futex(0x80bbe78, FUTEX_WAKE, 1)         = 1
    futex(0x805c1f0, FUTEX_WAKE, 1)         = 1
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    unlink("/tmp/hsperfdata_root/31506")    = 0
    exit_group(1)                           = ?
    What is buildnew.xml ? Whe should use it ?

  3. #3
    Francisco Laguna Guest

    Default

    Looks like the startscript is a little out of order. Try changing the /opt/open-xchange/sbin/open-xchange-groupware script and substitute @libdirpath@ with 'lib'

  4. #4
    mackie Guest

    Default

    Ok, latest snapshot and ... it works. Thank you

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •