Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    sedeke Guest

    Default Adding mail alias error

    when I want to set new alias with
    changeuser -c 2 -A oxadmin -P geheim -u user2 --aliases user2alias@druckereiclassen.de

    I got following error:
    Server response:
    primaryMail, Email1 and defaultSenderAddress must be present in set of aliases.

    What I'm making wrong??

    I wanted to change the main mail adress, so I have tu set the new mail adress to aliases before using option -e and imaplogin.
    When creating the user I made a mistake, so trying to correct it.

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by sedeke View Post
    when I want to set new alias with
    changeuser -c 2 -A oxadmin -P geheim -u user2 --aliases user2alias@druckereiclassen.de

    I got following error:
    Server response:
    primaryMail, Email1 and defaultSenderAddress must be present in set of aliases.

    What I'm making wrong??

    I wanted to change the main mail adress, so I have tu set the new mail adress to aliases before using option -e and imaplogin.
    When creating the user I made a mistake, so trying to correct it.
    The address set in primaryMail, Email1 and defaultSenderAddress must be one of the addresses set in the aliases. So if you replace all existing aliases with a new one, what you are doing with the command above, you need to specify all the other addresses also within that command.

    E.g.:

    Code:
    changeuser -c 2 -A oxadmin -P geheim -u user2 \
    --aliases user2alias@druckereiclassen.de \
    -e user2alias@druckereiclassen.de \
    --email1 user2alias@druckereiclassen.de --defaultsenderaddress user2alias@druckereiclassen.de

  3. #3
    sedeke Guest

    Default

    Ok my fault.

    I thought the option -a give add one alias. Not replacing the others.
    So when I want to give or to add a new one I have to separate them by ","??
    e.G.
    -a alias1@test.de,alias2@test.de

    Is this right?

  4. #4
    sedeke Guest

    Default

    Yes I'm right. Have tested it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •