Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    joschuan Guest

    Unhappy ox install Connection refused to host java net

    After 400 cigarettes and about 100 hours, three new installations i got every time this
    error by the command oxinstaller .......

    (Re)Starting Admin Daemon
    Error:
    Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused


    I use opensuse 10.2
    libs seem to be ok
    mysql ok
    apache2 ok
    sasl2 ok
    hosts checked
    the installations are build successfully.

    everything looks fine and now I don't have any idea.

    ps: sorry for my terrible english.

  2. #2
    joschuan Guest

    Exclamation Additional Information

    The message "initialize database (2/2)" don't appear.
    Seem it hangs in allpluginsloaded

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Did you made sure the MySQL database is configured without a password for user "root"? Please activate the debug logging of MySQL to track down this to the original error, if the database did not get any query the problem might occur before.

  4. #4
    joschuan Guest

    Smile Geschafft

    Es waren bei mir einige Fehler noch enthalten. Habe nochmals neu installiert
    Folgendes
    - nicht exakt die Version : mysql-connector-java-3.1.13-bin.jar genommen
    - ANT 1.6 durch 1.7 ersetzt.

    und natürlich die vielen Änderungen vorher.

  5. #5
    bifi Guest

    Default

    hi there,

    i get the exact same error when executing the oxinstaller script. i use mysql-connector-java-3.1.14-bin.jar, is that really a problem? where can i find mysql-connector-java-3.1.13-bin.jar?
    I read in the wiki talk page that there is a hardcoded link to 3.1.13 in oxinstaller but creating a symlink did not solve the problem.

    the newest file in /var/log/mysql is mysql-bin.000043 when i open it using
    mysqlbinlog i get this:
    Code:
    CREATE TABLE context_server2db_pool (
        server_id INT4 UNSIGNED NOT NULL,
        cid INT4 UNSIGNED NOT NULL,
        read_db_pool_id INT4 UNSIGNED NOT NULL,
        write_db_pool_id INT4 UNSIGNED NOT NULL,
        db_schema VARCHAR(32) NOT NULL,
        PRIMARY KEY(`cid`, `server_id`),
        INDEX (write_db_pool_id),
        INDEX (server_id),
        INDEX (db_schema),
        FOREIGN KEY(`cid`) REFERENCES context (`cid`) ON DELETE CASCADE ON UPDATE CASCADE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_general_ci/*!*/;
    DELIMITER ;
    # End of log file
    unfortunately I don't have debugging compiled into mysql, cause i'm running the ubuntu version of mysqld.

    so now i'm looking into org.eclipse.osgi_3.2.2.ox.jar, I cannot find this exact version, does org.eclipse.osgi_3.2.2.R32x_v20070118.jar work as well, or shall i try another one?

    and for java: i'm running the ubuntu distributed sun-java-1.6
    ant is version 1.6.5.

    in the mysql databes the user openexchange exists and a configdb database exists.

    i will investigate into it further.

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    yes, it is important to use the exact filename which is given at the installation guide because the compile process will search for these files. Just rename the mysql-connector-java-3.1.14-bin.jar to mysql-connector-java-3.1.13-bin.jar and same with the OSGi framework .jar. I know this is a bit confusing, but the required .jar files are written with the exact filename to the build.xml file which is used by ant to compile.
    For MySQL logging: You do not need to compile with debug flags, just activate the query log at the my.cf file - its that entry with the "performance killer" warning - this option and a restart of mysql shows you all transactions logged to /var/log/mysql/mysql.log on a debian-like system.

    Greetings

  7. #7
    bifi Guest

    Default

    seems like it does not get to open a connection at all:

    Code:
    root@cuubserv1:/var/log/mysql# tail mysql.log
        read_db_pool_id INT4 UNSIGNED NOT NULL,
        write_db_pool_id INT4 UNSIGNED NOT NULL,
        db_schema VARCHAR(32) NOT NULL,
        PRIMARY KEY(`cid`, `server_id`),
        INDEX (write_db_pool_id),
        INDEX (server_id),
        INDEX (db_schema),
        FOREIGN KEY(`cid`) REFERENCES context (`cid`) ON DELETE CASCADE ON UPDATE CASCADE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_general_ci
                          8 Quit       
    root@cuubserv1:/var/log/mysql#
    as for the filenames, i renamed the links in all the build.xml files before compiling, and everything compiled cleanly. I'll try to create symlinks with the names as stated in the installation manual, and compile again. I suspect that there are some more hardcoded references in the code.

    I'll report when i'm done.

    regards
    tobias

  8. #8
    bifi Guest

    Default

    back again,

    all this did not get me any further unfortunately, I have symlinks in /opt/open-xchange/lib with the names of the installation manual pointing to the actual versions which i installed. I did not revert the references in the build.xml files however. After recompiling open-xchange and open-xchange-admin, the problem remains. maybe i need to give ANT an option to force overwrite of the previous installation.

    the mysql logs don't show anything about failed connections. There is a comment in my.cnf that says error logs go to syslog, and but /var/log/syslog does not mention mysql at all. there are two more files in /var/log: mysql.log and mysql.err, which are both empty.
    This is driving me nuts now. maybe i'll include some echos in the /opt/open-xchange/etc/admindaemon/oxfunctions.sh script.

    Or maybe i am stupid and need to compile every package of the admin* section by hand?
    Well I'll do a CVS update first, then we'll see.

    tobias

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    just try to _rename_ the .jar files, not via symlinks. You do not need to modify the build.xml if you do so. Note that all jar files are used by groupware & admindaemon source files. You only have to compile the "open-xchange", "open-xchange-admin" and "open-xchange-gui" with the ant options shown at the wiki. You do not need to compile each open-xchange-admin-* directory as they are called by the open-xchange-admin build files. Does the compile process throw any error message? And please try with ANT 1.7

    Greetings

  10. #10
    bifi Guest

    Default

    i just executed ant clean and it removed /opt/open-xchange/lib
    thank you for that...
    to everyone: make backups of those files!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •