Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    kipper Guest

    Default SLES V10 SP2 and OX LDAP Sync Compatibility

    Hi,

    I am trying to install OX LDAP Sync 1.0.0-2.1 onto Suse Linux Enterprise Server V10 SP2 and get the following error:

    Dependancy resolution failed
    Unsolved dependencies:
    Installing oxldapsync-1.0.0-2.1.noarch[local packages]
    Perl-log-dispatch-2.18-6.2.sle10.rf.noarch[local packages] provides
    perl-log-dispatch == 2.18-6.2.sle10.rf, but is uninstallable.
    Try installing it on its own for more details.
    There are no installable providers of perl-log-dispatch for oxldapsynch-1.0.0-2.1.noarch[local packages]


    I have tried to download and install perl-log-dispatch and get a similar perl error.

    Thanks,

    Chris.

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Well, that's what I get when searching for perl-Log-Dispatch:

    Code:
    zypper search perl-Log-Dispatch
    Restoring system sources...
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6/unsupported/repo/SLES10) is unsigned, continue? [y/n]: y
    Parsing metadata for SLES10-SP2-Online...
    Parsing metadata for SUSE Linux Enterprise Software Development Kit 10 SP1...
    Parsing metadata for SUSE Linux Enterprise Server 10 SP1...
    Parsing metadata for SLE10-SDK-SP2-Online...
    Parsing metadata for SLE10-SDK-SP2-Updates...
    Parsing metadata for SLES10-SP2-Updates...
    Parsing metadata for UNSUPPORTED...
    Parsing metadata for 20080204-091903...
    S | Catalog                                               | Type    | Name              | Version   | Arch
    --+-------------------------------------------------------+---------+-------------------+-----------+-----
    i | SUSE Linux Enterprise Software Development Kit 10 SP1 | package | perl-Log-Dispatch | 2.11-15.4 | i586
    Your version of perl-Log-Dispatch seems to be totally different: 2.18-6.2.sle10.rf

    Please post your output of zypper search perl-Log-Dispatch
    and the output of

    zypper sl

  3. #3
    kipper Guest

    Default

    Thank you for your reply.

    If it helps Oxldapsync-1.0.0-2.1.noarch.rpm was installed manually when the error was displayed as I did not have access to an Internet connection.

    Yesterday I setup SLES V10 SP2 on a laptop and took it home giving me access to an Internet connection.

    I ran the command zypper sa http://software.open-xchange.com/OX6...ed/repo/SLES10
    This gave the following output:

    server:~ # zypper sa http://software.open-xchange.com/OX6...ted/repo/SLES1 0
    2991 zmd
    ZENworks Management Daemon is running.
    WARNING: this command will not synchronize changes.
    Use rug or yast2 for that.
    Determining http://software.open-xchange.com/OX6...ed/repo/SLES10 source type...
    http://software.open-xchange.com/OX6...ed/repo/SLES10 is type YUM
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Added Installation Sources:
    [x]* http://software.open-xchange.com/OX6...ed/repo/SLES10 (http://softwa re.open-xchange.com/OX6/unsupported/repo/SLES10)
    server:~ # zypper sa http://software.open-xchange.com/OX6...ted/repo/SLES1 0 UNSUPPORTED
    2991 zmd
    ZENworks Management Daemon is running.
    WARNING: this command will not synchronize changes.
    Use rug or yast2 for that.
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Determining http://software.open-xchange.com/OX6...ed/repo/SLES10 source type...
    http://software.open-xchange.com/OX6...ed/repo/SLES10 is type YUM
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Added Installation Sources:
    [x]* UNSUPPORTED (http://software.open-xchange.com/OX6...ed/repo/SLES10)
    server:~ # zypper install oxldapsync Restoring system sources...
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Parsing metadata for UNSUPPORTED...
    Parsing metadata for SUSE Linux Enterprise Server 10 SP2...
    Parsing metadata for http://software.open-xchange.com/OX6...ted/repo/SLES1 0...
    Parsing RPM database...
    1 Problems:
    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to mis sing dependencies

    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to mis sing dependencies
    There are no installable providers of perl-Text-CSV_XS for oxldapsync-1.0.0-2.1 .noarch[UNSUPPORTED]
    Solution 1: do not install oxldapsync
    do not install oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 2: Ignore this requirement just here
    number, (r)etry or (c)ancel> r
    1 Problems:
    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to mis sing dependencies

    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to mis sing dependencies
    There are no installable providers of perl-Text-CSV_XS for oxldapsync-1.0.0-2.1 .noarch[UNSUPPORTED]
    Solution 1: do not install oxldapsync
    do not install oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 2: Ignore this requirement just here
    number, (r)etry or (c)ancel> 2
    Applying solution 2
    1 Problems:
    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to missing dependencies

    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to missing dependencies
    There are no installable providers of perl-Log-Log4perl for oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 1: do not install oxldapsync
    do not install oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 2: Ignore this requirement just here
    number, (r)etry or (c)ancel> 2
    Applying solution 2
    1 Problems:
    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to missing dependencies

    Problem: oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED] cannot be installed due to missing dependencies
    There are no installable providers of perl-Log-Dispatch for oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 1: do not install oxldapsync
    do not install oxldapsync-1.0.0-2.1.noarch[UNSUPPORTED]
    Solution 2: Ignore this requirement just here
    number, (r)etry or (c)ancel> 2
    Applying solution 2
    Summary:
    <install> [S1:0][package]oxldapsync-1.0.0-2.1.noarch
    Continue? [y/n]: y
    Downloading: [S1:0][package]oxldapsync-1.0.0-2.1.noarch, 16.8 K(63.0 K unpacked)
    Installing: [S1:0][package]oxldapsync-1.0.0-2.1.noarch
    [S1:0][package]oxldapsync-1.0.0-2.1.noarch Subprocess failed. Error: RPM failed: error: Failed dependencies:
    perl-Text-CSV_XS is needed by oxldapsync-1.0.0-2.1.noarch
    perl-Log-Log4perl is needed by oxldapsync-1.0.0-2.1.noarch
    perl-Log-Dispatch is needed by oxldapsync-1.0.0-2.1.noarch


    Invalid object
    Invalid object
    Installing: [S1:0][package]oxldapsync-1.0.0-2.1.noarch
    server:~ #



    I then ran the command zypper search perl-Log-Dispatch you requested, the output is below:

    server:~ # zypper search perl-Log-Dispatch
    Restoring system sources...
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Not found: Media Exception
    Not found: Media Exception
    /repodata/repomd.xml (http://software.open-xchange.com/OX6...rted/repo/SLES 10) is unsigned, continue? [y/n]: y
    Parsing metadata for UNSUPPORTED...
    Parsing metadata for SUSE Linux Enterprise Server 10 SP2...
    Parsing metadata for http://software.open-xchange.com/OX6...ted/repo/SLES1 0...
    No packages found.
    server:~ #


    Thanks,

    Chris.

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Now I see the problem.

    You need the SLES10 SDK also.

    I added that to the installation instructions:

    http://www.open-xchange.com/wiki/ind...c_Guide#SLES10
    Last edited by Carsten Hoeger; 10-28-2008 at 02:42 PM.

  5. #5
    kipper Guest

    Default

    Carsten thanks for your help.

    I have installed the perl SDK off the kit and installed Oxldapsync and modified the oxldap conf file.

    How do I go about syncing ldap with Open Exchange Appliance Edition, do I need to run a command?


    Thanks,

    Chris.
    Last edited by kipper; 10-29-2008 at 07:55 PM.

  6. #6
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by kipper View Post
    Carsten thanks for your help.

    I have installed the perl SDK off the kit and installed Oxldapsync and modified the oxldap conf file.

    How do I go about syncing ldap with Open Exchange Appliance Edition, do I need to run a command?
    Appliance Edition does not require an additional sync. It already ships with an integrated LDAP Server.

  7. #7
    kipper Guest

    Default

    We will be using SLES 10 as a PDC, DNS and DHCP server. I was also planning on it being an LDAP server and syncing with Open Exchange AE. I saw the AE edition and it looked ideal as it was an out of the box solution. We are planning to migrate from Microsoft Small Business Server 2003 to a Linux system and I have minimal Linux experience. I take it LDAP should be run on the PDC therefore I have two options, to use AE as a PDC, LDAP and groupware server or to use SLES as a PDC and LDAP server and use Open Exchange Server Edition for Groupware?

    Can you tell me the size of the Open Xchange Server download as I may download it using a mobile data card if its not too large. Alternatively can I download an image from anywhere?


    Thanks,

    chris.
    Last edited by kipper; 10-30-2008 at 12:41 PM.

  8. #8
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by kipper View Post
    We will be using SLES 10 as a PDC, DNS and DHCP server. I was also planning on it being an LDAP server and syncing with Open Exchange AE. I saw the AE edition and it looked ideal as it was an out of the box solution. We are planning to migrate from Microsoft Small Business Server 2003 to a Linux system and I have minimal Linux experience. I take it LDAP should be run on the PDC therefore I have two options, to use AE as a PDC, LDAP and groupware server or to use SLES as a PDC and LDAP server and use Open Exchange Server Edition for Groupware?
    OX-AE is an all-in-one solution which provides all you seem to need. No need of an additional LDAP or SMB Server as you plan to do it using SLES10.

    Can you tell me the size of the Open Xchange Server download as I may download it using a mobile data card if its not too large. Alternatively can I download an image from anywhere?
    OX-AE ships as an ISO image (Size ~= 2GB).

    Just register here, if you want to have a look as soon as it ships:

    http://www.open-xchange.com/en/produ...on-en/download

    OX-SE consists of our Open-Xchange Server 6 Packages, size ~= 121MB including online help.

    http://www.open-xchange.com/wiki/ind...ed_on_packages

  9. #9
    kipper Guest

    Default

    Carsten,

    Thank you for your advice.

    I managed to get Open Xchange Server up and running over the weekend, there is an error whilst using the web interface although for a first attempt I am very happy. I am going to try Oxtender and once that is working I will do a fresh install.

    I have two servers at my disposal but I am unsure which machine to run LDAP on?

    The intended configurations are as follows:

    Server 1:

    Operating system:
    SLES V10 SP2

    Roles:
    Primary Domain Controller
    DNS Server
    DHCP Server
    LDAP Server?

    Server 2:

    Operating system:
    SLES V10 SP2

    Roles:
    Open Xchange Server
    Ldap Server?


    Thanks,

    Chris.

  10. #10
    kipper Guest

    Default

    I have installed Oxtender on a client machine with Outlook 2003. I am using Oxtender 6.2.0.16 and received the error "Unsupported Method" whilst attempting to connect to the OXserver. Is this due to using an unsupported version of Oxtender, if so is it possible to get a trial license of a supported version for testing.

    Thanks,

    Chris.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •