Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default Upgrade von 6.4.2 auf 6.6.0

    Hallo,

    ich habe zur Zeit zwei Server mit der Version 6.4.2 laufen, da ich diese gerne Upgraden würde auf die Paket basierte Version 6.6.0 habe ich um dies nicht an einem Produktivsystem testen zu müssen einen Testserver aufgesetzt.

    Der Testserver ist voll Funktionsfähig und wurde meinerseits auch entsprechend getestet. Des Weiteren habe ich mehrere Test User angelegt.

    Als nächstes habe ich mittels einer Migrations Anleitung von Martin das Paket basierte 6.6.0 installiert.
    http://www.open-xchange.com/forum/showthread.php?p=7185

    Auch hier ist es zu keinen Fehlern bei der Installation gekommen.

    Wenn ich jedoch jetzt versuche die einzelnen Benutzer mittels

    /opt/open-xchange/sbin/changeuser -c 1 -i 4 --imaplogin testuser -A oxadmin -P secret

    auf das neue System einzustellen, bekomme ich jedesmal die Meldung das die Authorisierung fehlschlug.

    Einen Fehler kann ich bislang noch nicht erkennen und würde mich über Anregungen und Tipps freuen.

    MfG

    outlow

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    ganz dumme Frage - hast du vielleicht ein anderes Passwort für den Nutzer "oxadmin" gewählt? Ansonsten wäre ein Auszug aus der open-xchange-admin.log sicherlich ganz interessant.

    Gruß
    Martin

  3. #3
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Hi,

    bin davon ausgegangen das ich meine bestehendes Passwort anstelle von secret einsetzen muss.

    Einen auzug der Logfiles kann ich leider erst heute Abend einstellen.

  4. #4
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    so anbei das Log File:

    open-xchange-admin.log.0:
    27.10.2008 22:28:42 com.openexchange.admin.rmi.impl.OXUser getModuleAccess
    SCHWERWIEGEND: Authentication failed
    com.openexchange.admin.rmi.exceptions.InvalidCrede ntialsException: Authentication failed
    at com.openexchange.admin.rmi.impl.BasicAuthenticator .doAuthentication(BasicAuthenticator.java:130)
    at com.openexchange.admin.rmi.impl.OXUser.getModuleAc cess(OXUser.java:948)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)
    sollten noch weitere Infos benötigt werden, so teilt mir das bitte mit und ich werde entsprechendes Posten

  5. #5
    Join Date
    Feb 2007
    Location
    NRW - Germany
    Posts
    10

    Default

    Hi

    vielleicht Leer- und/oder Sonderzeichen im Passwort? Setz dein Passwort mal in "PASS" Anführungszeichen...

    Nur der Sicherheit halber... du brauchst das oxadmin-Passwort, nicht das vom Testuser...

    Gruß
    David

  6. #6
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Hi,

    da dies ein Testserver ist, ist hier das oxadmin Passwort und das Passwort der User gleich. Somit sollte es auch zu keiner Verwechselung kommen.

    Es sind keine Leerzeichen (sind in Passwörtern sowieso nicht zugelassen) und auch keine Sonderzeichen (bitte keine Belehrung über den Sinn von Passwörtern dies ist ein Testserver im nicht öffentlichen Raum) enthalten.

    Da die Passwort eingabe im Klartext erfolgt schließe ich eine falsch eingabe aus.

    Ein setzen in Anführungsstriche brachte das gleiche Resultat.

    Fehlt ggf. ein Schritt in der Anleitung von Martin? Frage nur da ja bei einer Neuinstallation doch noch ein paar Schritte wie registerserver etc. dazu gekommen sind.

    MfG

    outlow

  7. #7

    Default Admin settings

    Hi,

    I had a problem that sounds similar like this. After an update ther was in the config file "admindaemon/system.properties" the wrong servername (key: SERVER_NAME) entered and so te admin tools can`t access the right database tables. Myabe this is also your problem.

    Kind regards
    mmlitz

  8. #8
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    that it

    the server was misspelled

    Thank you,

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •