Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    ghosttalker Guest

    Question SSL/TLS Zertifikate und imaps

    Hallo,
    Ich habe nun erfolgreich OX6 installiert und konnte mich auch ohne Probleme einloggen. Da ich aus Sicherheitsgründen SMTP Auth mit SASL verwenden möchte, muß ich nun über SSL/TLS die Verbindung herstellen, da sonst das Passwort falsch ist (Verschlüsselungsproblematik cyrus/postfix).

    Dazu würde ich gerne wissen ob es dafür ausreicht die Datei:
    /opt/open-xchange/etc/groupware/javamail.properties
    zu ändern um dort TSL und SMTP Auth zu aktivieren:

    ...
    mail.smtp.auth=true
    mail.smtp.starttls.enable=true
    mail.imap.starttls.enable=true
    mail.imap.sasl.enable=true
    ...

    Außerdem möchte ich wissen wo SSL-Zertifikate zu hinterlegen sind, bzw wo ich das entsprechende Zertifikat auswählen/konfigurieren kann. Leider habe ich dazu keine Informationen in der Doku gefunden.

    Gruß Pit

  2. #2
    Join Date
    Feb 2007
    Location
    Olpe, Germany
    Posts
    88

    Default

    Die von Dir genannten Settings sollten ausreichen. Zudem musst Du (je nach eingesetzter OX Version) die Einstellung "imapServer" des Benutzers in der DB in "imaps://yourimapserver:993" ändern. Kannst Du bequem mit den Admin-Scripts machen.

    Per Default brauchst Du keine Zertifikate einrichten. Wäre technisch möglich, aber der Aufwand ist nicht zu unterschätzen und lohnt nicht. Die Verschlüsslung funktioniert auch so da per Default alle Zertifikate akzeptiert werden.

  3. #3
    raix Guest

    Default

    Hi,

    I've changed the properties

    Code:
    mail.imap.starttls.enable=true
    mail.imap.sasl.enable=true
    mail.imap.port=993
    mail.smtp.port=587
    mail.smtp.auth=true
    mail.smtp.starttls.enable=true
    in javamail.properties. And of course I entered the hostnames.
    Everything works good. I can login, see my email (hosted on 1und1 imap) and send email.

    I'm just wondering how I can check if the OX-Server is really using SSL to communicate with the imap-server?

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    you don't need to change those settings. If the users server is defined as imaps://server.tld:993/ it will automatically use SSL. If a server is defined as imap://server.tld:143/ Open-Xchange Server 6 will check if the server offers STARTTLS and encrypt the connection automatically through TLS. The status of the encryption can be checked when sniffing the network traffic.

  5. #5
    raix Guest

    Default

    My SSL-Connection suddenly stopped working.

    As I said before I changed the properties in the javamail.properties file and setup the user with --imapserver imaps://1und1.de:993 --imaplogin USERNAME.

    So i checked my logfiles and discovered entries that the connection to 1und1.de was refused.

    After that I changed the entry to --imapserver imaps://imap.1und1.de:993
    Now it works again.

    I don't know if 1und1 made some changes to their setup or if you have to setup the imaps from scratch to imaps://imap.domain.tld:993.

    Just thought I'll let you know, in case someone else encounters this behaviour.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •