Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default username ungleich imaplogin

    Hallo Leute,

    ich habe vor gut einer Stunde unseren Produktiv Server auf die neue Paket basierte Version von OX geupdatet.

    Dies hat soweit auch ohne Probleme funktioniert.

    Jedoch ist mir nun ein Problem aufgefallen wo ich Hilfe bzw. Tipps benötige.

    Bei einem unserer Benutzer ist es so das der OX Anmelde Name nicht gleich dem IMAPlogin Namen ist.

    Normal ist es: ox: vorname.name imap: vorname.name@mail.de
    Hier ist es: ox vorname.name imap: spitzname@mail.de

    Der Benutzer wurde damals mittels des Adminbereiches angelegt und es funktionierte innerhalb OX alles ohne Probleme.

    Nach dem Update ist es jetzt allerdings so das der Benutzer sich zwar in OX anmelden kann dort aber nicht seine Inbox angezeigt bekommt.

    Hier stellt sich nun mir die Frage ob ich das ganze irgendwo in OX anpassen muss oder ob es einer Anpassung des im Mailserver bedarf.

    Für eure Hilfe wäre ich dankbar den es stehen mir noch ein paar Updates ins Haus.

    MfG

    outlow

  2. #2
    Join Date
    Jul 2008
    Location
    Hamburg, Germany
    Posts
    50

    Default

    Hi outlow,

    Code:
    /opt/opt/open-xchange/sbin/changeuser -A oxadmin -P admpw -c 1 -u loginDesUsers --imaplogin imapLoginDesUsers
    sollte helfen. Bei -c ist die entsprechende Context ID anzugeben.

    Grüße
    Sven

  3. #3
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Also ich habe das jetzt auch noch einmal mit dem Benutzernamen in Verbindung mit dem Imaplogin Namen eingegeben, jedoch ist auch nach dieser Änderung das Postfach im OX nicht zu sehen:

    ox log:

    Nov 9, 2008 6:15:43 PM com.openexchange.ajax.Folder actionGetSubfolders
    SEVERE: MSG-1001 Category=3 Message=Wrong or missing login data to access server localhost. exceptionID=-2004285678-582
    MSG-1001 Category=3 Message=Wrong or missing login data to access server localhost. exceptionID=-2004285678-582
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:370)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:330)
    at com.openexchange.mail.api.MailAccess.connect(MailA ccess.java:313)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tConnection(MailServletInterfaceImpl.java:786)
    at com.openexchange.mail.MailServletInterfaceImpl.get RootFolders(MailServletInterfaceImpl.java:671)
    at com.openexchange.ajax.Folder.actionGetSubfolders(F older.java:639)
    at com.openexchange.ajax.Folder.actionGetSubfolders(F older.java:376)
    at com.openexchange.ajax.Folder.actionGet(Folder.java :221)
    at com.openexchange.ajax.Folder.doGet(Folder.java:174 )
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:596)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:376)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:152)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:120)
    at com.openexchange.ajp13.AJPv13RequestHandler.create Response(AJPv13RequestHandler.java:466)
    at com.openexchange.ajp13.AJPv13Connection.createResp onse(AJPv13Connection.java:197)
    at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:259)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    at com.openexchange.imap.IMAPAccess.checkFailedAuths( IMAPAccess.java:340)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:247)
    ... 16 more

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    vielleicht hilft es noch die Adresse des Mailservers anzugeben:
    --imapserver 1.2.3.4
    --smtpserver 1.2.3.4

    Laut der Fehlermeldung hat der Benutzer falsche Logindaten zugewiesen bekommen, deswegen kann das Postfach nicht angezeigt werden. Hat der Nutzer eventuell ein anderes OX Passwort als Mailserver Passwort? Man kann zwar den Loginnamen unterschiedlich definieren, die Passwörter müssen jedoch gleich sein.

    Gruß
    Martin

  5. #5
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    Das mit den Adressen werde ich heute abend einmal Versuchen.

    Die Passwörter des Users sind identisch, daher kann es eigentlich hier zu keiner unstimmigkeit kommen.

    bislang gehe ich davon aus das OX versucht den Mail Account in der Form vorname.nachname anzusprechen und da dieser so nicht existiert eine Abfrage des Postfaches nicht zu stande kommt.

    Leider ist den mir Bekannten Logfiles nicht zu entnehmen mit welchen benutzer Login Daten OX es versucht, das würde ja schon evtl. weiterhelfen.

    Gibt es noch ein weiteres Log Files, welches diese Daten aufzeigt oder ist es Möglich den Grad des Log zu verändern um an diese Informationen zu kommen??

    MfG

    outlow

  6. #6
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Smile

    Hi,

    ich habe mir das ganze nochmal angesehen.

    Die Benutzer wurden über das Admin Interface damals angelegt.
    Der Anmeldename wurde mit vorname.nachname erstellt
    Die erste E-Mail Adresse jedoch unterschied sich entgegen den sonst vergeben in der Form spitzname@ anstatt vorname.nachname@.

    Dies ist der mit einzig aufgefallene Unterschied.

    Resultat war das nach dem Update auf OX 6.6.0 diese Benutzer keine Mail Postfächer mehr angezeigt bekommen haben.

    Nach dem Überprüfen der Cyrus Mailboxen stellt sich heraus das diese dem Anmeldenamen gleich sind und der Zugriff auch möglich ist.

    Ich habe daraufhin mir die DB angesehen und dort in der Tabelle user gesehen das in der Spalte imapLogin der Spitzname(Name der ersten Mail Adresse) steht und nicht wie bei den übrigen USern der Anzeige Name vorname.nachname. Nach Manueller korrektur der DB, aus Spitznamen mach Anzeige Namen, funktioniert für die Benutzer der Zugriff wieder im OX auf Ihren Mail Account.

    Da fragt man sich doch jetzt nur wieso das ganze bislang funktioniert hat!?!

    MfG

    outlow

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •