Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
  1. #1
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default Spam Handler hier Spamassassin

    Hallo zusammen,

    wie schon in meinen anderen threads beschrieben wurde heute einer unserer Produktivserver auf OX 6 geupdatet.

    Dabei bin ich auf eine weitere Fehlermeldung gestossen:

    open-xchange.log:

    Nov 9, 2008 2:26:52 PM com.openexchange.spamhandler.SpamHandlerRegistry getSpamHandler
    WARNING: No spam handler found for registration name 'DefaultSpamHandler'. Using fallback 'NoSpamHandler'
    Auf unserem Server läuft Amavis mit Spamassassin daher habe ich auch entsprechendes Paket bei der Installation mit ausgewählt (open-xchange-spamhandler-spamassassin).

    Laut listbundles ist dieses auch active

    bundlename: org.eclipse.osgi status: ACTIVE
    bundlename: com.openexchange.authentication.database status: ACTIVE
    bundlename: com.openexchange.caching status: ACTIVE
    bundlename: com.openexchange.charset status: ACTIVE
    bundlename: com.openexchange.common status: ACTIVE
    bundlename: com.openexchange.configjump.generic status: ACTIVE
    bundlename: com.openexchange.configread status: ACTIVE
    bundlename: com.openexchange.control status: ACTIVE
    bundlename: com.openexchange.data.conversion.ical.ical4j status: ACTIVE
    bundlename: com.openexchange.global status: ACTIVE
    bundlename: com.openexchange.group.managerequest status: ACTIVE
    bundlename: com.openexchange.groupware.settings.extensions status: ACTIVE
    bundlename: com.openexchange.i18n status: ACTIVE
    bundlename: com.openexchange.imap status: ACTIVE
    bundlename: com.openexchange.mail.filter status: ACTIVE
    bundlename: com.openexchange.management status: ACTIVE
    bundlename: com.openexchange.monitoring status: ACTIVE
    bundlename: com.openexchange.passwordchange.database status: ACTIVE
    bundlename: com.openexchange.passwordchange.servlet status: ACTIVE
    bundlename: com.openexchange.push.udp status: ACTIVE
    bundlename: com.openexchange.resource.managerequest status: ACTIVE
    bundlename: com.openexchange.server status: ACTIVE
    bundlename: com.openexchange.sessiond status: ACTIVE
    bundlename: com.openexchange.smtp status: ACTIVE
    bundlename: com.openexchange.spamhandler.spamassassin status: ACTIVE
    bundlename: javax.servlet status: ACTIVE
    bundlename: net.freeutils.jcharset status: ACTIVE
    bundlename: org.apache.commons.logging status: ACTIVE
    bundlename: org.eclipse.equinox.event status: ACTIVE
    bundlename: org.eclipse.osgi.services status: ACTIVE
    Im Admin PDF habe ich jetzt auch nichts wirklich hilfreiches dazu gefunden, daher die Frage an euch was hier in der Konfiguration ggf. zu ändern ist, ich gehe bislang davon aus das alles notwendige Installiert ist ich jedoch OX dies nur mitteilen muss.

    MfG

    outlow

  2. #2
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Question

    Benutzt bislang keiner das Spamassassin Paket??

    Wie übernimmt ihr dann die SPAM überwachung??

    Muss damit das OX Paket mit Spamassassin umgehen kann die Debian Version installiert sein oder ist auch die Manuelle Version(IST Stand) möglich??


    Wie ihr seht viele viele Fragen, aber vielleicht hat ja wer eine Antwort.

    MfG

    Outlow

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    die eigentliche Spamüberwachung, also Filtering, Learning etc. wird vom Mailserver erledigt. Völlig unabhängig vom OX Server. Diese Plugins dienen dazu, gewisse Funktionen im Spamassasin zu benutzen, z.B. ein manuelles markieren als Spam oder Nicht-Spam.

    Gruß

  4. #4
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    so habe ich mir das schon gedacht, jedoch scheint OX dies nicht zu erkennen.

    vermutlich muss man die Einstellungen anpassen , doch genau dazu habe ich bislang nichts in der Doku gefunden,

    ich gehe davon aus das die Spam Funktionalität(Rechtsklick MArkieren als SPAM) in OX solange nicht zu sehen sein wird wie OX merkt das es einen Spam Handler gibt,

    verstehe ich das soweit Richtig??

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    korrekt. Schau mal bitte nach was in der imap.properties unter "com.openexchange.imap.spamHandler=" eingetragen ist.

  6. #6
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    ich würde wetten dort steht :

    DefaultSpamHandler

    werde ich aber heute abend mal überprüfen und posten

    MfG

  7. #7
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    wie ich vermutet habe steht dort

    DefaultSpamHandler

    aber wie gesagt ich finde keine doku dazu wie es zu ändern ist

  8. #8
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Angry

    Super das jetzt blödmänner oder spam roboter meine tickets nach oben posten



    Falls mir jemand die Sache mit dem Spam Handler mal erklären könnte, und wie die Einstellungen vorzunehmen sind wäre ich da nicht abgeneigt!!!

    MfG

    outlow

  9. #9
    Join Date
    Sep 2009
    Posts
    17

    Default

    Hi Outlow

    Hast du eine Änderung in der spamassassin.properties vorgenommen? Rsp. funktioniert bei Dir jetzt das manuelle Taggen?


    Gruss

  10. #10
    Join Date
    Oct 2007
    Location
    Germany, Essen
    Posts
    171

    Default

    hi,

    bis zum gestrigen update auf Version 6.12 Rev03 funktionierte das ganze nicht.
    Obige Fehlermeldung stand in den Logfiles und im OX wurde weder im Kontextmenü noch in der oberen Menüzeile wurde der Button Spam angezeigt.

    Nach dem Update ist jetzt im OX der Button Spam wieder in beiden Menüs vorhanden, beim markieren einer Spammail über den Button wurde die Mail gelöscht (oder vielleicht auch verschoben finde Sie aber nicht).

    Bei der 5 Version wurde glaube ich die Mail in den Ordner confirmed-spam verschoben und dies hatte auch funktioniert.

    Logfile habe ich mir noch nicht angesehen aber werde ich gleich nach reichen.

    MfG

    outlow

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •