Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    OliverPlunkett Guest

    Default Problems connecting to external (Fastmail.fm) IMAP server ox6.6

    Hi,

    I am installing Ox6.6 for the first time.

    I configured my yum to pick up the Ox6.6 packages from the FC9 repository, and then followed the instructions for FC8:

    http://www.open-xchange.com/wiki/ind...dition_Fedora8

    Everything is working fine. However, I want to connect to my ISP's (Fastmail.fm) IMAP server. I have read the forums and this seems possible.

    http://www.open-xchange.com/forum/sh...=external+imap

    I changed my testuser with the command:

    Code:
    /opt/open-xchange/sbin/changeuser -A oxadmin -P admin_password -c 1 -u testuser --imapserver mail.messagingengine.com:431 --imaplogin <mylogin>
    I changed the mail.properties file so that IMAP credentials are picked up from the database:

    com.openexchange.mail.credSrc=user.imapLogin
    I disabled the OSGI Sieve filter just in case:

    Code:
    /opt/open-xchange/sbin/stopbundle com.openexchange.mail.filter
    Then I restarted everything and tried the email. I see this in the log files:

    Nov 20, 2008 4:22:33 PM com.openexchange.ajax.request.QuotaRequest mail
    SEVERE: MSG-1023 Category=8 Message=Messaging error: connect timed out exceptionID=-1459155651-80
    MSG-1023 Category=8 Message=Messaging error: connect timed out exceptionID=-1459155651-80
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:456)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:330)
    at com.openexchange.mail.api.MailAccess.connect(MailA ccess.java:313)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tConnection(MailServletInterfaceImpl.java:786)
    at com.openexchange.mail.MailServletInterfaceImpl.get Quotas(MailServletInterfaceImpl.java:616)
    at com.openexchange.ajax.request.QuotaRequest.mail(Qu otaRequest.java:161)
    at com.openexchange.ajax.request.QuotaRequest.action( QuotaRequest.java:115)
    at com.openexchange.ajax.Quota.doGet(Quota.java:107)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:596)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:376)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:152)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:120)
    at com.openexchange.ajp13.AJPv13RequestHandler.create Response(AJPv13RequestHandler.java:466)
    at com.openexchange.ajp13.AJPv13Connection.createResp onse(AJPv13Connection.java:197)
    at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:259)
    at java.lang.Thread.run(Thread.java:636)
    Caused by: javax.mail.MessagingException: connect timed out;
    nested exception is:
    java.net.SocketTimeoutException: connect timed out
    at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPSt ore.java:571)
    at javax.mail.Service.connect(Service.java:288)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:288)
    ... 15 more
    Caused by: java.net.SocketTimeoutException: connect timed out
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.AbstractPlainSocketImpl.doConnect(Abstrac tPlainSocketImpl.java:310)
    at java.net.AbstractPlainSocketImpl.connectToAddress( AbstractPlainSocketImpl.java:176)
    at java.net.AbstractPlainSocketImpl.connect(AbstractP lainSocketImpl.java:163)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:381)
    at java.net.Socket.connect(Socket.java:537)
    at com.sun.mail.util.SocketFetcher.createSocket(Socke tFetcher.java:231)
    at com.sun.mail.util.SocketFetcher.getSocket(SocketFe tcher.java:189)
    at com.sun.mail.iap.Protocol.<init>(Protocol.java:107 )
    at com.sun.mail.imap.protocol.IMAPProtocol.<init>(IMA PProtocol.java:104)
    at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPSt ore.java:538)
    ... 17 more

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this seems to be a network timeout problem caused by a wrong port of the IMAP Server:
    mail.messagingengine.com:431
    seems a bit wrong - i tried to connect but got a timeout, using Port 143 should solve the Problem. Or is there any special need to use a non-standard port?

    Greetings

  3. #3
    OliverPlunkett Guest

    Red face

    Martin,

    Thank you for your quick reply. 431 was a good old-fashioned typo .

    I changed to 143 and it worked immediatley.

    Thank you again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •