Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    NTX Guest

    Question missing required option --object-link-hostname

    I am trying to complete the OX configuration on a Centos 5.4 Server. I am getting the Error "missing required option --object-link-hostname" after I run oxinstaller. Can anyone offer assistance? Thank you for your help

    [root@SVR001-linux /]# /opt/open-xchange/sbin/oxinstaller --servername=localhost --configdb-pass=NTXemail --master-pass=NTXEadmin
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host
    hostname: Unknown host

    /opt/open-xchange/sbin/oxinstaller currently knows the following parameters:

    Parameter | Default value | Possible values
    --------------------------------------------------------------------------------------------
    --servername | localhost |
    --imapserver | |
    --smtpserver | |
    --imaplogintype | user | user config global
    --configdb-user | openexchange |
    --configdb-pass | NTXemail |
    --configdb-readhost | localhost |
    --configdb-writehost | localhost |
    --configdb-dbname | configdb |
    --servermemory | 512 |
    --adminmemory | 100 |
    --clt-memory | 50 |
    --configdb-readport | 3306 |
    --configdb-writeport | 3306 |
    --tmpdir-path | /tmp |
    --master-pass | NTXEadmin |
    --master-user | oxadminmaster |
    --jkroute | APP1 |
    --ajp-bind-port | * |
    --imap-credentials | user.imapLogin | session user.imapLogin
    --object-link-hostname | |
    --extras-link | http:/// |
    --cache-udp-disc-addr | 224.0.0.1 |
    --cache-udp-disc-port | 6780 |
    --groupware-cache-port | 57461 |
    --admin-cache-port | 57462 |
    --gwsession-cache-port | 58849 |
    --ip-of-oxcluster | |
    --push-udp-disc-port | 9982 |
    --push-outlook-port | 44335 |
    --SesssionContTimeout | 4200000 |
    --NRSessionContainers | 8 |
    --maxSession | 0 |
    --DoubleLoginPerm | true | true false
    --sessionDefLifeTime | 3600000 |
    --disableauth | false | true false

    Example:

    /opt/open-xchange/sbin/oxinstaller --servername=ox6 --configdb-pass=secret --master-pass=secret

    use -D for Debug mode


    missing required option --object-link-hostname

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    what version of the OX packages are you using?

    Greetings

  3. #3
    Ted Guest

    Default Check localhost in /etc/hosts

    I had a similar problem with oxinstaller issuing the hostname -f command, and was fixed by editing my /etc/hosts localhost entry to include the domain info (correctly).


    -f, --fqdn, --long
    Display the FQDN (Fully Qualified Domain Name). A FQDN consists
    of a short host name and the DNS domain name. Unless you are
    using bind or NIS for host lookups you can change the FQDN and
    the DNS domain name (which is part of the FQDN) in the
    /etc/hosts file.

    - Ted

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •