Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Asmodis Guest

    Default Login fails - 503 - Service temporarily not available

    Hi,

    i tried to set up ox using the tutorial in the community area.

    I finished everything, except that i cant login via the web gui. I keep getting the error, 503 - Service temporarily not available.

    My distro is Ubuntu 6.06 LTS. I'm using the cvs build of today afternoon. I deleted the logs in /var/log/openexchange and rebootet my server, now the only entry is:

    Code:
    open-xchange-console.log
    /opt/open-xchange/sbin/open-xchange-groupware: line 41: exec: -X: invalid option
    exec: usage: exec [-cl] [-a name] file [redirection ...]
    So the only error message i actually have is the one from the web browser.

    Also, when I added the user, i didn't get what's said in the tutorial:
    And if everything is set up correctly the script will happily answer us with the new user id. Let's say it's
    23 in our case.
    I didn't get a user ID, but something that looked like a success message.

    Now I can't run the script anymore at all, it says:

    Code:
    /opt/open-xchange/sbin/createuser: line 93: -classpath: command not found
    said line reads like this:

    Code:
    $JAVA_BIN -classpath $LIBPATH/ox_admin_plugin_imap.jar:${ADMINCP} $JAVAMAIN $*
    I don't understand this
    - why can't I add users anymore? It worked before...
    - why doesn't he log anything at all?
    - why can't i log in?

    can anyone please help me?
    thx in advance

  2. #2
    carlex Guest

    Default

    probably the groupware engine is not running. try to turn it on first.

    /opt/open-xchange/sbin/open-xchange-groupware

  3. #3
    Asmodis Guest

    Default

    The groupware was running. At least I started it. Or does the log

    Code:
    open-xchange-console.log
    /opt/open-xchange/sbin/open-xchange-groupware: line 41: exec: -X: invalid option
    exec: usage: exec [-cl] [-a name] file [redirection ...]
    mean that the startup failed?

  4. #4
    Francisco Laguna Guest

    Default

    Yeah sounds like it. I'm not sure what the exec command in the start script is supposed to be doing. Maybe removing the 'exec' in line 41 of /opt/open-xchange/sbin/open-xchange-groupware helps.

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by Asmodis View Post
    Hi,

    Code:
    open-xchange-console.log
    /opt/open-xchange/sbin/open-xchange-groupware: line 41: exec: -X: invalid option
    exec: usage: exec [-cl] [-a name] file [redirection ...]
    Looks like java vm complains about unknown option.

    What does java -version on your system say?
    What's the content of /opt/open-xchange/etc/groupware/ox-scriptconf.sh?
    Looks like java vm complains about unknown option.

    What does java -version on your system say?
    What's the content of /opt/open-xchange/etc/groupware/ox-scriptconf.sh?

  6. #6
    Asmodis Guest

    Default

    Damn, it was so bloody easy

    the only problem was that the java executable was not in the $PATH...

    thanks to all of you!!

  7. #7
    c4stro Guest

    Default same error, but a different resson?

    I have the same message like the Topic, and i found this error in mod_jk.log:
    Code:
    [2901:64432] [error] ajp_service::jk_ajp_common.c (1794): Error connecting to tomcat. Tomcat is probably not started or is listening on the wrong port. worker=ajp13_worker failed
    i use this guide http://wiki.open-xchange.com/wiki/in...e_Installation
    for installation.
    Is the Problem worker.probities or groupware , i have start groupware by tty after login.
    Any Ideas?

    Thx 4 any replay

  8. #8
    Eisenkopf Guest

    Default

    i get the same error, help would be great


    thx alot,
    Eisenkopf

  9. #9
    neo Guest

    Default

    Hello,

    can you post your
    Code:
    /opt/open-xchange/sbin/createuser
    /opt/open-xchange/sbin/open-xchange-groupware
    Scripts?

    There is definitely something wrong there, may be some CRLF or something like this at the wrong position

  10. #10
    c4stro Guest

    Default @neo

    thx for replay, i have try to create a user but i have now the error:
    Code:
    Exception in thread "main" java.lang.NullPointerException
            at com.openexchange.database.Database.get(Database.java:113)
            at com.openexchange.server.DBPool.pickupWriteable(DBPool.java:75)
            at com.openexchange.admin.storage.sqlStorage.OXAdminPoolDBPool.getWRITEConnectionForCONFIGDB(OXAdminPoolDBPool.java:102)
            at com.openexchange.admin.tools.AdminCache.getWRITEConnectionForCONFIGDB(AdminCache.java:202)
            at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.selectwithint(OXToolMySQLStorage.java:1135)
            at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.existsContext(OXToolMySQLStorage.java:137)
            at com.openexchange.admin.rmi.impl.OXUser.checkExistsContextAndSchemaBeingLocked(OXUser.java:828)
            at com.openexchange.admin.rmi.impl.OXUser.create(OXUser.java:150)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:153)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
            at java.lang.Thread.run(Thread.java:595)
            at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
            at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
            at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:126)
            at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:179)
            at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:132)
            at $Proxy0.create(Unknown Source)
            at com.openexchange.admin.console.user.Create.<init>(Create.java:137)
            at com.openexchange.admin.console.user.Create.main(Create.java:78)
    something on java going wrong, is some lib wrong?
    P.S. If you like you can connect me on icq
    Last edited by c4stro; 06-07-2007 at 10:14 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •