Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    danisahne Guest

    Default access denied on mysql

    Hi

    I have installed mysql-server and he asked me for a root password and I set one
    But what to do now?

    root@server:/opt/open-xchange# /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a
    initializing configdb from scratch...ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    like stated in several postings and the setup guide, you should not set a mysql root password prior to the open-xchange installation since the installer cannot handle it. You could temporary remove the password, do the installation and set it again, Open-Xchange uses a separate user to access the database which will be created by the installer.

    Greetings

  3. #3
    danisahne Guest

    Default

    I have disabled the password but then...

    mysql> update user set password = '' where user = 'root'
    -> ;
    Query OK, 3 rows affected (0.00 sec)
    Rows matched: 3 Changed: 3 Warnings: 0

    mysql> select Host,User,Password from user;
    +-----------+------------------+-------------------------------------------+
    | Host | User | Password |
    +-----------+------------------+-------------------------------------------+
    | localhost | root | |
    | server | root | |
    | 127.0.0.1 | root | |
    | localhost | debian-sys-maint | *7F8DC2CA86701775D932D27139A790F6CA2A6DDF |
    +-----------+------------------+-------------------------------------------+
    4 rows in set (0.00 sec)

    mysql> quit;
    Bye
    root@server:/opt/open-xchange# /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a
    initializing configdb from scratch...ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR

  4. #4
    danisahne Guest

    Default

    or do i have to disable the password completely?

    and if yes how?

  5. #5
    danisahne Guest

    Default

    works!!!!!

  6. #6
    DeathShadow Guest

    Default

    How did your solve it?
    please help other people

  7. #7
    dalekurt Guest

    Default

    I'm using phpmyadmin to administer my MySQL database

    Select Privilege and edit the root (localhost) user and select NO PASSWORD.

    Apply the change to the user and execute the command once more.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •