Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 2 of 2
  1. #1
    sash777 Guest

    Post Exception on groupware daemon startup / latest cvs / ubuntu 7.04

    Hello,

    i am trying to get the latest cvs release working on an ubuntu 7.04
    machine.

    I followed the wiki installation thorougly and everythings works
    as expected; except that when i try to

    /opt/open-xchange/sbin/open-xchange-groupware

    nothing happens. ps ax shows no new process.

    /var/log/open-xchange/open-xchange-console.log shows:

    Exception in thread "main" java.lang.NoClassDefFoundError: java.util.concurrent.atomic.AtomicInteger
    at com.openexchange.groupware.AbstractOXException.<cl init>(AbstractOXException.java:76)
    at java.lang.Class.initializeClass(libgcj.so.70)
    at Starter.<init>(Starter.java:111)
    at ComfireServer.main(ComfireServer.java:62


    I suspected a problem with concurrent.jar. I went both ways, downloading
    the .tar.gz, getting the build.xml, doing an "ant dist", moving concurrent/lib/concurrent.jar to /opt/open-xchange/lib/
    and as that didnt help i also just renamed the downloaded concurrent.zip
    to concurrent.jar as mentioned several times in the forum.

    Any idea what i am into here?

    Kind regards,
    Sash

  2. #2
    calvin2 Guest

    Smile My resolution for this error

    Hi sash777,

    This response may be too late for you if you already figured this out, but hopefully it also helps others. I ran into this exact same issue on CentOS 5 and I found that my problem was simply my PATH environment variable. My system has 2 java binaries, the one installed by default at /usr/bin/java, and the other from the JDK installed while working through the tutorial at /usr/java/jdk/bin/java. These are different versions (1.4.2 and 1.5.0_12 respectively), and the PATH environment variable set in /etc/init.d/open-xchange-restart-services (line 53) was finding /usr/bin/java and using that instead of /usr/java/jdk/bin/java
    ---(original)---
    PATH=/sbin:/bin:/usr/sbin:/usr/bin

    JAVA_HOME has already been set to "/usr/java/jdk", so I changed this PATH variable to:
    PATH=$JAVA_HOME/bin:/sbin:/bin:/usr/sbin:/usr/bin

    I also have moved /usr/bin/java to /usr/bin/java-1.4.2 and executed:
    # ln -s /usr/java/jdk/bin/java /usr/bin/java

    so that /usr/java/jdk/bin/java will always be used. This resolved my problem and now 'open-xchange-restart-services start' executes cleanly and successfully.

    -----------------------------------------------
    For search engines and future googlers, here was the error output while executing '/etc/init.d/open-xchange-restart-services start':

    Error: connection failed to host: 127.0.0.1; nested exception is:
    java.net.ConnectException: Connection refused
    admindaemon startup still in progress, waiting...

    Along with this in the restart.log file:

    Exception in thread "main" java.lang.NoClassDefFoundError: java.util.concurrent.atomic.AtomicInteger
    at com.openexchange.groupware.AbstractOXException.<cl init>(AbstractOXException.java:76)
    -----------------------------------------------

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •