Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    francescog9 Guest

    Default oxinstaller script

    Hi,
    I have followed the wiki http://wiki.open-xchange.com/wiki/in...e_Installation
    and I haven't any errors. Wheni I did oxinstaller I took this error:

    server:/opt/open-xchange# /opt/open-xchange/sbin/oxinstaller -f --oxdb-pass=**** --admin-pass=**** --maildomain savananet.it
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    (Re)Starting Admin Daemon
    Error:
    Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused

    admindaemon startup still in progress, waiting...
    Error:
    Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused

    Where is the error?
    Thank you

  2. #2
    mlt Guest

    Default

    Hi,

    Have you already find a solution for your problem? I have exactly the same problem with OpenSuse 10.2.

    Error occurs when the following line is executed when running oxinstaller-script (file: /opt/open-xchange/sbin/allpluginsloaded):

    $JAVA_BIN -classpath ${ADMINCP} $JAVAMAIN $*

    Am I missing some .jar files or what could be the problem? All requirements, as far as I know, should be OK. I think it's not Mysql related issue. Mysql connections are OK as you see in mysql log.

    070629 13:15:40 24 Connect root@localhost on
    24 Query select @@version_comment limit 1
    24 Query drop database if exists `configdb`
    24 Query drop database if exists `open-xchange-db`
    24 Query GRANT ALL PRIVILEGES ON *.* TO 'openexchange'@'localhost' IDENTIFIED BY '*************' WITH GRANT OPTION
    24 Query create database `configdb`
    24 Quit
    25 Connect root@localhost on
    25 Query flush privileges
    25 Quit
    26 Connect openexchange@localhost on configdb
    26 Query select @@version_comment limit 1
    26 Query CREATE TABLE configdb_sequence (
    id INT4 UNSIGNED AUTO_INCREMENT,
    PRIMARY KEY (id)
    )
    26 Query INSERT INTO configdb_sequence VALUES (0)
    26 Query DROP PROCEDURE IF EXISTS get_configdb_id
    26 Query CREATE PROCEDURE get_configdb_id() NOT DETERMINISTIC MODIFIES SQL DATA
    ....

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by mlt View Post
    Hi,

    Have you already find a solution for your problem? I have exactly the same problem with OpenSuse 10.2.

    Error occurs when the following line is executed when running oxinstaller-script (file: /opt/open-xchange/sbin/allpluginsloaded):

    [...]
    Check /var/log/open-xchange/open-xchange-admin.log.0 in case of problems with the oxinstaller. There you should be able to find more details for the problem. At least you could then post it here.

  4. #4
    mlt Guest

    Default

    Hi,

    There was following in /var/log/open-xchange/open-xchange-admin.log.0

    Jul 24, 2007 5:22:52 AM com.openexchange.admin.daemons.Activator start
    INFO: Starting Admindaemon...
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache readMasterCreden
    tials
    FINE: Master credentials successfully set!
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPEndpoint <clinit>
    FINE: Start Level Event Dispatcher: localHostKnown = false, localHost = 127.0.0.
    1
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPTransport <init>
    FINE: Start Level Event Dispatcher: Version = 2, ep = [127.0.0.1:0]
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPEndpoint getLocalEndpoint
    FINE: Start Level Event Dispatcher: created local endpoint for socket factory nu
    ll on port 0
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPTransport listen
    FINE: Start Level Event Dispatcher: (port 0) create server socket
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPEndpoint newServerSocket
    FINER: Start Level Event Dispatcher: creating server socket on [127.0.0.1:0]
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPEndpoint setDefaultPort
    FINE: Start Level Event Dispatcher: default port for server socket factory null
    and client socket factory null set to 46182
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.tcp.TCPTransport run
    FINE: RMI TCP Accept-0: listening on port 46182
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.WeakRef pin
    FINER: Start Level Event Dispatcher: strongRef = sun.rmi.transport.DGCImpl@c5c3a
    c
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.ObjectTable putTarget
    FINER: Start Level Event Dispatcher: add object [0:0:0, 2]
    Jul 24, 2007 5:22:52 AM sun.rmi.transport.ObjectTable putTarget
    FINER: Start Level Event Dispatcher: add object [0]
    Jul 24, 2007 5:22:52 AM sun.rmi.server.Util computeMethodHash
    FINER: Start Level Event Dispatcher: string used for method hash: "createSelfSig
    nedCertificate(Lcom/openexchange/admin/rmi/dataobjects/Context;Lcom/openexchange
    /admin/rmi/dataobjects/CertAttributes;Lcom/openexchange/admin/rmi/OXCaMgmtInterf
    ace$KeyForm;IILjava/lang/String;Ljava/lang/String;Lcom/openexchange/admin/rmi/da
    taobjects/Credentials"
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache readMasterCreden
    tials
    FINE: Master credentials successfully set!
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache readMasterCreden
    tials
    FINE: Master credentials successfully set!
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting...
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache readMasterCreden
    tials
    FINE: Master credentials successfully set!
    Jul 24, 2007 5:22:52 AM com.openexchange.admin.tools.AdminCache initOXProccess
    INFO: OX init starting.

    Log file didn't helped me so I downloaded all jar files again and checked that they are exactly right versions as wiki said. After recompiling and oxinstaller I get

    (Re)Starting Admin Daemon
    done
    initializing database (step 2/2)
    Server response:
    Authentication failed

    I had missed cyrus configuration and after checking all pam and cyrus configuration files I tried again. Same problem.

    Then I used the same passwords for --oxdb-pass and --admin-pass and updated this password to /etc/libnss-mysql.cfg, /etc/libnss-mysql-root.cfg, /etc/pam.d/imap and /opt/open-achange/sbin/oxinstaller. After that I restarted cyrus and saslauthd daemons.

    After that /opt/open-xchange/sbin/oxinstaller --oxdb-pass=<password> --admin-pass=<password> --maildomain <domainnname> was SUCCESSFULL.

    So, check that you have right jar files and cyrus, saslauthd, pam, postfix, mysql, apache and mod_jk has been configured before you try oxinstaller.

    - mlt
    Last edited by mlt; 08-13-2007 at 02:59 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •