Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    Sneeper Guest

    Default OXInstaller continues to fail on Ubuntu 7.04

    I've tried uninstalling Java5 and installing Java6 and runing ALL the steps again down to the dreaded Oxinstaller step ... I have even (using Synaptic) reinstalled MySQL.

    But the oxinstaller still fails to connect to ConfigDB !!!!! :0(

    root@ubuntu:/tmp/open-xchange-admin# /opt/open-xchange/sbin/oxinstaller --oxdb-pass=******** --admin-pass=******** --maildomain localhost
    initializing database (step 1/2)
    done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting CREATE_HOMEDIRECTORY in /opt/open-xchange/etc/admindaemon/User.properties
    setting SetupLink in /opt/open-xchange/etc/groupware/system.properties
    (Re)Starting Admin Daemon
    Server response:
    OXAdminCore
    admindaemon startup still in progress, waiting...
    done
    initializing database (step 2/2)
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-736729138-2
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-736729138-4
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-736729138-6
    done
    setting up the system
    creating certificates
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-736729138-8
    chmod: cannot access `/etc/ssl/certs/eecert.pem': No such file or directory
    chmod: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
    chgrp: cannot access `/etc/ssl/private/eekey.pem': No such file or directory
    configuring ox admin gui
    configuring mail system
    using mail.localhost as FQHN of the mail server
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=-736729138-10
    done

    What bothers me is that in MySQL you can see the database "configdb", but the error message shows "config DB" ? Is this a bug in the script?

    Short of re-installing the entire OS and starting completely over again, what can I try to get past this problem?????

  2. #2
    rhultay Guest

    Default Same Issue

    I am using a fresh Gentoo install, and have the *exact* same issue. Almost down to the letter.

    I don't know what the problem is, I have tried modifying oxinstaller, I have tried modifying configdb.whatever in both groupware and some other folder, and to no avail.

    I have tested MySQL at length, and just can't figure this out.

  3. #3
    rhultay Guest

    Default open-xchange-admin.log.0

    I noticed in my logs:

    Jun 15, 2007 1:43:43 AM com.openexchange.database.Database back
    SEVERE: DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=308115491-11
    DBP-0001 Category=5 Message=Cannot get connection to config DB. exceptionID=308115491-11
    at com.openexchange.database.Database.get(Database.ja va:120)
    at com.openexchange.database.Server.loadServerId(Serv er.java:135)
    at com.openexchange.database.Server.getServerId(Serve r.java:97)
    at com.openexchange.database.AssignmentStorage.getAss ignment(AssignmentStorage.java:127)
    at com.openexchange.database.Database.resolvePool(Dat abase.java:86)
    at com.openexchange.database.Database.back(Database.j ava:228)
    at com.openexchange.database.Database.back(Database.j ava:214)
    at com.openexchange.server.DBPool.push(DBPool.java:88 )
    at com.openexchange.admin.storage.sqlStorage.OXAdminP oolDBPool.pushOXDBRead(OXAdminPoolDBPool.java:168)
    at com.openexchange.admin.tools.AdminCache.pushOXDBRe ad(AdminCache.java:194)
    at com.openexchange.admin.auth.MySQLAuthenticationImp l.authenticate(MySQLAuthenticationImpl.java:143)
    at com.openexchange.admin.rmi.BasicAuthenticator.doAu thentication(BasicAuthenticator.java:106)
    at com.openexchange.admin.rmi.impl.OXMailServerImpl.w riteConfig(OXMailServerImpl.java:237)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: com.openexchange.pooling.PoolingException: Cannot create pooled object.
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:381)
    at com.openexchange.database.Database.get(Database.ja va:118)
    ... 23 more
    Caused by: java.sql.SQLException: No suitable driver
    at java.sql.DriverManager.getConnection(DriverManager .java:545)
    at java.sql.DriverManager.getConnection(DriverManager .java:140)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:190)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:137)
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:373)
    ... 24 more

    This tastes like a Java + JDBC issue.
    I have mysql-connector-java.3.1.13-bin.jar in /opt/open-xchange/lib downloaded direct from MySQL.org

    I also installed jdbc-mysql in Gentoo via emerge, and it is also 3.1.13.

    So now I *know* it's a Java related issue. Speaking of which, I am using Sun JDK 1.5.0.11

  4. #4
    amishmunshi Guest

    Default

    I had the same problem, I had to execute oxinstaller again with -f.

  5. #5
    kwelong Guest

    Default

    Hi guys,
    I have just tested it on Gentoo too, and managed to get it up after 2 weeks.

    I noticed 1 of the admin-plugin build.xml misses to define the MySQL connector jar. Here is how I do it:

    # emerge jdbc-mysql
    # cp /usr/share/jdbc-mysql/lib/jdbc-mysql.jar /opt/open-xchange/lib

    Then I add the missing jar definition into the build.xml
    # vi /tmp/open-xchange-admin-plugin-context_light/build.xml:
    <pathelement location="${lib.dir}/jdbc-mysql.jar"/>

    Recompile the open-xchange-admin and the mysql connector class not found error is gone.

  6. #6
    rhultay Guest

    Default Attempted fixing build.xlm

    I tried what you suggested, and it compiled nicely. I also ran 'ant install' and it copied the necessary files over to /opt/open-xchange

    I still get this message in /var/log/open-xchange/open-xchange-admin.log.0:

    Caused by: java.sql.SQLException: No suitable driver
    at java.sql.DriverManager.getConnection(DriverManager .java:545)
    at java.sql.DriverManager.getConnection(DriverManager .java:140)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:190)
    at com.openexchange.database.ConnectionPool$Connectio nLifecycle.create(ConnectionPool.java:137)
    at com.openexchange.pooling.ReentrantLockPool.get(Ree ntrantLockPool.java:373)
    ... 24 more

    I am using JDBC-MySQL v3.1.13-r5 and Sun JDK 1.5.0.11

    This is getting confusing, any help would be greatly appreciated.

  7. #7
    rhultay Guest

    Default Fixed! Kinda...

    I deleted all installations and instances of open-xchange source and started from scratch.

    I emerged (gentoo) all packages which could accommodate the .jar files required in /opt/open-xchange/lib/, and copied them over. The rest I retrieved via the installation guide's recommendations.

    I ran oxinstaller, and SUCCESS!

    I can create and delete users and resources, however when I access the gui via www.mydomain.tld, I get '500 Internal Server Error' of which I cannot find any logs related to it.

    Here is my httpd.conf addition as per the mod_jk settings:
    Code:
    LoadModule      jk_module       modules/mod_jk.so
    JkWorkersFile /etc/apache2/workers.properties
    JkLogFile     /var/log/apache2/mod_jk.log
    JkLogLevel    error
    JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
    JkRequestLogFormat     "%w %V %T"
    JkMount /ajax/* ajp13_worker
    JkMount /servlet/* ajp13_worker
    Here is my workers.properties as per an example, and modified as per the installation guide:
    Code:
    worker.list=ajp13
    worker.ajp13.port=8009
    worker.ajp13.host=localhost
    worker.ajp13.type=ajp13
    worker.ajp13.lbfactor=1
    worker.ajp13.cachesize=10
    workers.java_home=/etc/java-config-2/current-system-vm/
    Tomcat5 is installed and running (with no modifications, I saw none to perform) and apache is loading the open-xchange-gui login page successfully. It's when I try to login as oxadmin, or any other user that I get '500 Internal Server Error'

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    You MUST not use tomcat and the OX parallel. With Hyperion, we replaced tomcat by using a own servlet container which collides with tomcat. So just shutdown tomcat and check if Port 8009/tcp is reachable - it is provided by the open-xchange daemon.

    Hope that helps.
    Last edited by Martin Heiland; 06-19-2007 at 11:44 PM.

  9. #9
    ostaquet Guest

    Default Install on Ubuntu Feisty

    Hello,

    I've installed Open Xchange on Ubuntu Feisty (7.04) whitout problems.

    I've followed this tutorial (with some "apt-get" adaptation) :
    http://www.open-xchange.com/wiki/ind...e_Installation

    Regards,

    Olivier STAQUET

  10. #10
    rhultay Guest

    Default Working

    Once I shutdown tomcat (didn't know about the conflict), and once I correctly installed and configured mod_jk, everything works.

    There are some minor gui issues, but it's great. I really like this project.

    Now on to trying to do multi-domain. :P

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •