Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    ss300 Guest

    Default OX 6 server on Debian Lenny - Java problem

    Hello smart people. I am trying to install OX on Debian following instructions from this page http://www.open-xchange.com/wiki/ind...dition_Debian5


    And I can not pass this step. See below:

    Code:
    $ /etc/init.d/open-xchange-admin start
    Starting Open-Xchange Admin Daemon: open-xchange-admin.
    
    $ /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    server could not be registered: 
    Error: connection failed to host: 127.0.0.1; nested exception is:
    	java.net.ConnectException: Connection refused

    Installation done as root user. MySQL root has "blank" password.

    Please advise.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    please check if the open-xchange-admin service is running (ps axf| grep java) and check the logs at /var/log/open-xchange and/or syslog if you've installed the log4j packages.

    Greetings

  3. #3
    ss300 Guest

    Default

    Hi Martin.

    According to syslog log4j package is installed, according to Package manager it is liblog4j1.2-java version 1.2.15-4


    ps axf| grep java gives me following results:
    Code:
    # ps axf| grep java
     2420 ?        Sl     0:17 /usr/bin/java -Xmx512M -XX:+UseConcMarkSweepGC -Djava.awt.headless=true -Dopenexchange.propdir=/opt/open-xchange/etc/groupware -Djava.util.logging.config.file=/opt/open-xchange/etc/groupware/file-logging.properties -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/groupware/osgi
     4334 pts/3    S+     0:00                  \_ grep java
    Thanks for your help.

  4. #4

    Default

    Did you solved this problem? Because we already have the same issue. The packages are installed, and java is running. But we get the "connection refused" too.
    Last edited by wesdgf; 03-30-2009 at 05:56 PM.

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    it seems that the admindaemon is not start up. Please check the logs at /var/log/open-xchange. By "using log4j" i meant the Open-Xchange implementation which sends all logging for the groupware and admin to the local or remote syslog daemon. You can determine the installed logging mechanism by running "dpkg -la | grep open-xchange-log" if that reports -log4j installed, please check out this guide to enable local logging: http://www.open-xchange.com/wiki/ind..._Configuration.

    Please also attach the output of "java -version". What version of Open-Xchange are you using? Since we only offer snapshot packages for Lenny it could be that you're running a unstable version of OX which is not recommended for productive use. You can use the stable packages für Etch on Lenny. Generally we support Debian Etch, RHEL5, SLES10 with stable OX packages.


    Greetings
    Last edited by Martin Heiland; 03-30-2009 at 06:47 PM.

  6. #6
    ss300 Guest

    Default

    Hello Martin.
    Here are my outputs:
    Code:
    # dpkg -la | grep open-xchange-log
    ii  open-xchange-log4j                      6.8.1-3                    log4j library bundle and xml configuration file
    Code:
    # java -version
    java version "1.5.0"
    gij (GNU libgcj) version 4.3.2
    
    Copyright (C) 2007 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    I use your tutorial, how to install OX on Debian. I kept everything for the sake of exercise, including passwords.

    I got everything what this code brings to me
    Code:
    apt-get install mysql-server open-xchange-admin-client \
    open-xchange-admin-doc open-xchange-admin-plugin-hosting-doc \
    open-xchange-admin-plugin-hosting open-xchange-admin \
    open-xchange-authentication-database open-xchange-cache \
    open-xchange-charset open-xchange-common open-xchange-configjump-generic \
    open-xchange-configread open-xchange-control open-xchange-data-conversion-ical4j \
    open-xchange-global open-xchange-group-managerequest open-xchange-gui \
    open-xchange-i18n open-xchange-imap open-xchange-jcharset open-xchange-mailfilter \
    open-xchange-management open-xchange-monitoring open-xchange-online-help-de \
    open-xchange-online-help-en open-xchange-online-help-fr \
    open-xchange-passwordchange-database open-xchange-passwordchange-servlet \
    open-xchange-push-udp open-xchange-resource-managerequest open-xchange-server \
    open-xchange-sessiond open-xchange-settings-extensions open-xchange-smtp \
    open-xchange-spamhandler-default open-xchange open-xchange-contactcollector
    Thanks

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    it seems that your default JVM is gcj. Open-Xchange is designed for Sun Java 1.5 - not for gcj and it will not work/crash on gcj since the compiler architecture is very different from "normal" Sun Java (aot compiler vs. jit compiler).
    To solve this issue please run
    Code:
    update-alternatives --config java
    and select Sun Java 1.5 from the list, if it does not show up in that list, please install it using
    Code:
    apt-get install sun-java5-jre
    Greetings

  8. #8
    ss300 Guest

    Default

    Hello Martin.

    update-alternatives --config java did a trick

    I did select Sun Java from the list and finished the install process without any problems. I will recommend to run that command to everyone prior to install just to be sure.

    This problem is solved.

    Thanks a lot for your help.
    Igor

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •